Why do I need ASPI?

As the title states…why do I need them?

ANd which version and where should I get them?
I know adaptec has them and ahead too…are they the same? Do I need to install both??

http://aspi.radified.com/
http://www.ncf.carleton.ca/~aa571/aspi.htm
http://www.nu2.nu/aspi/
http://www.snapfiles.com/get/aspilayer.html