Why do all my DVDs play choppy?

…on my Toshiba 1800 laptop. I’ve tried everything I can think of and I’m at my wits end. I installed latest codecs, latest display drivers but nothing seems to fix the problem. I’m running the latest version of VLC media player. Is the computer just too slow? (Pentium IIIE, 1100 MHz, 512 MB). Should be plenty fast enough but when I run the Aida benchmark it comes up third last for memory read (230 Mb/s). That can’t be good. Any ideas?

…one more thing I just discovered the CPU speed hits 100% (system monitor) soon after I start VLC to view a DVD. That’s when the picture/sound gets real choppy. Is this normal?

I had choppiness running VLC on a 2500+ Athlon. It was an early version a long while ago and I don’t know if they made it more leaner/stable. Anyway, try using AVS DVD Player http://www.avsmedia.com/DVDPlayer/index.aspx . It’s free and really easy to use. The software runs smoothly on the same PC I mentioned earlier, but it uses a lot more RAM (around 80 MB if I remember correctly) than PowerDVD 6.

No, it’s not normal… try the player that uses the least resources, probably powerdvd, and then if the problem still persists I would think you need to test your RAM, and then also possibly your burner/ROM.

tasteslikeburning mnrenfest?

I tried using AVS DVD player and DVDs won’t play at all. I tried PowerDVD and playback was worse than with the VLC player. I tested the memory with memtest86 and it gave no errors. I tried removing one of the two 256Mb memory cards and that no change. When I run Aida32 the memory read benchmark test ranges from 140 to 400 Mb/sec. I tried plugging an external DVD R/W drive and get the same choppy display and audio. The laptop is a P3 1100 MHz and should be plenty fast enough to view DVDs. Any thing else I could try?

Hi Steve -

It’s just an idea, but have you tried checking/enabling DMA for your drive?

The fact that you say your CPU hits 100% makes me think that might be the problem.

Hope it helps. :slight_smile:

Hi Steve, and welcome to the forums.

Firstly, what would be most feasible is to establish the cause of the problem to be softwar erelated, or hardware related. I suggest you copy an entire DVD to your HDD, and try to play the contents staright from there with a known software (in this case VLC) that has given choppy output before.

We can take it to the next step from there.

Thanks for the DMA suggestion Arachne. I checked and both the primary and secondary channels are set correctlt to ‘DMA if available’. I’ll try copying a dvd to the hard drive as Xtasydima suggested and see what happens when I play it.

ok, I used dvd shrink to save a copy of a commercial DVD on my hard drive and then I tried playing the movie from my hard drive. It seems to play a little better but is still quite choppy with the video stopping and starting and the audio sometimes losing sync as it tries to keep up with the video stream. I’m stumped as to what to try next.

Well, this helps us now because we know its not a hardware problem, we’ve just eliminated BIOS settings for Optical drives as well as the optical drive itself.

Since it plays, but not well, its seems to be resource avilable. Your specs do seem to meet the specs required to play a DVD smoothly. Perhaps an old Windows install… to much junk in accumulation over the years?

I would start by doing a system cleanup, erase all temp files, and temp files created from installs, try a registry cleaner, do a defrag (several times with reboots) until its like perfect, and also go throught he PC to ensure no dead programs are laying around. Check your virtual drive space (RAM alooted) , as well as free space on the HDD left to cahce to when the OS is running.

Will try thinking of more an dpsoting later, I am sure so will other members.

Thanks, I already tried reformatting the hard drive and re-installing XP. The virtual drive space is set by the system. This is starting to be a project!

Its most likely the DMA issue. I’ve had this same problem b4. Although in my case the solution was a new PATA cable for my drive. i.e. the drive slows down to PIO mode. Which is a little tricky to fix in a laptop. At least at the lamen lvl. Also, ur hardware settings shouldn’t just say “DMA if available” it should actually specify the transfer mode. If it doesn’t, u may be looking at the wrong port.

Good Luck - this was a real pain for me to fix (at least to work out the cause of the problem anyway) shudder

Thanx, I’ll look into the DMA issue and see what happens.

It works now!!! Thanks to OriginalGnome for the DMA suggestion. After reading a little bg on DMA I discovered that DMA doesn’t work on virtual memory. So I went to the the place where you can set virtual memory: Start menu, right-click on My Computer and tab to: Advanced Settings, select “Settings” under Perfomance and tab to: Advanced, select “Change” under Virtual Memory, select “No paging file” then hit “Set”. Reboot computer.
That did the trick for me. Thanx to everyone for all your suggestions. btw OriginalGnome, the DMA channel setting still shows “DMA if available”.

Glad you were able to fix it…but…um…you mean to say u disabled ur page file? o_O I thought Windows needs that. Or at least for performance anyway. Oh wells.

The pics below are for my HD and DVD-RAM/RW respectively.



I’m not sure what’s going on now. With the paging set to 0, dvds player fine for a few minutes then went back to being choppy. My DMA settings are similar to your screen shots. A lot of tec info on DMA talks about it being very finicky and can revert back to PIO mode after read errors. Anyways, back to the drawing board. sheesh!

Hi, i am having the same problem with my tsst corp ts-h652l, the firmware version is 0803. it will play all burned cds and dvds and play original dvds and cds but the sound and video is choppy. i have tried nero showtime, windvd, and media player 11, i followed advice in this thread and checked my dma settings, under 2 of the primary channel ide’s it shows transfer mode:dma if available, current transfer mode n/a on the last one it says the same except the current transfer mode is ultra dma mode 5, and in one of the secondary ide channels it says current transfer mode pio only, any ideas if this is my problem??? the ultra dma mode 5 and pio only show up under device 0

As stated before, if it plays choppy from the HDD, DMA is not a possible cause.

Have you tried to clean up the system yet?