Why can't my hard drive be accessed?

I just transferred an IDE hard drive from my old computer to my new computer. In my old computer, it was connected up as a Primary Slave data-only hard drive (i.e. No O/S on it). I connected it to my new computer as the Secondary Slave (the Master being the DVD drive). The Primary Master & Slave on the new computer are 2 IDE hard drives. When I boot up the computer, when it’s still in pre-windows mode, there is a message saying thus:

“Secondary IDE channel no 80 connector cable installed”

The slave part of the IDE ribbon cable (i.e. the one in the middle) is connected to this hard drive, as is the power cable connector. The jumper is set to slave. The IDE cable itself was a 40-conductor cable. And when I try access this hard drive in Explorer it says that the drive is not accessible.

I then swapped that 40-conductor cable for an 80-conductor one, and also swapped about the motherboard slots, so that the configuration now reads:

Primary Master = 120GB system HDD
Primary Slave = 80GB data HDD (the one with the problem)

  • both of them connected via an 80-conductor IDE cable…

Secondary Master = DVD-ROM drive
Secondary Slave = 80GB data hard drive

  • both of them connected via a 40-conductor IDE cable

No more error message at bootup about the cable. But, I still cannot access the problem hard drive in Windows.

Any thoughts?

P.S. on my previous computer, the hard drive in question was set up so as to be only accessed from one user account. I may or may not have restored normal access before I took it out. Could this be what’s causing the problem now?

P.P.S. the problem hard drive was a slave in my old PC

what version of windows? are you able to see the drive in device manager?

the 80pin connector is not aproblem it is telling you that the drive is not on an 80 pin cable so you wont get full speed from the ata100/133 drive

Windows XP Pro SP2, and the device is viewable in device manager and disk management.

It’s possible you may have to regain file ownership on the drive in question if it is formatted with NTFS.

First you need to disable Simple File Sharing if it is not already:

My Computer -> Tools -> Folder Options -> View tab -> Scroll to the bottom of the list of advanced settings and un-check Use Simple File Sharing (Recommended) -> Click OK.

Next go to the drive and right click on it and select Properties -> Security tab -> Advanced button -> Owner tab -> Select a new owner from the list and put a check in Replace owner on sub containers and objects -> Ok -> Ok

Yes! Thank you - that worked!

Nice… AND as FOR:

“Secondary IDE channel no 80 connector cable installed”

Install an ata133 or ata100 IDE cable, you are using an old thick IDE cable and this will slow down speeds as well as cause I/O delay read/write failures. The new IDE cables are very thin and have many more wires.

…cause I/O delay read/write failures

What do you base it on? Unless the cable is broken your statement is incorrect and as for the amount of conductors it’s 80 compared to 40 for the old ones as stated above.
//Danne

This is a possibility, it was part of my certification training by COMPTIA and also happened to my friend, coincidently, 3 weeks ago, and he went out and bought a new board without consulting with me first, instead of changing an IDE cable. It was a popup that came about near the system updates that said read/write delay failure. I found in my old books this can be a cause.

He feels bad now. :sad:

I didn’t say it will happen, I said it can.

Hope that helps!!!