Why can't I copy a CD this way?

vbimport

#1

Hi,

I’m a total newbie in CD/DVD copying.

Have got a RosettaStone CD that I need to copy/backup. Apparently, it is copy-protected.

I’m running Fedora 9. I basically want to know that if every ‘device’ is simply a ‘file’ on *nix (as is often touted especially when discussing the elegance of *nix), then why can’t I simply copy my CD/DVD (even a copy-protected one) as follows:

$ cat /dev/src-cd-device > /home/me/cd-image.iso

??

So far, I have tried:

  1. dd . It fails due to read errors.
  2. ddrescue: Please refer to this thread of mine: http://groups.google.com/group/comp.os.linux.misc/browse_thread/thread/63a4e3702d32ed2c/9b33aec294903b2a#9b33aec294903b2a
    (No complete solution yet.)
  3. cdrdao also does not work.
  4. The above cat command I have not tried because I am a bit afraid that it may cause some havoc to either my source CD or to something else on my system. I would issue the cat command above only after some assurance from some expert on this forum that it is absolutely safe.

I’m about to try Alcohol 120% (Windows) now to see if I can get some success.

Will greatly appreciate if some one can not only give me fish (in this particular instance) but also teach me fishing (by giving me reason on the why’s behind things).

Many thanks in advance,
/SD


#2

There are a few threads on ROsetta Stone CDs in the COpy Protection forum (in the software section on the forum mainpage), maybe they can be of help.