Which Linux distro do you use

No problem .

1 Like

We probably have a similar board… my previous main computer (which is now my backup (although the board is in a old Alienware case I got back in 2001)) is a Socket 939 CPU and is a ASUS A8N32-Sli Deluxe motherboard (which was the first PC I built in 2006 although I had desktops since 1995) and I flashed newest BIOS to it back around Jan 2019 as the motherboard was collecting dust from May 2012 (which is when I removed it from my main PC and bought a new motherboard/CPU/RAM(which is my current main PC(and recently upgraded to i5-3550 CPU)) until then but I had a old Alienware PC from 2001 and removed the motherboard in that and put in the A8N32 into it (I got a hold of a quality Seasonic 4xx watt PSU for only $2x.xx(as I reasoned worse case, if the A8N32 board dies I can always use that PSU on my main PC should my main PC’s Seasonic PSU fail(which is going on 8 years old this November)) and upgraded BIOS but I noticed with BIOS versions newer than a certain version(I don’t recall exact version from memory), the GPU Slot 1 fails to output video as it’s like there is no graphics card installed into it, but if you switch to GPU Slot2 it works (I tested Radeon 5670 512MB and a Geforce 7900GT 256MB(off the top of my head I know the Radeon does not work and I don’t think the 7900GT worked either in Slot 1 with certain BIOS)). but if your on a slightly older BIOS, both GPU slots 1 and 2 work fine. but at the time when I initially flashed the BIOS to upgrade and after a reboot, I had no display as I thought the BIOS flash went bad so I ended up paying like $10-15 for a new BIOS chip online and after I put that in, since it was also running a newer BIOS, the same thing happened and eventually I tried the Slot 2 and noticed it was good at that point so I put back in the old BIOS chip, and sure enough, it worked (then I flashed back to a older BIOS just to see what happened and sure enough Slot 1 is working again). so I did not even need to buy the BIOS chip in the first place but it’s odd a fairly major bug like that would exist. but at the end of the day… I just run the newest BIOS (which is a BETA) and use GPU Slot 2.

but anyways, that motherboard won’t work on Windows 10 but Windows 7 is fine but since Microsoft no longer supports it, Win7 is not a option. technically Windows 10 32bit will install but it’s unstable and Windows 10 64bit won’t even install as it says lacks ‘nx-bit’ which I assume is motherboard issue related (just does not have proper support etc) as I doubt it’s the CPU as that should work since it’s a AMD Athlon X2 3600+ 2.0Ghz dual core CPU (Socket 939).

but Linux Mint is perfectly stable on it but I am not sure how long it will last as even years ago when I pretty much retired the board in May 2012 (originally bought in March 2006) you can see it has a fair amount of swollen capacitors with some appearing to have mildly leaked. but the board is still stable to this day even though you can really see the age of that CPU setting in as while it’s still okay enough for general use, you can feel it’s noticeably behind CPU’s over the last 8-10 years or so as it seems like CPU’s over the last 8-10 years or so, still feel more current/snappy than not in their overall speed where as it does not take much to put a higher load on that 3600+ CPU when browsing etc. but, like I mentioned, worst case… that A8N32-Sli board dies, I can always use the PSU in my main computer should my main PC’s PSU ever die. I even upgraded RAM in it as it was like 2GB but I upgraded it to it’s max limit of 4GB (4x 1GB chips) for like $10 on Ebay back in Jan 2019. I suspect it will be a okay backup machine for general internet for at least some more years to come.

but anyways, that 3600+ CPU I mentioned I installed back in 2010 (mainly so I could run the PC game Mafia II (2010)) as the original CPU in it back when I built it in March 2006 is a AMD Athlon 3500+ 2.2Ghz single core.

years ago I ran the 3600+ CPU overclocked a bit (I want to say from 2.0ghz to either 2.2-2.4Ghz) but I figure at this point in time it’s not even worth messing with as I leave it at stock settings (i.e. 2.0Ghz)

p.s. at the time I build that March 2006 computer, AMD was ahead of Intel (for general use/gaming) but shortly after I got that, Intel released the core 2 duo’s in about mid-2006 and, to my knowledge, have not lost the speed crown ever since in terms of per core performance/gaming. but in more recent memory it seems like while AMD is a bit slower in per core performance on say gaming, it does not appear to be much and you can usually get additional cores for similar price range to a Intel CPU. so AMD’s CPU’s ‘might’ be overall better. but I have not looked into the details but this seems to be the gist of it.

1 Like

@NBR That build was for a computer that had the old Thermaltake Armour Case with 11 - 5.25 " optical bays and they were all full. I was a BenQ and NEC freak at the time and I couldn’t get enough of them. I just recently sold 54 BenQ, Plextor and NEC drives to someone in California, along with 2,000 pieces of Taiyo Yuden Media and believe me I was very happy someone wanted them LOL. I also built my first computer in 2005 era, and Wendy helped me get over the fear of actually ordering parts and putting them together. Then she patiently took her time and walked me through the whole build. I owe her a lot, if not for her, I think I might have been using an HP for the rest of my life LOL. But since Sandy Bridge I have most probably built 20 or more builds for myself, donated many more to our local school tech classes, and as for parts that either went unused or just bought them because they were on sale, I still have a whole closet full of stuff. The next thing to go are my old SSDs, I still some from the first batches of OCZ Vectors and others that I bought from the same era. Back then a 128gb ssd was the cats meow. Anyway nice reminiscing with you.

1 Like

IMO. The OCZ Vector is the best SATA SSD ever made.
Their power of keeping the NAND clean and therefore long term performance is unmatched.
They are so much better than the crappy TLC and QLC NAND based SSD that are available now.
I have 2x 256GB Vectors in RAID 0 that I still use to this day, Used as an audio scratch disc in my DAW.
They will easily maintain read/write speeds of 1GB per second all day long if required.

2 Likes

I have 2X 512s gb OCZ Vectors in my closets and havent used them since the m.2 came out, I know you are going to think I am lying but I have never had an SSD die on me. Ever. Everyone complained about OCZ and their horrible return rates, I never had to return 1 and I had plenty.

1 Like

A perfect time to take one of them out the closet, pop it into a PC and install Linux on it. :slight_smile:

1 Like

Damn, that’s a lot of drives.

I got into CD/DVD burning more back in the day but I pretty much only got what I needed, pretty much. currently I only have a total of 5 burners (2 CD(HP/Liteon), 3 DVD(two Liteon/one Sony)). even counting the earlier days (1998-1999, maybe a touch after) I had a couple of Memorex CD burners but I think I was exchanging those and never stuck with them (but I never had these two at the same time as I exchanged one for another as I believe I was getting buffer-underuns etc). so all-in-all maybe a maximum of 7 (but more towards 6) that I personally bought at some point. but I still have nearly everything I had lacking that initial CD burner I got in the old days from Best Buy.

I still have some (less than 100) Taiyo Yuden DVD-R (TYG02) media but nothing extreme like you had :wink: ; and the usual Verbatim DVD-R (less than 100 of them) and some MITSUI. I think I paid $50 for a 100 pack of these MITSUI CD-R’s back in the day as you can see they have a coating over the back of the disc. about the only thing I might use these once in a while for is burning a AUDIO CD. the DVD media I only use for family pictures/videos backup but even this I have been slacking and usually just opt for the simple/easy option of backups on two different hard drives (maybe a bit more) at the minimum etc.

but on SSD’s… I never was a early adopter of these as I only have two. a Samsung 850 EVO 250GB which I got in May 2015 (so it’s just out of warranty), which is on my main PC, and another Intel 545s 128GB which is in my backup laptop computer (it’s still under warranty). the Samsung I paid like I think it was $120 where as the Intel, without checking, I am pretty sure it was like $31.99 (give or take a little). now for around $120 tops I could get 1TB which would be nice but I am not getting enough of a upgrade to justify the costs which is why ill likely continue with the Samsung 850 EVO 250GB for the foreseeable future. I know the older ones had different memory as some dislike TLC etc but I figure anything MLC/TLC should last a long time. but I noticed with some of the newer ones which have worse than TLC stuff, since the SSD’s are generally larger in size it helps offset the lack of total writes to it etc.

but at the time I bought my Samsung SSD that was around the time you could get decent sized SSD’s for a reasonable price. much before that prices were too high and drives where too small in size (I am of the mindset that for a person who’s going to use their computer a 250GB is THE minimum I suggest. although nowadays 500GB range is probably much safer) and I imagine general reliability was a bit suspect to.

1 Like

Well so far Mint v20 is looking more negative than positive in comparison to v19.3…

like on my laptop while things install fine and appear to be okay loading up ‘xfburn’ and trying to burn a ISO fails as it won’t even attempt erase/write to the drive and throws a “Burn mode is not currently implemented.” error.

but on my main PC, at least as far as using UEFI mode, after installing Mint v20 and it boots up there are no hard drives visible in the file manager etc like usual and insteady shows ‘efi’ ‘filesytem root’ etc. even powering off and back on does nothing. then when trying to boot to the USB card reader which has a 4GB SD card in it, which is what I used to install Mint v20, after Mint v20 was already installed in regular mode (not UEFI) it just hangs with a cursor there etc. so I said screw it and restored my Clonezilla image of v19.3 and everything is as expected once again.

another thing I noticed that Mint has a issue with in general is… during install when you select to wipe the SSD and install it clean, if you have other hard drives installed, which I do, it seems to want to put the grub2 etc junk on one of those instead of where it should be which is on the main boot SSD drive like it’s supposed to be. I think I found away around that, but even if I did, the damn thing does not see my hard drive which is a show stopper.

so at this point in time… I might try one more time booting from the card reader with the SD card in it with Mint v20 on it but in regular BIOS mode, NOT UEFI mode and see if that fairs any better. if that fails I am probably going to attempt a DVD+RW install as I am currently using Clonezilla my Mint v20 install on the laptop and then going to restore Mint v19.3 image I created a bit before I did the Mint v20 install and hopefully my DVD+RW burning works as expected with ‘xfburn’ as then I can attempt using that disc to install on my main PC by temporarily connected a external device to one of my internal DVD drives just for the installation. I got another option which is to use the USB stick I got YUMI on which allows me to boot from multiple ISO’s. but I suspect ill just try the DVD option first as it’s less likely stuff will act up.

so I am not out of options to try yet but it’s a pain in the butt and the Mint team definitely needs to make it so that the grub bootloader installs to the main boot drive by default (like the one you install the OS to) which it currently does not and I have to use workarounds to get it to do that.

p.s. but worst case scenario… assuming this v20 release does not like my main desktop computer, I might have to wait until Mint v21 and hopefully that won’t have these weird install issues of not seeing my hard drives etc. because it looks like it will be about 2 years before Mint v21 is released looking at the past release pattern and Mint v19 is supported til April 2023. hopefully Mint v21 does not have these weird issues.

EDIT: Yep, after restoring Mint v19.3 on the laptop, burning the Mint v20 ISO with ‘xfburn’ starts burning as expected. ill probably look into using that to install the Mint v20 OS on my main PC and see if that fairs any better. because I kind of assume CD burning is broken on Mint v20 from the looks of things. but on my main PC, while a Sony Optiarc 7240S burner is installed, it’s not connected to anything as all of my SATA ports are in use with SSD/HDD’s. so if only DVD burning is broke on Mint v20 I can probably get by with it. but who knows, I might just say screw it and stick with Mint v19.3 for a while. but at the same time I just want to see if I can get Mint v20 installed where it can see my hard drives as if it does that I suspect most of the general stuff I so will probably work.

It’s strange that different hardware can upset a modern Linux distro.
I blame the UEFI implementation on older hardware, and generally you wont be able to download a BIOS update to fix it.

As I understand it. There is an workaround for installing any ubuntu 20.04 based distro.
Assuming your HDD has GPT partition table.
Go to your BIOS and in the Boot section enable CSM
Install Mint and update it.
Install the NVidia GPU driver.
Restart and go back to your BIOS and disable CSM
Mint should now be fine.

Alternatively if your 19.3 install is fine, and a clean install isn’t a must. Wait until the official 19.3 to 20 upgrade is available in your Mint updater tray app. It should be available early July.

I can’t comment on MInt 20 ability to burn optical media, as its something I no longer use.
I do have an LG USB3 BD drive I could connect and try if I get a chance later.

Well after messing with things some more (I have not read your comments until just now though) I noticed if I remove the three regular hard drives I have (all are EXT4) and install the Mint v20 OS, it installs fine (on my Samsung 850 EVO SSD) and after reboot things function as expected as I can insert a USB stick and it works as you can see it in the file manager. but as soon as I power down PC, connect my three hard drives, and power it back up as soon as I get to the desktop I can now see some folders that should not be there… ‘efi’ and ‘Filesystem root’ and, as usual, I can’t access my hard drives through the file manager as normally one can. but if I do a ‘lsblk’ from terminal, it does see the hard drives like sda1/sdb1 etc(so this appears okay here). so currently Mint v20 is not a option as not even being able to access the hard drives is a major issue. but as soon as I restore my Mint v19.3 install with Clonezilla, everything is working as expected. so while I am only one person, Mint v20 is quite out of whack as I am surprised things turn out this badly as the not being able to burn a DVD is one thing with xfburn, but not being able to access ones hard drive is a show stopper/major issue.

another thing is when I boot from my bootable USB media (SD card reader with a SD card (I even tried DVD+RW with basically same results)), of which I even verified the integrity of the install data(it gives you a option before the install to check this), whether it’s standard boot or UEFI, upon initial boot it does see the hard drives in the file manager like expected. but after the install and once I reboot is when things get all out of whack like I described above.

weird ain’t it? ; any suggestions?

p.s. but given my impression here, if a clean install is that bad, I can’t imagine a upgrade is a good idea either. hopefully a worst case scenario is Mint v20 is shot and I can wait 2 years, which will be only mid-2022, and hopefully Mint v21 will be okay since I can continue to use Mint v19 series til April 2023.

Not really much I can add.

Both PC’s here have no problems installing or running Mint 20.
All my partitions are GPT but I wouldn’t have thought that should make a difference.

When you’re booting from USB before installing Mint. In other words the ‘live’ Mint desktop. Does all your HDD’s show?

Also, what happens in Mint 19.3 when you install and use the 5.3 kernel? If I recall correctly you were using a 4 series kernel.

I recently tried Ubuntu Desktop 20.04 and did not really like it. And running Ubuntu directly from DVD was slow.

Painfully slow i would imagine. :slight_smile:

Yeah, as it does seem like a odd issue as it’s a show stopper issue but it’s surprising a bug like this would be in the OS.

p.s. it’s kind of funny though… earlier in this thread you had 2nd thoughts about Mint v20 and eventually warmed up to it, where as early on I was saying good stuff about Mint, but after trying it I now have doubts about it. funny how stuff reverses like that :wink: ; but my opinion of MInt v19.3 with 4.15 kernel is rock solid.

Yes, that’s the odd thing… during initial boost from the live desktop (Mint v20-Cinnamon), the hard drives show up as normally expected. but as soon as you install the OS and reboot, so it’s running from SSD (and no longer the live desktop), everything is out of whack with the ‘efi’ / ‘Filesystem root’ folders on desktop which can’t be removed and should not be there in the first place.

but like I say, if I disconnect all of my other hard drives (which are EXT4 format) besides the main OS install SSD, install the OS and reboot, everything works as expected as I can connect a USB thumb drive and it reacts like is typically expected on Mint. but if I shutdown computer, connect my hard drives again, reboot, the issue comes up with the ‘efi’/‘filesystem root’ folders on desktop and drives are not visible in the file manager. but the ‘lsblk’ command from terminal does see the hard drives are connected.

I even tried Mint v20-Xfce and it reacts similarly but on the live desktop it does not even show any hard drives connected in the file manager even though the OS does seem them with the ‘lsblk’ command in terminal.

so I guess at this point my only options are to either attempt the upgrade (which according to the Mint team will probably be about mid-July when they release official instructions on how to upgrade to v20 from Mint v19.x) or wait til maybe Mint v20.1 in about 6 months from now and see if that fairs any better as I think if not, the entire Mint v20 series will probably be shot. or come to think of it… maybe after some months pass, there might be a different kernel available and I could try that just to see if it’s any better. just some random thoughts… makes me wonder if it’s some bug on the Mint teams end or is it a bug on the Ubuntu 20.04 LTS base or maybe my computer does not like the 5.4 kernel etc(?).

Yeah, I am using the LTS v4.15 kernel on Mint 19 which I recommend everyone use unless their hardware is too new since it’s a LTS kernel and supported the life of the v19.x series which is until April 2023 where as if you use the others you will be forced to upgrade the kernel here and there as the previous ones expire and are no longer supported.

I suppose I could try the 5.3 kernel but Mint v20 uses 5.4 and right now the kernels available on Mint v19.3 are… 4.15/4.18/5.0/5.3/5.4. NOTE: a clean install of Mint v19.3 defaults to kernel 5.0 (I think they did it so it has more updated hardware support) but one can switch back to 4.15 series, which I suggest if your hardware is supported, as you can basically… install 4.15, reboot and either hit esc/hold shift and then select the 4.15 kernel, after OS loads, remove all kernels newer, then reboot and you should permanently stay on 4.15 series.

I guess here is another stretch… like after initial install and I reboot, how things are out of whack, there is a kernel update (still of the same 5.4 series though), but I never bothered to try it. might be a small chance running updates helps(?). but at this point I might hold off on v20 series for a while, at least until a possible upgrade attempt or I might wait until v20.1 is released about a half year from now.

but I may consider making a report on the official Mint forums soon just to see if they can narrow things down a bit. because if what I experience is not common(or more on the rare side), there is a good chance it won’t be fixed if I don’t report it.

Yeah, I am not 100% sure but it does seem like booting up to desktop after OS is installed is noticeably slower on Mint v20 (with kernel 5.4) vs Mint v19.3 with 4.15 kernel.

so right now my opinion of Mint v20 is so-so, but Mint v19.3 (with 4.15 kernel) is rock solid.

This would suggest to me that the native UEFI drivers are not present in the BIOS.
This is not uncommon on older hardware, from what I’ve read.

From what I’ve read. To stand the best chance of getting a working installation of a ubuntu 20.04 based distro, is to make sure the following is set in the BIOS when you boot the live media.

  • CSM (compatibility system module) - Enabled
  • Fast Boot - OFF
  • Secure Boot - OFF

Once you have the system installed and working.
Update the system
Install NVidia driver.
Reboot and make sure all is well. Then you can re-enable CSM and Fast Boot if you wish. Secure Boot should be left OFF for Linux.

My opinion is the ubuntu 20.04 ‘base’ is crap. Out of 6 or 7 distro’s I tried based on unbuntu 20.04. Mint 20 is the only one that works and doesn’t screw up this PC. I don’t think kernel 5.4 is blameless either. Compared to kernel 5.6 and 5.7 in Manjaro, 5.4 is buggy and sluggish.

I’ve been using Manjaro 20.03 (community Cinnamon edition) for a few weeks now. The Cinnamon version because I’m familiar with the desktop environment, and like it.

In terms of performance when compared to Mint. Manjaro is miles ahead, and is just as stable for me.
The only downside is this edition doesn’t come with Libre preinstalled and comes with the Office 365 wrapper instead. It’s hardly a difficult task to install Libre from the Manjaro app store (package manager).

You would also have to install the flatpak and snap plugins as well if you want to use these packages from the package manager. Again, hardly a big task. AUR (Arch user repositories) plugin is pre-installed, and only requires you enable it from the package manager.

dde

The reason I asked is.
If later kernels are causing a problem with your system. Moving forward is going to be a task with Linux.

From the top of my head. Manjaro incidentally allows you to use a 4 series kernel. But I’ll need to confirm this.

EDIT: Yes Manjaro allows a 4 series kernel.
Here is a list of the available kernels.

PS I seen your thread on the Linux Mint forums. At least I assume it’s you, unless someone else has exactly the same problem.
Let’s see what they can do for your problem there.

I should have mentioned, if this matters… when booting from the USB card reader to do the OS install I can choose regular boot and UEFI when selecting the specific device (shows two entries for it, one regular and one UEFI). it does not seem to matter which one I choose as the end results are the same, the hard drives not showing after OS is installed and I reboot.

would it still be worth seeing if there is a specific entry for CSM (compatibility system module) knowing this? ; I bought my motherboard in May 2012 so my guess it’s probably around 2011 when it was made, give or take.

Even if all of that is great I suspect my password manager is not available for Manjaro. because my database I used on Windows for years works fine on the Linux version of it. but I suspect there is no Manjaro version. so leaving Ubuntu (and the like) based Linux distro’s is probably not a real option for me.

Hopefully it’s not or just some weird version. but the version of Clonezilla I am using, which is the most recent stable appears to be using “Linux kernel was updated to 5.5.17-1.” and that see’s my hard drives fine for whatever this is worth.

but lets say I try installing kernel 5.4 on Mint v19.3-Cinnamon and that works… that would be proof the kernel is not at fault, correct? ; so if that’s good I would imagine it’s something else.

Yeah, it’s me.

CSM is part of the UEFI specification, so it should be present. It will normally be located in the Boot menu of the BIOS.
When CSM is enabled. It doesn’t insist than a native driver is offered to the OS. Therefore allows the OS to choose and configure the hardware.

Regarding the UEFI boot option on the install media.
If you have a GPT partition on the OS drive and UEFI BIOS, then the UEFI option should be used.
Mines wont boot at all if I choose the non UEFI version.

Regarding the password manager. The only one I can think of that works across Windows and Linux is Keepass, which is the one I’ve been using for years. If it’s Keepass then its available from Manjaro (all three versions). If not, let me know what it is and I can check for you.

Ill have to reboot fairly soon and check this stuff out (and while I am at it ill probably image the HDD and try the 5.4 kernel on Mint v19.3 to before attempting the Mint v20 install once again with the CSM tweak). hopefully that works though :wink:

I am using Password Safe (originally by Bruce Schneier) as the official website is pwsafe.org ; I am using the .deb file to install the newest Linux release which is currently v1.11 released not all that long ago… https://sourceforge.net/projects/passwordsafe/files/Linux/ ; I have been using that basic password manager for probably around 15 years or so, more than 10 years for sure.

but Password Safe is in the Mint repositories as in the software manager as you search for ‘passwordsafe’ ; the one you get by default in the Mint v20 repository is v1.08.2 BETA (which is from Dec 2019) which was the release just before a stable v1.09 release not all that long ago in Feb 2020. but the newest one is v1.11 released in June 2020. the Ubuntu20 works on Mint v20 as I tried it when I had Mint v20 on my laptop (but that laptop is currently back on Mint v19.3 since it works with DVD burning unlike Mint v20).

p.s. there is even a mobile version but I don’t really mess with smart phones much and I don’t trust them in general since they ain’t as secure as a proper computer is. smart phones are okay for doing something simple real quick but that’s about it.

You would have to compile a 5.4 kernel for Mint 19.3, as I believe 5.3 was the latest official version.

Here is what the Manjaro package manager offers when search for password safe.

There is also several github versions as well from the Manjaro AUR repositories.

Here is a link to one of the github versions.
https://pwsafe.org/

edit: Here is github version installed on my Manjaro. I don’t have a database to open.

passwordsafe

I am currently on 5.4 kernel in Mint v19.3-Cinnamon as I just installed it and rebooted and nothing appears out of whack. so given this info, must be a issue with Mint v20?

what’s shown in the ‘Update Manager > view > Linux Kernels’ are… 4.15/4.18/5.0/5.3/5.4. 5.4.0-40 is the newest one available on Mint 19.3-Cinnamon.

also, I checked my BIOS under the ‘boot’ tab (I have a ASUS motherboard) and nothing specifically mentions CSM but the only thing of interest I see is ‘PCI ROM Priority’ which defaulted to ‘Legacy ROM’ but one can choose either ‘Legacy ROM’ or ‘EFI Compatible ROM’. I did not change anything at the moment. but some basic text the BIOS has in relation to that specific setting, it says, and I quote…“In case of multiple option ROMs (Legacy and EFI compatible). specifies what PCI option ROM to launch”

anything of interest to you there? ; because if not I definitely don’t see anything else that looks interesting.

It looks exactly like mine does. I assume that was installed from a official source?

p.s. also, to say it again on Mint repositories, I specifically searched for ‘passwordsafe’ (exactly like that without the ') and it shows a total of two entries but one is some generic crap where as the other is the official one.