Where do I buy a lite one compatible with the new fimawre for xbox 360

vbimport

#1

just got a brand new Asus DRW-24B3ST version C 1.05 with the intention to cross-flash to a liteone Ihas , so I can back up my xbox360 games , I did some research and I guess I need the version 1.04 of the drive , what are my options now ? can it be flashed ?

if not where do I buy for sure a lite one driver that is going to work with xbox ?
thank for your time


#2

One post of the same topic is enough.
Crossposting (i.e. posting the same more than once) is not rules compatible.

Thread closed.