When I launch BlindWrite Sute 4.24, it always shows "Stack Overflow"

Blindwrite Suite 4.0.6.45 can run on my machine without any problem. But after I upgrade to the newest version 4.24, it always shows “Stack Overflow” when launching it. Why?

My OS:Win98
My CD Recorder:Samsung SM-316
Installed ASPI Layer: Adaptec 4.7 and Patin-Couffin internal version 5

Hi you seem to have a problem during the installation you should have the patin-couffin drivers version 10.

please check your hardware control panel and remove entry of vso-patin-couffin.

try to uninstall / install… to be able to have the right version of the drivers V10

Thank you for your reply.

First, I uninstall the BlindWrite Suite
Then, I open control, click vso-patin-couffin, click remove to remove entry of vso-patin-couffin
After, I reisntalled the newest BlindWrite Suite
After rebooting, I open control to check the versioin, it shows “patin-couffin engine ready and active internal version 10”

But the problem still exists. It shows “Stack Overflow”.

How should I do?

Thanks!

what you should do is update that os

its frightnenly old hehe

go for win2k or winxp pro the home version sucks :Z

I need a high detail report, about what you do, step by step to obtain the error, using which cd etc… do you have directcd installed ?

If this is your problem then here is a fix:

SYMPTOMS

When you are running Windows 95 or 98, you may receive the following error message:

Stack Overflow: There are no spare stack pages. It may be necessary to increase
the setting of ‘MinSPs’ in System.ini to prevent possible stack
faults. There are currently <nnn> SPs allocated.

CAUSE

This error can occur when Windows 95 or 98 encounters an internal overflow of the stacks used by 32-bit Windows device drivers. Please note that this is not related to the “Stacks=” line in the Config.sys file, which is used for 16-bit MS-DOS device drivers.

Stack overflow conditions are indicative of errors in the device driver. Device drivers are allocated 4 kilobytes (one page) of space to be used as a stack. If the device driver uses more than 4 kilobytes of memory, a stack overflow condition occurs.

Windows 95 and 98 sets aside a number of extra memory pages (spare stack pages) to be used temporarily to prevent a system “crash” due to a stack overflow condition. When the stack overflow condition has passed, Windows 95 or 98 reclaims the temporary page. The default number of spare stack pages is 2.

If Windows 95 and 98 detects that it has run out of spare stack pages, the warning message stated above is displayed. Windows 95 and 98 continues to operate normally unless a device driver encounters a stack overflow condition when there are no free spare stack pages.

RESOLUTION

To resolve this situation, add the following line to the [386Enh] section of the System.ini file and then restart your computer:

MinSPs=4

YOu get there by using run and putting in sysedit. Then go to system.ini. Put this in exactly MinSPs=4 in last line under [386Enh]

If the problem persists, increase the number of spare stack pages by 2 at a time until you have 12 or so. Reboot after each one.

NOTE: Each spare stack page requires 4 kilobytes of memory.

Thanks for all kind help.

I installed Roxio CD Easy Creator 5, but didn’t select directcd to intall (It can’t be installed with my cd recorder).

Below are some detailed info

OS:Win98 with IE6 sp1
CD Recorder:Samsung SM-316B e303
CD-ROM:SHARK 48X CD-ROM YHJ2
Installed ASPI Layer: Adaptec 4.7 and Patin-Couffin internal version 10
burner software I am using on my computer: Nero BurningRom 5.5.9.17, CloneCD, Roxio CD Easy Creator 5, CDRwin 5
Virtual CD: Daemon Tools 3.26

  1. I open control panel, open Add/Remove Promgram, select BlindWrite Suite, click add/remove to uninstall it, then reboot
  2. I open control panel, open “patin-couffin configuration”, click “Remove” to remove vso-patin-couffin driver, then reboot
  3. I reinstall the BlindWrite Suit 4.2.4 with default options, then reboot.
  4. I click BlindWrite Suite icon on the desktop to launch it
  5. No matter I choose BLINDREAD or BLINDWRITE, it first shows " STACK OVERFLOW", then shows the Wizard interface
  6. No matter what I choose, it doesn’t work expect the “Exit” button.
  7. I open control panel, click “patin-couffin configuration”, select VSO DRIVER, click “Test”, it shows

“Patin-couffin” engine ready and active
internal revision 10

Patin-Couffin Engine
0:0:0 - ROXIO CD-ROM EMULATOR 1.02
0:0:0 - SAMSUNG CDRW/DVD/SM316B E303
0:0:0 - SHARK 48X CDROM YHJ2
0:0:0 - Generic STEALTH DVD

If I uninstalled BlindWrite Suit 4.2.4, but didn’t remove patin-couffin driver internal version 10, then reinstalled BlindWrite Suit 4.0.6.45, it can work fine.

BTW, I have added MinSPs=12 in last line under [386Enh]. After bebooting, it looks to seem of no use.