What's up with Alcohol 52%?

vbimport

#1

Ok, I installed Alcohol 52%, since it’s free, supports a whole bunch of image formats, and the virtual drives work well alongside programs like IMGBurn. But…

I can no longer use the virtual drives, anymore. When I try to open up the Alcohol control program (or whatever you call it), it gives me an errer: “Loading alcohol device drivers failed! Emulation optoins and native driver interface of Alcohol 52% will not be available!”

So, I tried downloading the setup program from Alcohol’s website, hoping maybe I could reinstall the software. But instead, I got this message: “Internal Setup error. Contact Support”. WTF?

I have the latest SPTD drivers installed (and I tried removing them, and reinstalling them, but that didn’t help), I don’t have a Dell, neither do I have that Broadcom Trusted Platform Module software, either. Help?

PS: the only Firewall/Anti-Malware software I have currently installed is Comodo Internet Security Premuim. IDK if that will help.


#2

Update: I found a program on Alcohol’s forums that (I assume) does a better job of removing the STPD than Dupex Secure’s software. I tried that, rebooted, reinstalled SPTD, rebooted, and now it seems to have no problem with the “Default Device Control Interface” Problem solved, right? [B]WRONG![/B] Now, there are no virtual drives listed. When I try to create new ones, it says “Unable to add adapter”. I assume it means the SCSI adapter, to which it connects the virtual drives? Any Ideas?


#3

Please try to disable D+ defense in Comodo.

Also have a look here:
http://support.alcohol-soft.com/en/knowledgebase.php?postid=31003&title=Installing+Alcohol+with+Commodo+Firewall
http://support.alcohol-soft.com/en/knowledgebase.php?postid=30925&title=Alcohol+and+Commodo+Firewall


#4

Yes, I did that as soon as I installed the software, as I generally find sandboxing annoying.