Whats the difference between philips dvdr1640k and DVDR1625K?

vbimport

#1

whats the difference between philips dvdr1640k and DVDR1625K??
the 1625 is much cheeper but whats the difference in hardware??
thx


#2

hello??
nobody who knows it??


#3

Hmm… as far as I know… 1640K = 1620K + MPEG2 encoder (I don’t think it’s really useful because you can get DVD Shrink for free) + 1 blank 16x disc IIRC.
1625K and 1645K = 1640K and 1620K… but they have the new P3.0 firmware out of the box. Internal they are all the same drive (Philips 1640P). I have Philips 1620K.
So I guess you should go for the 1625K if it’s cheaper.


#4

Are you sure? Because the 1625K/1645K supports 8x DVD+RW and 6x DVD-RW according to various webshops:
http://www.geizhals.at/eu/a137138.html
http://www.geizhals.at/eu/a137119.html
According to a post here there will be an official firmware update for 1640 -> 1645.

I haven’t seen any official info about the 1645 or any firmware updates though…


#5

Yes I belive I’m right…
According to the post you posted “The Philips 1645K uses the same hardware as the 1620 and 1640. These can be (officially) upgraded with the new firmware.” and also someone has bought 1625 and posted that it’s the same as 1620/1640 but with P3.0 firmware. =)


#6

http://club.cdfreaks.com/showpost.php?p=822717&postcount=182


#7

Hi all

I AM going to purchase a Philips DVDR1625K/30 retail, but after looking at the links above I am unsure about the firmware 3.2 update as there is no mention about it updating the /30 there’s a /35 but not a /30.
Has any one got his drive and can it be updated with the latest firmware I’m a bit worried about no mention of that /30 on the end and what it stands for?

Many thanks

Andy


#8

Just try it… the flasher is smart enough to prevent you from flashing to a wrong drive. However I think you can flash the firmware to all the drives that identify themselves as Philips 1640P… no matter if it is 1620K, 1625K, 1640K or 1645K… and no matter what it says after. /30, /35, etc might just be drive revisions I guess. But the core of the drive itself is the same.


#9

Hi Quikee2

So the drive then becomes a 1640 or it stays a 1625 but with the new firmware?
Is there bitsetting for R, DL and RW media?
Also is there any problems with backing up and compatibility playing my Ps2 games I have heard the Benq has problems with -r? I use Datasafe media Ritek04?
And do you know of a good review for the Philips DVDR1625K/?

Many thanks

Andy


#10

Does any one know any of the answers to my questions above as I need to replace my Pioneer A106 today? :bow: :bow: :bow:

Thanks

Andy


#11

Yes their is bittsetting for +R/RW/DL

You shouldnt have any trouble with PS2 backups with DVD-R as long as the discs are of decent quality if you have a v5 or higher PS2 it can read DVD+R/RW discs also.


#12

Thats good news, my PS2 is the V5 I will pick a DVDR1625 up later from a local shop. Thanks 8T8 and every one else for your help.

Andy


#13

Hi

Just read the review on the DVDR1640P at http://www.cdfreaks.com/article/152/1 and it shows in Nero InfoTool under supported features that it doesn’t support C2 errors and I thought it did, does this mean that the DVDR1625K won’t support it eather?

Thanks

Andy


#14

Well because DVDR1625K is only selled by this name actually all… DVDR1620K, DVDR1625K, DVDR1640K and DVDR1645K are all identical drives also know as DVDR1640P (the name of the drive identifies itself in windows)… so Yes… C2 is not supported in any drive.


#15

How important is it to have a writer that can support C2 errors because it looks like the LG GSA-4163 writer can?
What are the pros and cons of this?

Thanks

Andy


#16

Just purchased the Philips DVDR1625K and so for I am very pleased it, its come with F/W P3.0 and its made in Malaysia.

Thanks

Andy


#17

I just bought a 1625K today and did a straight swap with my old DVDRW but I haven’t been able to get it to work.

1st boot after installation was OK, found new hardware etc, requested a reboot and then it continually tried to reboot. On just 2 occasions it has booted all the way.

I checked the jumpers and its set to slave like my old drive.
I can’t access the BIOS during bootup using DEL. In fact, sometimes the boot screen mentions ‘ESC’ as well as ‘DEL’ but with no explanation of what for (and it do anything anyway)>

I’m not a hardware genius - have I done something stupid? I’m mystified because it has actually booted a couple of times so something must be correct, what could be causing the intermittent failure? Are there any known issues with this combination?

I’m using a Gigabyte GA 7VAXP Ultra F4 and Athlon 2600


#18

You are probably running WinXP SP2 on your nForce4 motherboard. There is a bug in pre-3.6 firmware which will cause rebooting when you try to access the drive on this setup :slight_smile:
Boot up in safe mode, then flash immediately to 3.6. Your problem should be solved.