What to do when flashing a BIOS goes wrong?

vbimport

#1

Ok, I’m a complete Newbie - just got a Willem programmer in the mail yesterday, and figure that you folks must have a LOT more experience with this stuff than me. I’m stuck, so I’m hoping you might be able to help me figure out if my chip is trashed, or if perhaps I’m just not doing something right. I just got my programmer in the mail yesterday, so it could easily be either.

Here is my situation: (relates to a Biostar M7VIT Pro motherboard, which is in our primary PC downstairs)

About 10 days ago, my primary PC started acting strange. First, the onboard sound went out. I checked all the audio connections. Then I uninstalled and reinstalled the sound drivers. After that, I deleted the partition on the hard drive, made a new partition, formatted, and reinstalled Windows XP. Same problem. This all started after adding a new IDE hard drive. I had already been having occasional problems with having to turn the PC on twice sometimes in order to get it to boot. (I’ve been told the power supply probably was having problems, and have ordered a new one now) Anyway, at the time I thought that perhaps the BIOS got hosed. I went into the BIOS and used the flash utility there to update the BIOS with a file from the mboard manufacturer. Then, the system wouldn’t boot any more. Using the AwardBIOS flash utility v 8.26G, I was able to do some sort of basic boot, with a message “boot block” something or other, and then it would let me get started flashing the BIOS. The system would always hang then, showing the status bar, as if it was going to flash, but nothing else would ever happen.

I figured that perhaps my BIOS chip was hosed, but wished there was some way I could at least try to flash it independently of the system. That was when I found out about the Willem programmer.

I bought an “Enhanced Willem Programmer”, Ebay item # 3000 7861 4693, recently. This model is available on mcumall.com, product 3082. I am unable to determine exactly which model it is. Distinguishing features are:

A) parallel port data hookup
B) power is provided by USB hookup only. USB power connector is right next to the parallel port
C) Built in FWH/LPC, PLCC32 & P28F002BC adapters on the card

Still, even with that information, I can’t seem to figure out from any of the documents online exactly which version of the Willem Programmer this is, which is becoming annoying. The Ebay auction also doesn’t refer to any specific hardware version.

Anyway, here are the details on the BIOS chip I’m trying to reprogram. It is a PLCC32 that originally had an “Award” sticker on it. I removed the sticker, and underneath it said “AMIC A2900s1TL-70”. Evidently this is a 256K 70ns 20ma 8-bit 5 Volt CMOS. From what I can tell, the programming software refers to this as "SST PH29EE010. I have no idea why this wouldn’t be under some sort of “PLCC32” menu, to make it easier for newbies like me to figure out if we were doing the right chip or not.

Ok, so I hooked up the programmer. I made sure the parallel port on my secondary upstairs PC was set to bi-directional in the BIOS. (My BIOS has choices of EPP, ECP or “Bi-directional”. I have to assume that the “bi-directional” corresponds to the “both” setting I’ve seen in some other BIOS settings)

I made sure that the data cable and USB power cables were secure on both ends.

I loaded software 97ja from included CD.

I then double checked to be sure that I had inserted the chip into the PLCC32 socket, and not the incorrect one

I tested the Willem board, and it tested ok

I was unable to erase the chip, and every time I tried to program the chip with a BIOS file, it gave me the message:
“error: write sector 0”

I therefore uninstalled software version 97ja

Then I downloaded and installed Eprom prog .97g

I chose SST PH29EE010

Double checked jumpers (3, 5, 6, 10 & 11 all on, rest off)

set sector size to 256 (also tried later at default 128 setting)

clicked “disable software data protect”, & verified that I really wanted to do this

erased the chip - got “erase completed by check DQ7” message

blank test gives message “device is NOT Empty $000000” (although once I did get verification that it was empty - yet an
immediate test afterwards again said that it was not)

trying to program chip with any of the official BIOS file downloads from Biostar gives message:
“Error: Write sector 0” I get this consistently.

So, I haven’t really made any progress. At this point, I still don’t know if I’m just doing something wrong in my programming procedures, or if the BIOS chip may indeed be messed up to the point where it won’t accept a flash.

I’m stuck. If anyone can suggest either:

A) a procedure that I might be doing wrong

or

B) a source for an inexpensive AMIC A290021TL-70 BIOS chip

Either would help me get a bit further in my troubleshooting. If this chip is really bad, I guess my only option is to try flashing a known good chip. I’ve heard that these chips are available for under $2 each.

Our PC downstairs was our only “TV” in the house, so we have been without TV for about 10 days now, and will continue to be until this is resolved. My wife is missing her favorite show “Jeopardy”.


#2

I hope you didn’t pay a whole lot for that programmer. I think you could’ve just bought a new motherboard to solve your troubles considering the price of the flasher plus a new bios if you needed to buy one. Have you tried getting a new bios chip here http://www.biosman.com/