What to do next

vbimport

#1

I have a wh12ls39 and I downloaded the core and main firmware from post #1707. I then updated the main firmware download with mediacodespeededit to increase the speed only. My question is can I use Devilclaw as my next step to flash the drive or do I have to dump the drive’s firmware first?

Thank You Bob H.


#2

For safety sake I would dump the main and core firmware from your drive, and put in a safe place. it only takes a minute or two. What you downloaded could be corrupted.

See my post # 1753 in the MCSE thread.
Use the flasher utility to

  1. verify drive ID number
  2. flash the main modded firmware
  3. turn off system, turn off PSU and unplug. Wait a few minutes, then plug back in, turn o PSU and boot.

#3

Did all the things you said. Went to flash the modified firmware, it starts to do the flash, then it says Falloc and says it could not open the bin file.I’m stuck at this point.

Thank You Bob H.


#4

I don’t know what any of the error messages mean.
You may have to send PM’s to ala42, cvs or wait for additional help from some of the other posters in this thread.

Does your drive otherwise still work?

If so you may want to try again, this time using the main.bin you dumped using the flasher utitily that you saved to a safe location and use MCSE on it.

I am assuming you at least did the dump successfully so you must how to use the flasher.

The tricky part is to NOT make any typos and to have the complete path.
I copied the flasher utitliy and my speedpatched.bin to the root drive (i.e. C:) to make it easier to type. at the CMD prompt, I did a ‘cd C:’.

Assuming you correctly dumped and generated a main_speedpatched.bin, you would type this at the CMD prompt (with the correct path, etc., etc.,)

Flashes drive with new firmware:
flasher -d [Drive ID] -f firmware.bin

where d is the drive ID (without the brackets), and substitute the complete filename of the speedpatched.bin for ‘firmware.bin’.

I hope I did NOT insult your intelligence.

Regards

flasher instructions.txt (2.95 KB)


#5

All it did was try and open patched.bin as if that was 1. The drive works fine, I’m just trying to increase the speed. I put the flasher and files on my D drive in a folder called flasher. At the command prompt I type in D: then
flasher\flasher -d 1 -f patched.bin
I lost my intelligence a long time ago.
This is really getting to me.

Thank You Bob H.


#6

OK.

  1. Good that the drive still works
  2. When I do start/acces…/Command prompt I get this:
    C:\Documents and Settings\Gary>

After the ‘>’ I type cd C:\pathname to where the flasher and .bin file are located and hit ENTER.
then I type flasher blah blah…
Is this esentially what you did?

If the root cause is really as you said ‘…it could not open the bin file…’ (I am guessing here)
the original file you downloaded might be corrupted;
you made a typo somewhere {pathname, etc.};
MCSE messed it up and corrupted it.

You could wait for additional replies by some of the other folks;
PM ala42 and or cvs;
perform MCSE on a COPY of the main.bin file you dumped and re-flash.

I am somewhat grasping at straws here.
Be patient.

Regards


#7

The file is actually the drive’s firmware and I also downloaded firmware from post #1707. When I bring up my prompt it has C:\users\robert> I then type in D: and hit enter and it brings me to this prompt D:> so now is when I type in:
flasher\flasher -d 1 -f patched.bin
I have done a couple drive dumps and also used different file to input into mediacodespeed. The only other thing that I haven’t done is the rip the firmware files out of windows update executable. Don’t understand what that even means.

Thank for your replies Bob H.


#8

When I ran my dumped ‘main_backup.bin’ thru MCSE and ‘checked’ the increase readspeed box and saved, I got a file called ‘main_backup_speedpatched.bin’. Is this what you got?

Ripping the firmware files (using flasher: ‘flasher -r firmwarename.exe’ rips and generates the main.bin and core.bin files from the firmware update executable. In my case I couldn’t do this because there was no firmware update for my drive. I had to dump from drive using flasher.

Regards


#9

Yes, whatever file you go into mediacodespeededit, it comes out with the files name and speedpatched.bin added to it.
Flasher -d dumps the core and main firmware
I also didn’t have any firmware update to use, so I used flasher -d
Like I said, don’t know what flasher -r does other than what it says in the read me file.


#10

That’s all the -r switch does is extract the core and main.bin. Nothing else.


#11

BTW: If you haven’t noticed Re: the posts I made about my 38 drive, the MCSE speed increase did NOT have any effect with ripping DL DVD’s that I own.
The before and after MAX rip speed was the same - about 7.9x.

As far as BluRay, I did not do a TRT. But there is a claim in recent posts that there is some kind of speed increase.

So it is possible you may not see a speed increase with your drive. What is your rip speed MAX with a commerical DL DVD with the out of the box firmware?

Regards


#12

I don’t rip DL DVDs, the only thing I rip are Blu rays. The person that handles one of the Doom9 forums claims he saves at least 10-15 min a rip. He has a lg wh10ls30 with mediaspeed activated.

Back to my problem I have just about stood on head trying to make the program flash. No matter what I put at the end of the command, it cannot open a bin file. I can’t open it just by clicking on it, but that may not mean anything.


#13

No - you can’t open the bin file direectly. I have opened other .bin files in notepad. all you get is jibberish.

OK I just opened may main_backup.bin using notepad: Right click on the file once, you will get “OPEN WITH…”, a caution. click on the ‘Open With…’ button and then click on the Select the program from a list; button; select notepad; click OK. Ya, there are a few lines in English that are readable, the rest is code.

I have to log off now, I’m trouble shooting another system.

Regards and Good Luck.


#14

I have dumped the firmware 3 times, just to be sure their not corrupted. It still doesn’t make sense because if you can dump the firmware, you should be able to flash, said by one of the moderators here.


#15

You would think so.
I am at a loss.

I can only suggest a few things:

  1. Can you open main_backup.bin in notepad?
    if you can, you should see, in the first line, then ‘official’ name of the main firmware. I don’t know what it should be, I’m just asking.
    Maybe this particular firmware can’t be modified correctly by MCSE and as a result, can’t be opened by flasher.

  2. Armed with that info:
    Send a PM to ala42, cvs and the mod of this forum and plead, plead, plead for help. Point to our posts.

Regards


#16

Got it!!! Woke up early this morning and went at it again. I tried typing the cmd line all different ways to no avail. I then came back here and read some of your posts over again. You said that you put the flasher and the file in the root directory on the C: drive. Did that, typed in the cmd line and it started flashing the drive.

I want to thank you for your patience and sticking with me.

Thank You Bob


#17

I would have guessed that, at the >, as long as you type in the full path name to the flasher and .bin file, it should have worked, but?? Glad you got it to work!!!

After flashing - Don’t forget to completely shut system down, turn off PSU and uplug. wat a few minutes, then plug power cord back in, turn on PSU, and start.

Do me a favor (and for everyone else as well):

Could you please rip one of your BluRays (hopefully a double layer one >25 gig) with the patched firmware and see exactly how long it takes?? And then re-flash your drive with the original main.bin and rip the same BluRay again? I’d love to compare the rip times.

Kind Regards, glad you figured it out. Have a great day!!