What should I do when my 1620 keeps stucking on PIO mode?

vbimport

#1

After burning 2 DVD+Rs @ 1.4X, I did a lot of tests. It turned out that my 1620 is always using PIO, instead UDMA. I have made sure my XP setting is correct, switch between master/slave and removed the other drive on that 80-pin cable. No luck.

Any help is very appreciated.


#2

Does XP show you PIO or UDMA mode in the device manager ?


#3

Uninstall the IDE controller in device manager and reboot.


#4

I just answered this same question in the thread titled: “Benq 1620 and sudden slow burns”. Here is what I wrote:

If Windows detects a certain number of disk errors, it assumes that DMA may be the problem and it automatically sets the drive to PIO mode (without telling you).

Sometimes, even though you set it back to DMA mode, Windows will continue to use PIO mode. The only way to fix this problem is to delete the controller, then re-boot and let Windows will reinstall it. Once the controller is re-installed, you can set the drive back to DMA mode. (If you need to do this, delete the controller, not the drive).

(PS it looks like rdgrimes already answered the question while I was typing in my response).


#5

make sure dma is selected in the bios


#6

XP shows PIO, the option is chosen at ‘UDMA if available’. :a


#7

Then proceed as rdgrimes said in post #3.


#8

You might also want to check out the bios and see under usually integrated peripherals the IDE controller and what mode its set to run at, sometimes a bios update can also cure these problems.


#9

Thanks to rdgrimes and Scandy. :bow:

The problem is solved after uninstalled and re-installed the IDE controller. Many thanks.