What means yellow color led on 812S?

hello,

I’m trying to use a 812s drive under linux.

It seems to work except this:
During a dvd±r(w) burning process, if the load of the system is lighty used for something else (open a new web page in an already launched web browser for example), the drive led color is going from red to yellow for a short period and then is going back to red. This does not occur with cd-r(w).

I didn’t find any documentation about the meaning of this color (is it red+green that giving yellow ?), but I suspect it means buffer underrun is occuring.

Does someone know something about it ?

Thanks by advance.

Hi
You can read about it here, and other colors here.

:wink:

Thanks for your reply.
The link to this post was very interresting for me :slight_smile:

here are my specs:

maxtor 7200 rpm 8MB cache UDMA 133 connected on a promise pci ide controller (ATA 133).
812s with DMA enabled.
Athlon 2800xp barton
1GB RAM
KT333 chipset (asus a7v333-x motherboard)

with this specs, I need to not use my computer during dvd±r(w)@4X burning process to avoid buffer underuns. I notice that creating an image before burning reduces buffer underuns, but I still need to not use computer during burning process. Do you think it’s a normal behavior or that’s there is a trouble somewhere in my setup ?

With those system specs? You definitely shouldn’t be getting all those buffer underruns. As I said in one of the threads that pinto2 linked to, I have a 1.4 GHz Celeron with a mere 384 MB of PC100 memory, and I can burn at 8x and do some light things like browse the web and programming while I’m burning. Your system is considerably better than mine, so for you to be having buffer underruns at 4x is not normal. Try out the things suggested in that thread, and let us know if any of those suggestions helped any bit.

Something that you might want to do is to simulate a 4x burn using CD-DVD Speed (this requires a -R disc). Pop a blank -R disc into your drive, and have CDS to a transfer rate test (NOT create data disc… transfer rate will simulate, create data disc will burn your disc). And also have CDS do a burst-rate test while you’re at it.

Ok, thank you :slight_smile:

Now I know there is a trouble somewhere.
Thank you for suggesting a test procedure, but I dont have any windows system installed on this computer (a linux box), so I can’t try it.

I will see if there is a way to make some equivalent tests under linux but I suspect a trouble with the dvd burning application that I’m using (growisofs), or the way I’m using it, because it seems to me that the OS setup is ok.

I will post if I understand something new.

Oops! I keep forgetting that. First in the firmware forum and now here. :o

Is there a DMA equivilant for linux? Im not sure, but perhaps the way the drive is configured in linux has something to do with it.

DMA is an hardware protocol. with Linux, it can be activated with the hdparm tool.

here are the hdparm settings of both my 812s and my maxtor hard disc:


hdparm -i /dev/dvd-rw

/dev/dvd-rw:

Model=LITE-ON DVDRW SOHW-812S, FwRev=US0N, SerialNo=[…]
Config={ Fixed Removeable DTR<=5Mbs DTR>10Mbs nonMagnetic }
RawCHS=0/0/0, TrkSize=0, SectSize=0, ECCbytes=0
BuffType=unknown, BuffSize=0kB, MaxMultSect=0
(maybe): CurCHS=0/0/0, CurSects=0, LBA=yes, LBAsects=0
IORDY=yes, tPIO={min:227,w/IORDY:120}, tDMA={min:120,rec:120}
PIO modes: pio0 pio1 pio2 pio3 pio4
DMA modes: mdma0 mdma1 mdma2
UDMA modes: udma0 udma1 *udma2
AdvancedPM=no
Drive conforms to: device does not report version:

  • signifies the current active mode

hdparm -i /dev/hdf

/dev/hdf:

Model=Maxtor 6Y120P0, FwRev=YAR41BW0, SerialNo=[…]
Config={ Fixed }
RawCHS=16383/16/63, TrkSize=0, SectSize=0, ECCbytes=57
BuffType=DualPortCache, BuffSize=7936kB, MaxMultSect=16, MultSect=off
CurCHS=16383/16/63, CurSects=16514064, LBA=yes, LBAsects=240121728
IORDY=on/off, tPIO={min:120,w/IORDY:120}, tDMA={min:120,rec:120}
PIO modes: pio0 pio1 pio2 pio3 pio4
DMA modes: mdma0 mdma1 mdma2
UDMA modes: udma0 udma1 udma2 udma3 udma4 udma5 *udma6
AdvancedPM=yes: disabled (255) WriteCache=enabled
Drive conforms to: (null):

  • signifies the current active mode

something I have noticed, is that the cache size is not displayed for the dvd writer. I dont know if there is a trouble with that or not. I have tested the output with another cd-rw drive, cache is not displayed but it’s working perfectly.

dmesg gives this:

hdd: LITE-ON DVDRW SOHW-812S, ATAPI CD/DVD-ROM drive
[…]
hdd: ATAPI 40X DVD-ROM DVD-R CD-R/RW drive, 2048kB Cache, UDMA(33)

and hdparm -I /dev/dvd-rw gives this:

hdparm -I /dev/dvd-rw

/dev/dvd-rw:

ATAPI CD-ROM, with removable media
Model Number: LITE-ON DVDRW SOHW-812S
Serial Number: […]
Firmware Revision: US0N
Standards:
Used: ATAPI for CD-ROMs, SFF-8020i, r2.5
Supported: CD-ROM ATAPI-2
Configuration:
DRQ response: 50us.
Packet size: 12 bytes
Capabilities:
LBA, IORDY(cannot be disabled)
DMA: mdma0 mdma1 mdma2 udma0 udma1 *udma2
Cycle time: min=120ns recommended=120ns
PIO: pio0 pio1 pio2 pio3 pio4
Cycle time: no flow control=227ns IORDY flow control=120ns

I have done some reading speed tests, I don’t know if it can help:

hdparm -tT /dev/dvd-rw

on 4x cdrw
/dev/dvd-rw:
Timing buffer-cache reads: 632 MB in 2.00 seconds = 315.73 MB/sec
Timing buffered disk reads: 8 MB in 3.81 seconds = 2.10 MB/sec

on 4x dvd+rw
/dev/dvd-rw:
Timing buffer-cache reads: 1040 MB in 2.00 seconds = 519.30 MB/sec
Timing buffered disk reads: 8 MB in 3.35 seconds = 2.39 MB/sec

on a dvd 9
/dev/dvd-rw:
Timing buffer-cache reads: 1040 MB in 2.00 seconds = 520.08 MB/sec
Timing buffered disk reads: 14 MB in 3.37 seconds = 4.16 MB/sec

What Linux distro and version are you running?
What kernel?
ie is it optimised for 1Gb of memory?
I use Mandrake 10.0 but with 1G mem, I installed the …up-4GB kernel.
It does seem a tad faster in sometings especially multi windows apps.
Are you using Gnome or KDE or other window system.
I can’t think what else.
Do you get good DVD movie playback via say Totem or Mplayer (I can’t get this working). Totem is good though.
I get in my 812@832
hdparm -Tt /dev/hdc (ie 812s)

Timing buffer-cache reads: 1916MB in 2.00 seconds = 956.23Mb/sec
Timing buffered disk reads: 14MB in 3.15 seconds = 4.44Mb/sec

I haven’t tried DVD burning of any type yet.
But I normally used K3b for sytem backups to cd previously.

I’ll try to back up one of my DVD’s to see how she burns.

We have similar(ish) hardware
Gigabyte 7N400Pro2
Athlon 3200XP
1G pc3200 mem
WD ATA 7200 hdd; pri master
812s; sec master

hi :slight_smile:

I’m using gentoo, kernel 2.6.5-gentoo-r1.
It is optimised for 1GB.
I have good DVD movie playback with xine or mplayer.

I see you have better timing buffer-cache reads, but I think it is explained by the higher specs of your memory (400MHz) as hdparm -T displays “the speed of reading directly from the Linux buffer cache”.
I have tried k3b, but it just uses growisofs. Because of the buffer underruns I have experimented, I think it’s better to use directly growisofs to understand where is the trouble and to try various command line options.

One thing is that k3b is requiring sticky bit on cdrecord executable, to launch it IRC with a higher priority by using “nice”. I have try growisofs as root with a higher priority (nice -10) and it is working perfectly, even in “on the fly” mode @4x on a dvd+rw :slight_smile:
I know that k3b dvd writing support is recent, and I think its growisofs is not totally completed. In particular, I now think it should use growisofs with a higher priority as it does for cdrecord.

let me know if you successfully burn your backup.

gentoo! sounds good. (I mean if I had time I’d give it a go too!)
I’m having trouble with (at first k3b) growisofs.
[:frowning: unable to open64…"/path/to/filename,O_RDONLY): No such file or directory ] is one error I get ?? File IS there and NOT set to read only or whatever!
I’m not to bothered ATM, but I’ll search around later.
So I can’t get anything happening on DVD side.

Ok, at least you’re burning

SeeYa.