What I can do with my 48125S?

I have the 48125S, its possible to put the firmaware of another recorder?

you can burn cd’s with it

lol

have a look here;
http://club.cdfreaks.com/showthread.php?s=&threadid=42502

http://club.cdfreaks.com/showthread.php?s=&threadid=49985

http://club.cdfreaks.com/showthread.php?s=&threadid=56190

perhaps there is something about your burner

but can I put the LTR-52246S or the LTR-48246S or LTR-48126S or the LTR-48125W firmware last version in my LTR-48125S recorder??
my recorder doesn´t support MT-Rainier mode, and the LTR-48125W yes, and this recorder has more revisions of firmware that the S version

You can only make it a 48125W.
Putting a 6S firmware in it will cause malfunction.

I’ll strongly second what Airhead said. I tried 6S on my rebadged 48125W (Memorex 48MAXX 48/12/48). It didn’t work. When I flashed it back, I started having problems with the burner which was functioning flawlessly prior. Unreadable sectors at the end of the disk, even with TY 48x media. Probably a coincidence. Fortunately I was able to flash it back to the original Memorex firmware (it was still malfunctioning), and returned it for another drive which seems to be okay so far. It was a coincidence, right? I mean, after I flashed it back to MTK 5 based firmware, it should have completely overwritten the bad flash?

That was a pretty dishonest thing to do. If you screw it up you should not return it.

BadReligionPR: If I was sure I screwed it up I would have taken my lumps and learned from the experience. Everything I’ve read indicates that a bad flash can be recovered from. So I strongly feel that it must have been a coincidence, and I hadn’t noticed it until after the flash, because that’s when I ran it through a thorough series of tests. I went back and checked a couple of the most recent burns I did before the flash, and they all have a series of C1 errors towards the end of the disc. This leads me to believe it was already failing. So no, I don’t feel it was particularily dishonest.

Stepping back down off the soapbox.

Originally posted by Airhead
You can only make it a 48125W.
Putting a 6S firmware in it will cause malfunction.

yup , found that out as well :slight_smile:

luckily i could flash it back to a 48 with VS08 firmware , works like a charm now.