What are the common causes for erase failure?

vbimport

#1

I have a computer running Window 98 with Easy CD-Creator. I tested my CDRW drive with some CD-RW media, it works for me when I burnt a Data CD with ~50 MB data. The CD is then erased without problem.

Because I found a step-by-step instruction to burn a bootable CD using Nero 6. I installed the demoVersion onto a new partition that runs Windows 2000 under the same computer (multi-boot). I tested burning a new CDRW media (same brand, brand new) with Nero, it runs a very short while but then sends me a error message. The media couldn’t be erased afterwards. Two more CDR media were also wasted similarly

I took another CDRW media (same brand, brand new) and test writing some data using the build-in copy-to-CD function of Windows XP in another machine (with the same CDRW drive), I failed again. The media of this test was again not erasable afterwards.

What were the common causes for erase failure? I tried all ways to erase the RW media, using XP, using Adaptec Easy-CD Creator, or using Nero. Nothing works for me. I also tried to upgrade the firmware of my CDRW drive, it did not help.

BTW,
My CDRW drive is a Matsuita CW-7586, one that is notorious for giving grief to users. I found it works ok if I am only using it for burning “data CD” and “audio CD”, using one particular type of CDR media. To avoid ruining new media, I have restricted to using the same type of media only, restrict myself to EasyCD-Creator only (EzyCD was coming with the drive package with I purchased it). After the firmware upgrade, my drive is still working well when burning the same type of CDR.

Any help other than suggesting me to throw this drive to the bin? I am hesitating to test more CDRW media. It is so likely that it won’t burn and will ruin more media (since I have no ways to erase it after the burning goes wrong).