WH16NS40 freeze entire computer Windows 10 x1709


#1

For those with WH16NS40 and WINDOWS 10 X1709, i have 1.02 firmware installed.When i try to use Device Manager and try to “Scan for New Hardware changes”, it would load a message “Scanning for New Plug And Play” and then completely freezes the computer.

Side Note: If i unplug the Blu-Ray drive, device manager no longer freezes the entire computer.
Also note, reading dvd and blu ray discs are fine.

Also, I tried installing Firmware 1.03 but got an error: Drive may be in Abnormal State, use Boot mode.
I believe 1.03 is only meant for NS50 and NOT NS40. I am STILL on 1.02.

This is on Windows 10 Fall Creator x1709.

Any idea on what causing it?
Can someone with WH16NS40 try to use device manager on Windows 10 and click “Scan for New Hardware”. Thank you.


#2

I would try a different drive in it, if the other drive works and its just this one, I would think the drive is bricked.


#3

Thx for the suggestion.

Tried it and it seems to be the WH16NS40. Strangely, it still works. I think it a software issue.

Do you think it wise to flash it again to 1.02 or possibly 1.00?


#4

I haven’t flashed a drive since 2005 and I have bricked a few in my day. Thats totally up to you.


#5

I do not believe that you can flash a LG drive with the same version of firmware. I tried it and the flasher responded with a messaging stating that the drive is on the same version or later and refused to permit the flash.


#6

I tried scanning for new hardware and nothing abnormal happened. My drive is a LG wh16ns40 svc code ns50 on firmware version 1.02. I have my controller set up as AHCI and I have two DVD drives hooked up in my machine. I also flashed the firmware on the LG wh16ns40 to version 1.03 and still had no problems scanning for new hardware. I have a ASRock Z270 Extreme 4 motherboard with a Intel I7-7700K processor in this machine. My machine is also on Windows 10 version 1709.