Weired problem with DMA enabling in XP

vbimport

#1

Hi, there, I have got a weired problem with DMA enabling in my winXP pro system.

I have a sony 12x8x32 CDW and a toshiba 16X DVD Rom installed the secondary IDE channel of my Asus A7V133 mb of my AMD 1GHz system. I am quite sure these 2 drives are DMA capable but NO MATTER HOW I tried to set them to “DMA if Available” in my device manager, they always remain “PIO Mode” after restart.
in the BIOS setup, both ROM has default setting of PIO level 4 and DMA level 2. and my system has 256MB SDRAM, and 80GB hd,

I have experience sound lagging while playing DVD movie, and I couldn’t do anything while I am burning a CD. I suspect that all these problems are caused by PIO mode.

Could some expert points me to some solution?

Thanks in advance


#2

What IDE cables do you have. Sometimes when wrong cables are used this happens. Are you using ATA 100 or ATA 133?


#3

Run Regedit and find the following key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro
l\Class{4D36E96A-E325-11CE-BFC1-08002BE10318}\000x

Last four digits usually are 0001, 0002. Under those keys you will find MasterIdDataChecksum, SlaveIdDataChecksum. Delete the value corresponding to your drive. It will make the OS to redetect the device DMA capabilities after reboot

This worked for me.


#4

Thanks for all your reply.

I just fixed the problem. I deleted the secondary IDE channel from the device manager, and reboot my system, then the system re-detected the ROMs and gave them UDMA2 instead of PIO.