Weird things + dramatic slowdown

vbimport

#1

hi all.

well i have an issue with nero linux, which is to my opinion acting weird. when i burn (anything) it starts and goes to 20%, the it spins the drive faster and burns faster, when it reaches 66%, it spins the drive even more and either burn even faster(when my HDD an old 20G maxtor is quick enough) or it slows down dramatically (when the HDD seems to be too slow) maybe to 1x speed, while the buffer is still full. in windows version i was used to, that it keeps speed as high as possible, and the buffer fill drops. i know this is not good for quality of the burnt content, but i really don’t want to wait an hour for my DVD to be burnt at “4x speed”. in windows it takes 17 minutes +/-. i have LG 4160B DVD-RW. if there is anyone with archaic hardware experiencing the same problems, please let me know. looking forward to any responses.

ethyl


#2

Which kernel are you using ? If it takes you more than one hour to burn a DVD, this sounds to me like you are using this old ‘ide-scsi’ bridge with a 2.4 kernel…


#3

sorry. i should be more specific. i am using vecor linux 4.3 with 2.6.7 kernel(not using ide-scsi emulation). my cpu is an old celer 500 (mendocino), 128M ram, 20G maxtor udma 66, mobo is matsonic 7112C (ble…)


#4

Is your DVD drive connected to the same IDE channel that your hard disc ?
Can you also provide a dump of what lspci say ? It is very strange because my developpement machine is also running a 2.6.7 kernel and one of my test burner is a LG 4160…

Do you have additional swap that the 128MB of RAM ? Maybe you could run a burn process with a term open executing ‘top’. I suspect that when you experience your ‘slowdown’ it is because you do not have RAM left and your system starts to swap.


#5

thank you for your quick response. i indeed have a burner on the same channel as my hdd. i’ve read it is not a good option, but i’ve tried it (in windows only) but without a significant benefit. i use this setup, cause i have only one 80 wire ide cable, which is connected to disk. the other one is only 40 wire cable on which i have my old TEAC W54E. my lspci dump:

00:00.0 Host bridge: VIA Technologies, Inc. VT82C693A/694x [Apollo PRO133x] (rev 44)
00:01.0 PCI bridge: VIA Technologies, Inc. VT82C598/694x [Apollo MVP3/Pro133x AGP]
00:07.0 ISA bridge: VIA Technologies, Inc. VT82C596 ISA [Mobile South] (rev 21)
00:07.1 IDE interface: VIA Technologies, Inc. VT82C586/B/686A/B PIPC Bus Master IDE (rev 10)
00:07.2 USB Controller: VIA Technologies, Inc. USB (rev 0d)
00:07.3 Host bridge: VIA Technologies, Inc. VT82C596 Power Management (rev 30)
00:0a.0 USB Controller: OPTi Inc. 82C861 (rev 10)
00:0b.0 Multimedia video controller: Brooktree Corporation Bt878 Video Capture (rev 11)
00:0b.1 Multimedia controller: Brooktree Corporation Bt878 Audio Capture (rev 11)
00:0d.0 Multimedia audio controller: C-Media Electronics Inc CM8738 (rev 10)
01:00.0 VGA compatible controller: nVidia Corporation NV5 [RIVA TNT2/TNT2 Pro] (rev 15)

i use a swap partition of approx 250M. i noticed that when my buning is very slow, iowait is showing over 80 or 90%. disk activity is almost none. what causes it? could it be the burner and HDD on the same channel? i am sorry, but i don’t know what exactly is “iowait”…


#6

so i was googling for iowait and found that it’s information value is somewhat misleading and saw several people saying having high iowait is kosher… i know my HDD is slow… hdparm says the read is around 14 MB/s, buffer-cache reads around 60 - 70 MB/s. i’ve read that i won’t get these numbers in real life (and i don’t). but i am wondering… (this might be a little off topic, but could be the point of this problem). when i copy from my LG 4160B to my ext3 partition i can get my copy speed as high as 8 - 9 MB/s. but copying from HDD to HDD (the same partition) i get maximum of 5 maybe 6 MB/s, which could be explained by seeks (maybe), when i copy form one partition to another (ext3 -> FAT32) i get around 2 MB/s, which i explain by seeks plus different filesystems (maybe i am wrong). but when burning, the HDD reads not more than 5 MB/s. why is it so? why is it able to write at 8 - 9 MB/s and it cannot read more than 4.8 MB/s?, that’s why i cannot burn DVDs at 4x, cause it needs to read (at least) 5400 kB/s. maybe there is some fundamental difference between reads and writes which makes this almost 100% speed difference. both my HDD and the LG are using UDMA4 (hdparm). thank you for your response in advance.

ethyl


#7

and to add… my system is not swapping while i am burning


#8

So… If your system is not swapping and your HDD is not able to deliver you more that 6MB/sec, I would suspect some kind of IDE chipset problem.
In the other hand, we made a test on a Celeron 400Mhz, 128MB of RAM and with the same burner: everything was OK.


#9

i think my HDD could be the bottleneck. it is reffered to as “slow”, but couldn’t find any real life numbers. it is an Maxtor DiamondMax 30 VL 32049U3. but it still doesn’t explain why it takes an hour to burn a DVD at 4x in Linux and in Windows it is finished in 17 minutes. disk performance in applications seems to be equal in both OSes. but now i remember, that xcdroast had the same problem (slowing down without any apparent reason). i just forgot about it. there must be something which is holding it all back. i will try to figure it out. it really could be an hardware issue, VIA apollo pro 133 were one of the worst chipsets around. thank you very much for your help. if i find out anything i will share the knowledge.


#10

i probably forgot to mention, that all that time i was just simulating and never waited till the end of the simulation. today i forgot to set the slower burning speed and left the maximum (40x for a CD). the slowdown occured, but i said to myself i should bare it. but around 60 percent of the CD, the burn process failed. i don’t remember, what it said, i don’t know where exactly should i find the logs, i was searching for them, but found nothing. it’s very odd when the burner spins the media to the extreme, like it was writing at maximum speed, but disk doesn’t do anything. when i am burning at 24x, the disk led flashes rapidly. in the slowdown case, it flashes once at a time…


#11

my appologies to all wise people (mainly mathf) who told me not to have my hdd and burner on one IDE channel. i swapped it and WOW. it works so far. no slowdowns so nothing. i guess i was too blind to look and too deaf to listen. but i’m not dumb so i say thank you. :slight_smile:


#12

Check your hard disk performance now. I bet it will be better without the burner slowing it down.


#13

yeah, it went up a bit. but the main thing is that i can burn faster and more reliable. tomorrow i am buying another 80 conductor cable for my secondary channel where my burner is hanging now. next month i will probably have some money, so i can upgrade my box (actually, the only thing i will keep is the burner - a hell of an upgrade). after five years - it was about time.