Weird System Hang Problem - Please Help!

vbimport

#1

Hi everyone;

This is my first post and I was hoping to get some advice on a weird problem I’m having with my PC.

I have two Lite-On burners, one is a CDRW (32123) and the other is a DVDRW (411S). I have had the CD Burner for 2 years or more and the DVD Burner for about a year and a half. I’ve used both drives to burn data, music, and movies with no problems until now.

The problem I am having now is when I insert any kind of disc (CD-ROM, written CD-R, DVD, DVD+RW, DVD Movie) into the DVD Burner or any kind of CD in the CD drive the system will sometimes hang. Sometimes it can read the disc just fine but most of the time the system will totally hang and I have to reset it. I have not been able to write a CD with the CD Writer or a DVD with the DVD Burner since this started happening.

Both drives are usign the latest firmware available from Lite-On. I have read that some Users are having problems with FS0K (the latest formware for the DVD burner) but that wouldn’t explain the problems with the CDRW drive, would it? I am thinking I am having a system driver, hardware, or firmware problem and don’t know where to go from here.

System is custom-built running Microsoft Windows XP Professional SP1. The drives are IDE and are connected to the same channel (DVD = Master, CD = Slave). The other channel has a hard drive connected to it and nothing else.

I am using the same brand media that I have burned successfully to before (Maxell CDRW and Maxell DVD+RW).

Previously I used Nero 5.5 and InCD3 with no problems and upgraded to Nero 6.6/InCD 4 recently. This is the software recommended by Lite-On.

Lite-On’s technicians thought it was a problem with the laser and that the drive is just worn out. I don’t use my burners that much so I doubt this is the case and it wouldn’t explain why sometimes I can play a disc ok and other times the system hangs completely.

I can boot my system usign another hard drive to Windows Milennium Edition for diagnostics but haven’t tried that yet sicne my burners ahve always worked fine under XP Pro.

Any advice would be greatly appreciated. Thanks for your time!

…C_Guy


#2

Lite-On’s technicians thought it was a problem with the laser and that the drive is just worn out…no way.
i have had this happen when raspti.sys AND SPTIP.dll decidedto go AWOL or turned retarded on me. also apps that require aspi can display the symptoms you describe if no aspi is installed . also IMAPI, CD autorun might be playing a part. sound like a software issue to me or even DMA/PIO mode issue. try these steps.

  1. go through the 10 points listed @ http://www.mrbass.org/dvdnewbie/ [ you may not be a newbie, but the trouble is, and might be related to one or more of the listed items ]. note: very important to keep the transfer mode on IDE channels in DMA mode. check them every now and then as the transfer mode can change without you being notified. see this MS article http://www.microsoft.com/whdc/device/storage/IDE-DMA.mspx

  2. a) know your drive’s capabilities. use nero info tool to discover them. also go to the drive maker’s website and find out what media types and brands, and at what speed to those media types, the drive supports. [ eg., my pioneers 107d & 108a can burn to dvd-rw @ 4x without trouble, but my optorite 401 can only burn @ 2x to dvd-rw even though Nero and other burning programs will allow the drive to burn @ 4x and will produce a “successfull” disc @ 4x…but the result is a coaster ] b) update the firmware of the drive. check for updates @ http://forum.rpc1.org/dl_all.php

  3. a) try another brand of CD/DvD disc. b) try burning at lower speed. eg., don’t burn at 24x to 16x media; burn according to MEDIA speed limits, don’t try to burn at the cd/dvd drive’s max speed until you are certain that you can do so without negative consequences.

  4. a) disable and/or uninstall any virtual drives. b) install an aspi layer. preferred is v460. get it @ http://www.snapfiles.com/get/aspilayer.html

  5. a) update the burning program you are using to the latest release. b) uninstall any recently installed software. c) do a virus scan, and a scan with spybot s & d [ get it @ http://www.safer-networking.org/en/index.html ]

  6. for XP or Win2K users, optimise your operating system Services for best system performance. for info go to http://www.blackviper.com/WinXP/service411.htm#Alerter and http://www.freeware-alternative.uni.cc/downloads/service-controller-xp/service-controller-xp.html

  7. before burning, open taskmanager and shutdown ALL unneeded processes that are running. DON’T commence a virus scan or a defrag before or during a burn - sadly, i have seen it happen !

  8. a) try another burning software and see if you get a better result. deepburner standard is free. get it @ http://www.deepburner.com/ b) for users of alcohol 120%, update to the latest drives support DLL [ look for topic “Alcohol 120% Device Support Patch Released” @ http://forum.alcohol-soft.com/index.php?showforum=10 ] c) if you have multiple burning softwares installed, uninstall them all, then install one. test it. install another if needed. test it, and so on…

  9. make sure mainboard chipset drivers are up to date. make sure all cables and jumpers connected to drives are correctly configured with regard to master/slave setup.

  10. enter your BIOS and disable anything you don’t use. set memory speeds to default. set cpu speed to default. if you overclock, DON’T [ until you are certain that overclocking is not the cause of the trouble ].

  11. if you still cannot fix the problem, try the drive or the CD/DvD disc you are having problems with in another PC that has no burning issues [ if possible ]

  12. Disable autorun…unless you really need it for some purpose. for XP users go to start/run/type REGEDIT.EXE then click OK
    press Ctrl+F, type NoDriveTypeAutoRun in the box/find next
    doubleclick the highlighted key and replace the HEX value with b5
    repeat for each NoDriveTypeAutoRun key found. reboot.

  13. Two other settings to consider changing, but ONLY if you never use Windows’ in-built CD
    burning function [ie. you only ever use nero, roxio, intervideo etc. to burn cd/dvd]. Rightclick on your cd/dvd drive icons in My Computer/properties/recording and clear the Enable CD recording on this drive box. Note that this WILL NOT cause your 3rd party burning programs to malfunction - it only disables Windows’ in-built cd burning capabilities. now go to start/run type services.msc and hit ENTER, scroll to IMAPI CD-Burning COM Service, doubleclick it, disable it, apply/ok.

14.it’s also a good idea to try an arrange the device IRQ assignment so that each device on your system has it’s own IRQ. this is not always possible or user-configurable. however, on a modern PC running Windows XP Pro you can try the following.

a. enter your BIOS and look for a setting/option similar to “plug and play operating system” . you need to set this option to No or Disable. this allows the BIOS to assign IRQs to devices instead of Windows. there might also be an option like “allow BIOS to assign IRQ”. Enable it.

b. restart. open device manager/view/resources by type/interrupt request

note that in the above image all my devices have thier own IRQ ? this was not always the case; my NVIDIA GeForce and my Realtek NIC were both sharing IRQ 16 and my Realtek Sound device and a couple of USB controllers were sharing IRQ 18. so what i did was disable the USB controllers [ see below ] as i never need them. i also put my Realtek NIC into another PCI slot.


Anyway, see what you can do. maybe you’ll only be able to reduce the devices sharing an IRQ from 3 to 2. Better than nothing . Trial and error will get you through if you disable your mouse or keyboard etc. just renable it.


#3

Hey G)-(osters;

Thanks for your long and informative post! I went through all the tips you provided but unfortunately…if you can believe it… I still have the problem.

I’ve been reading of similar problems other Lite-On Users are having with their 411S drives so I am thinking of just dumping them and getting a new burner but I am hesitant to order one in case this doens’t fix the problem.

Can anyone offer any insight? I’ve heard that the Pioneer 108 (http://www.ncix.com/products/index.php?sku=12458&vpn=DVR-108B&manufacture=Pioneer) is a great buy :slight_smile:

Thanks!!

…C_Guy