Weird safe disc problem (i think)

vbimport

#1

This might not be exactly on topic, but nobody has been able to figure this out so I thought I would try the true experts on safedisc.

I recently upgraded my computer (krza-133 abit motherboard, 1900 athlon, g4 video gard) and at the same time purchased four games with a gift certificate (Morrowind, freedom force, jedi knight, Mohaa). Every game except jedi knight would just flash briefly and then go back to the desktop when I tried to run it. I had heard somewhere that this was possibly a safedisc issue, that some CD-rom drives couldn't read it properly, so I tried out a NOCD executable for Morrowind and the game worked fine.

Figuring it was my CD player I installed my Plextor 12/10a drive from my other computer (was using a generic mitsumi), but had the same problem. Then I tried a creative blaster and I still couldn't get the games to start. Giving up I just used NOCD executables for both MW and MOHAA, but now I've been trying to get Freedom force to work and the NOCD patch is not working correctly (or I've installed it wrong most likely). Then out of desperation I installed Freedom Force on my old celeron based system and lo and behold it ran fine off the Plextor CD-rom drive.

This has completely confused me. I assume it is still a safedisc issue because the games work with the safedisc protection removed and Jedi Knight runs fine (which I believe does not use safedisc). I've futzed around with every setting I can think of, but I'm completely at my wits end (not that long of a journey, I admit).

Anyway, if anyone actually read this whole thing and understood it, I'd appreciate any ideas.


#2

The use of no-cd patches is illegal even if you do own the original game in question and therefore posts that refer to such programs are not allowed in this forum … you should keep that in mind.

Having said that, it is kind of strange that you can’t even get to run the originals … mentioning the os of both your pcs would help. It is known that windows xs are somewhat incompatible with safedisk and sometimes sd protected games won’t run on xp. There is a “patch” made by microsoft to fix this incompatability. This issue has been newsposted by cdfreaks here

If you use xp, reading this and this might help :wink:


#3

thanks for the reply, I appreciate it. Sorry about the lack of info, both systems use win98. I’d tear the new system apart replacing it component by component to see if there was somekind of weird problem, but since all all games work with a little ‘help’ (figured the Freedom Force thing out today) and the only ones that don’t work use safedisc I have to believe there is somekind of weird conflict between safedisc and my system.

As far as the legality goes, I find it strange since Morrowind’s tech support suggested I just keep using the ‘patch’ since they couldn’t figure it out. Of course none of the other companies even respond to my emails. I think if they smell a safedisc problem they run away because they realize there is not much they can do besides suggest a new CD-rom drive. Still, absolutely no jury in the world would convict a gamer who bought a game (especially from best buy, no returns) and used a program that simply let him play the game like its supposed to be played. Frankly no company would ever charge someone, think of the great publicity there. Plus, I’m just trying to find out how to play the original games without the bloody things. But I understand why forums would have to be extra-cautious (not exactly in the same position as the gamer), so I’ll just drop it.

Anyway, my problem is a strange one and probably not really resolveable here, especially if we can’t mention certain words:) So if the mods feel like this is a risky thread because of the subject matter, feel free to delete, I’d understand. This was sort of an act of desperation anyway.


#4

ok, my turn as a semi-proficient source

safedisc blacklists certain programs. these programs are things that enable you to do illegal things. these programs include playbackup, daemon tools, and anything else that qualifies as a debugger / emulator / decompiler that might be used to crack their executables. to get around this, you must clear the traces of anything of this nature you might have on your computer. at least, this is how i’ve come to understand it. i GUARANTEE a reformat will allow you to run these, if you dont know what is causing it, but since a reformat is a pain-in-the-ass, i suggest you find your program of this nature, and take it off :wink:


#5

Ok usually with no-cd’s the post(s) are questionable. Normally the mods/admins will close a post like this, be careful on your wording.
But here my 2 cents.

But this is a strange thing indeed. Is that the pressed originals dont work in the drives that means that originals are hosed(May be they work or maybe they dont)
But these are the backups that you made, I am assuming you have children and do not want them touching the bought copies.
You could be having a problem with a later version of safedisc(2 and above.) MOHaa has SD2.51. (whatever rest of the version is)
and it also has a atip check built in to it to determine if a cd-r and the disc being in a cd-rw drive. It is a real pain in the rear.

As for the other games I m not sure what protection is on them.
If you were told by the Morrowwind tech to keep using the patch, maybe you should send them a copy of it so they can figure what the hell is going on with it.

Btw what type of software are using to make your backups?
If its clonecd you might to try the FES skip and 0 retries and set it as none, play around with the settings and see what happens.
Do not use ROXIO to back up a suspected protected disc.

And when you update the games, the protection to the exe file might be updated also, a good example of this is Max Payne.


#6

I ll have to agrre with scin2001 here. Since you do not use xp, i can see no other reason why the originals don’t run on your system unless you use some blacklisted software … Try what scin has suggested and see what happens :slight_smile:
I’d suggest getting the latest drivers for your video card but i don’t think it is the cauze of your problem since the games run when they’re patched … it won’t hurt anyways :wink:


#7

Interesting about the black-listed programs. I don’t think I’ve used any, but can’t be sure (of course I’ve used some now, to try an get around the problem). I’ll search the registry to see if I can find any incriminating evidence.

I tend to agree that it must be something like that, though, just because the originals run fine on my secondary computer and it only manifests itself with safedisc games. I think I’ll try installing diablo II again and see if that works (I believe that uses safedisc). I’m just kind of curious to see if this only happens on the newer version of safedisc.

At some point I’ll try re-installing the operating system, just because this problem bugs me on a weird level (I can run all the games now, after all, with the patch). Just to add some info, the games do not run with daemon or other such programs.

Thanks for all the help everybody.


#8

diablo2 is securom new, and i think it blacklists stuff to. the people @ www.fileforums.com can help you with this kind of thing, they are dedicated to screwing macrovision over :wink: