Weird Problems with DMA

vbimport

#1

I know DMA has been discussed lots on here but can’t seem to find an answer to a problem I am having.

I realised that my Sony DVD recorder was taking ages to burn my dvd’s, checked the properties and realised it was using PIO only, tried to change the setting to DMA if available but it still said it was using PIO.

Got a firmware upgrade which changed my sony dvd to a LITE on dvd, now I can change the setting to DMA and it says it is using Ultra DMA 2 however it now won’t read the DEVD or let me burn. All works fine but slow when I change it back to PIO.

Another weird thing, when I changed it to DMA and rebooted the it hung when loading windows at the balck screen with the windows logo and the blue progress indicator.

I have tried all the common fixes such as deleting the IDE channel and rebooting etc, also tried editing the registry but still can’t get DMA to work

All comments welcome
Cheers


#2

Hi,

check you BIOS settings and replace your IDE cable against a new one…


#3

Changed the cable, no DMA options in bios
will allow me to change to dma in device manager but when I do it won’t read the drive and if i reboot won’t load windows!

any ideas!

Cheers


#4

Tried everyting and tested the iDE channel which was fine, bit the bullet and bought a new dvd burner all is now well!

Bit of a shame to scrap a 2 month old burner but I want DMA so that’s that!

Cheers


#5

I there no warranty involved? Only two months old?

As the Sony could be flashed as LiteOn the DMA should be UDMA-4, and it is advisable to use a 80 wire IDE-cable. You said you changed the cable, but did not say a 40 or 80 wire type. You did not tell what brand or model you are using now. If it is f.i. a Benq, you don’t need a 80-wire cable, as it runs UDMA-2. You see, the right info is nescessary for a better answer. It could very well be that your drive is perfectly alright…

:confused: Leo