Weird problem with optiarc7170a

it’s a pata optiarc 7170a.
i pulled it out of my old system and placed it into my new one.
installed winxp 32bit. it will read all dvds fine, it will burn to them fine also.

what it will not do is read DL media. the icon under my computer
shows dvd-ram drive, if i put in a dvd, it shows the contents.

when i put in DL media, it will change the icon from dvd-ram drive
to cd-rom drive. and when i double click, it shows nothing in explorer.

i put the 7170a back into my old system, and it reads DL media fine.

new system
e6850
abit ip35 pro
crucial ballistix ddr2 6400 2gb
evga 8800gt

any ideas? i tried flashing the firmware, but i keep getting checksum errors even in safe mode, and the ide set to PIO.

I have been saying this alot today, unistall the drive in the device manager and restart windows. Windows will reinstall this drive and hopefully your problem will be gone!

just tried it, rebooted, redetected the 7170a
but still will not read dual layer media
only regular dvdr

anyone have any ideas?

[QUOTE=stage_;1955035]just tried it, rebooted, redetected the 7170a
but [B]still will not read dual layer media[/B]
only regular dvdr[/QUOTE]

Please explain “dual layer media” en detail here.
Pressed, burned, BLANK??
Which brand, which speed rating, which mediacode/MID?