Weird Problem w/ Sony DRU530a (wont recognize ANY cds)

vbimport

#1

I just started having a problem w/ my burner. It is a Sony DRX530UL (external) but it uses the same firmware as a DRU530a. A few days ago I was buring a Audio CD w/ nero and it stopped about 1/3 of the way through. At the time I didnt think anything of it, just thought it was a bad disk or something. Ever since then if I put any kinda CD in the drive (software, audio, game), the drive light will stay on and the PC wont recognize any media in the drive. At first I thought it was a PC problem, but I tried it on a fresh install of windows, and the same thing happened. Also if I disconnect all cables but the power cable the same thing happens. I am almost positive it is a problem w/ the firmware or EEPROM. I have also tried it in both ILINK and USB ports. The strange part is I do not have any problems w/ any type of DVDs (games, movies, blank ones), it reads/writes those fine. I have tried several firmwares ranging from 1.0C to 2.1g. None of them helped at all. Any help would be greatly appreciated.

Thanks

Kevin