Weird NEC ND-2500A problems!

Right here goes…

I have a NEC ND-2500A and recently it’s been acting up. I’m running XP Home SP2. For some reason whenever I insert a new CD or DVD the icon and volume label in My Computer doesn’t change. They will only change when I restart the computer. So basically the label and icon is set when i turn on the computer to whatever disc is in the drive, and won’t change! This obviously isn’t a massive problem… but it’s just the start!

Secondly, when I insert a CD, double clicking on the drive will open up the contents of the CD fine (as it should). No problems there (other than the whole icon thing). However when I insert a DVD, and double click on the icon, I either get an error saying ‘D:\ is not accesable’ or ‘Please insert disc into D:’.

At first I thought this may be something to do with the hardware dying on me, and my drive just not being able to read DVD’s any more. However when a DVD is in, if I open up ‘Power DVD’ the DVD will play fine! And if I open Nero, it will burn to a blank DVD fine as well! But I still get the error messages when double clicking on the drive. This means that watching DVD’s and burning them isn’t too much of a problem, however trying to use data DVD’s is impossible!

I’ve tryed a few things:

  • Flashed my drive from a NEC ND-2100AD to NEC ND-2500A
  • Flashed latest firmware update
  • Removed upper & lower limits in regestry
  • Uninstalled & reinstalled the drive (several times!)
  • Swapping the jumper (master, slave, etc)

None of these made any difference.
I’m using the same DVD+R that I’ve always used without problem, all burned from the same drive.
DMA is on, Autorun is off. The drive is set as Secondary Master.

Any help would be hugely appreciated, as being a student I can’t really afford a new one! Thanks in advance!

I suggest you to try some live linux distribution. Then You will know for sure if it is problem with your drive or with windows settings.

That’s only a cosmetical problem because almost any burn-software disables Auto-Insert-Notification for a good reason.

Hi again,

thanks for the replies.

Firstly chef, i’m not actually worried about the icon and volume label, I just thought it may be related. Is there anyway to turn back on the Auto-Insert-Notification (purely out of interest)?

And kolos, I’m not familiar with ‘live linux distribution’. What does it mean, and how do I do it?

Thanks again.

Ok kolos, I think I tried what you suggested. I downloaded and used ‘SLAX’, to boot into a Linux OS.

I tried several different types of discs with varying results:

  • CD-R with just data on, worked fine.
  • a music CD came up with the following error after doube clicking on it: ‘Could not start process. Unable to create io-slave: klauncher said error loading ‘kio_audiocd’’ (It means nothing to me!)
  • a proper DVD Movie said ‘No medium found’!
  • and all the DVD+Rs i tried came up as blank! It recognised the disc, but not the contents!

I think the music CD not working is due to something different because, they work in windows fine. I tried the DVD drive on another computer briefly, and it was very similar, DVD+Rs all came up blank, and CDs worked fine. This suggests to me maybe it is a hardware thing.

HELP ME PLEASE!

I don’t know much about DVD’s mechanics and hardware configuration problems, the only thing I can suggest is to try out drive in another computer. Then you will probably know if you need new one or not.

Imo, it is probably a software issue. Make sure that you use the standard Microsoft IDE drivers. Maybe there is an additional tool / driver installed which interferes with Windows? InCD or something like that. I suspect that a fresh windows install will help. Good luck.

Have you CloneCD installed by a chance?

I don’t have CloneCD or inCD installed. I use Nero 6.??. I used to use Sonic RecordNow. I think thats the only burning software I’ve ever had installed.

I really want to avoid formating and starting over! To much hassle!

I will try uninstalling and reinstalling the IDE drivers when i get home from uni!

Thanks for the help thus far, any other suggestions welcomed!

Disable the “Imapi Burn Engine” in system services too.

Right, I’ve disabled the ‘Imapi Burn Engine’.

If i just uninstall the IDE drivers, and restart the computer, will they reinstall themselves?

Thanks again for the help.

OK, i’m sooooo confused!

I’m just gonna outline whats happening when i double clck on the drive icon:

CD’s seem to be working fine, be it music CD’s or data CD’s

Proper DVD films don’t work at all! I get an error message sayin “Please insert a disk into drive D:” every time, even with brand new DVD’s

Data DVD’s seem to work sometimes. I have one with a few documents on it, and it always works, but ones with video files on them don’t seem to at all! (all using the same brand disks.) I don’t know if its anything to do with the amount of data on them, cos it seems that the ones that work don’t have much on them, but that may just be coincidence.

The weird thing is that I have some VCD’s and these won’t open when I double click on them but will play in PowerDVD!!! If this makes sense to anyone please shed some light on it for me!

Just a quick update.

I managed to get the volume label and icon to work! It’s still having issues with DVD’s though. I also noticed a clicking sound when it’s trying to read the disk.

This proves that the trouble comes from the OS/explorer.

It’s not the best reader and if the source media isn’t that good (even if its a pressed DVD), then the drive re-syncs and re-reads (clicking).

I had very similar problems when overnight my drive stopped recognising CD/DVDs through Windows Explorer. Whatever i stuck in returned ‘Drive not accessible’ or ‘Cannot read from disc’ errors. No file browsing, no autoplay or software installation from discs. Downright pain in the rear. Oddly Nero and WinXP would burn discs, and WMP/PowerDVD could access and play media just fine. Further alarm bells went off when an install of Daemon Tools would mount ISOs I knew to be good, which then became unreadable via Windows Explorer (drive not accessible), suggesting something core in Windows had gone belly up. Borrowed a friends CD writer, slapped it in, it functioned precisely once then went the way of the NEC2500a.

After a month of fruitless Googling I caved in and nuked the OS with a full reinstall, and now everything’s good. Don’t know what caused it, and don’t know how to fix it in Windows (and i tried pretty much everything). If you don’t fancy a complete format/install you could try a WinXP repair from the repair console.

OK, i managed to get a couple more burned data DVD’s, with varying amounts of data on them, to work. But I’m talking like 2 out of 20! This seams a bit strange, and none of them were particularly more scratched or dirty than the rest.

But real film DVD’s are still not working at all!

I’m starting to go a little bit mad!

Please help.

Re-install the OS.

(final advice)

How did you solve the Icon - Volume label issue?
I just build a new computer (Windows XP, Athlon64 3000+), and had exactly the same problem with my Asus dvd-burner (have to restart my computer to refresh icon and volume label …).
Have a fresh install of Windows XP SP1.

Found the solution:

Google for Autoplay Repair Wizard. Fixed the problem within a minute !!

Sorry, must be