Warning: BTC1108 B230 firmware kills drive

vbimport

#1

Title says it all.
FW update software was fine, then drive began flashing on the LED.
Started to make funny noises too.

Reboot (Start -> Shutdown -> Restart) and computer came back, drive still flashing.

Hard reboot (Start -> Shutdown -> Shutdown) and the power back on again. Computer refuses to boot with drive connected.

Tried drive on another system. Will not be seen on the system where it would boot.

There is no way to fix this. The drive is fubar’d all to hell

Good job BTC.


#2

Aren’t the BTC drives based on the mediatek chipset? If so, they can be flashed from a DOS prompt when the drive is so fubared it cannot be recognized by ordinary means. See this page:

http://dhc014.rpc1.org/howto.htm


#3

BTC recovery page


#4

Nope. Doesn’t work. The drive is hosed.
I tried several methods, several version of everything.
Nothing phases it. It’s locked on the write light.


#5

On some Liteon drives the eject button must be pressed during power on to get mtkflash running. It is worth a try.


#6

I took it back to the store and got a new one. It was only a day old.
Since I use it mainly as a reader, not a writer, not worrying about it.
It works fine on 030 right out of the box.