W98SE loathes LTR52246S software

vbimport

#1

I’m not a complete newbie, but surely I’m missing something obvious here…

The LTR52246S drive itself has installed fine, hardware-wise. Then I installed the software (Nero etc.), tried to use it, it hung W98SE. I rebooted… Windows then started repeatedly hanging on the second or third command after any boot-up, even a command as simple as opening Windows Explorer.

Removed software. The problems remained.

Tried installing software that came with my old drive. The problems remained.

Removed that. The problems remained.

Had to do a full reinstall of W98 from fdisk on up. Tentatively tried installing CD drive software at an earlier stage - same problems; had to restart reinstall from fdisk on up.

Tried updating firmware; after a download, I started running the update program, which reported that I already had the latest version. I aborted the update. Problems started again - not at full intensity, but annoying enough. (At least this time I had GoBack running!)

So I have a drive that reads fine, but I can’t put anything to do with writing anywhere near it.

The firmware is up to date, as is the ASPI. No DMA conflicts reported.

Has anyone else had any remotely similar experiences? Anyone any advice? Is there something obvious that I’m missing (other than “send it back”)?

Thanks in anticipation.


#2

Have you actually tried to disconnect the Drive & see if Win 98 boots up okay? What happens if you reconnect your old drive?
Just a suggestion to eliminate any suggestion of a faulty drive/or IDE port.


#3

Looks like a RE-re-upgrade of ASPI - reinstalling exactly the same version - has cleared things.

Now all I have to worry about is that it maxes out its burn speed at 4x, but I seem to remember seeing something about that elsewhere, so I’m hoping it’s common enough and its fix simple enough.