W98 and LiteOn 812S - a bad match?

I picked up a Liteon 812S from newegg and I’m almost convinced this sucker is DOA and before I return it to them I wanted to see if anyone knew of any issues with W98 with the 812S and nero burning Rom 6.

I could not burn any discs at first until I changed the firmware to US0Q (released 7/22/04).

My system is 750Mhz Athlon, 640Mb RAM, W98SE, ASPI 4.6, my motherboard’s IDE-1 is running a primary and slave hard drive, IDE-2 with the 812S as master and CDROM as slave (yes I tried just running the 812S with no CDROM on the IDE channel). The promise card is running a single drive 60Gb Maxtor. I have one IDE slot open on the promise card.

812S is set for DMA support. Yes it’s a 80 wire ribbon cable.

I made 2 DVDs this morning at 8x and both worked ok (data discs) they both burned w/o incident, and the data appeared on the drive when I double clicked the disc from My Computer.

I then proceeded to make 3 coasters, 2 8x and 1 4x, they were unreadable. Then I rebooted.

Now the discs I made earlier today show nothing when I click on them in my computer - the drive just won’t read them. I think this drive is busted, but wanted to see if anyone else has witnessed or heard of any problems like this.

I already have an RMA # to return it, but wanted to see what the forum thought. Any comments or “just return it” messages are ok.

Thanks in advance.
zen

The 750 CPU is a bit weak for my taste - however, at least, make sure your burner’s irq is not shared with any other device like video card, sound etc.

my 2 cents

steve

Well IRQ steering is enabled on the PCI bus in system settings.

Any other ideas?

zen

…and this (irq steering) does mean to you that everything must be OK?

I do not see any IRQ conflicts - at least none that are obvious. If you want to give >>specific<< advice I’m all ears.

zen

Oright, assuming your mobo is not really as old as your Win98 CD - a clean install of Windows 98 can really make a difference (no joke!). I’ve worked some 5 years with 98SE and installing from scratch solved most nasty problems for me. :iagree:

I’m not a real big W98SE expert, but I double checked the IRQ settings.

While there are no stated conflicts in the device manager, I did see multiple devices on IRQ channel 09, 10, 11, and 15. 00-15 IRQ are filled.

09 - ACPI IRQ Holder for PCI IRQ Steering
09 - AMD 756 PCI to USB open host controller
09 - SCI IRQ used by ACPI bus
10 - Win9x-ME Promise Ultra100 TX2 IDE Controller (recently installed)
10 - Creative SB Live! Series
10 - Texas Instrumentss OHCI Compliant IEEE 1394 Host Controller
11 - ACPI IRQ Holder for PCI IRQ Steering
11 - ASUS AGP-V6600 SGRAM V 6.31c
14 - AMD 756 PCI Bus Master Dual IDE Controller
14 - Primary IDE Controller (dual fifo)
15 - AMD 756 PCI Bus Master Dual IDE Controller
15 - Secondary IDE Controller (dual fifo)

And yeah, this computer is old - but I can’t update it anytime soon unless I absolutely have to. I suppose I could get a new case, MB, chp and RAM in teh AMD family for about $400 and rebuild it with the parts from this one, but if I can get the damn DVD-RW to work on this one, I’d be even happier.

zen

Hmmm, IRQ 10 shares 3 devices - not so good (bottleneck)
Hmmm, IRQ 14,15 says they are (dual fifo) - this normally means not DMA

u sure DMA is really working on your system? wait, I am just starting my wife’s computer still running 98SE to compare. Yes, that dual fifo should read DMA or UDMA if this mode is active. Something fishy going on in your box. Does the device manager/ hard disk controller/ primary and secondary controller do show udma or dma modes? (not fifo?)

Yeah you have touched on an issue that I have been trying to determine since I started using UDMA cables on my hard drives (is the dang MB DMA complient?)

I checked my Hard drives, the only one running in DMA mode is the maxtor 60GB which is now running on the promise card, the transfer rate is just under 11,000Kb/sec which is fine.

I was debating putting the DVD-RW (master) and my CDROM (slave) on IDE-4 on the promise card to see if it made a difference. But I do not know if it’s a good idea. I could always run the DVD-RW to IDE-4 and leave the CDROM on the MB’s IDE-2 just to have a (primary) master CDROM. Think it’s worth a shot?

And get this… last night after rebooting after checking my IRQ settings from the previous email the DVD-RW started reading my data discs, and it burned a new one. Left the computer off all night and when I fire it up this A.M. it also continued to read the discs…

I think I have a conflict somewhere in the either the MB or DMA settings now.

I checked the DVD-RW and it’s enabled in DMA mode, and so is the CDROM, but it is running on my motherboard’s IDE-2… Weird. According to what you said the (dual fifo) settings means it’s not DMA complient. I wonder if I need to see if my MB needs a new set of drivers, I built this system in november of 2000 - and to be honest, I am not sure what MB it is anymore.

Think I should move the DVD-RW and CDROM to the promise card and see if the problems go away?

The last time i had a problem like this it meant it was time to upgrade… I can’t believe how cheap the AMD MB/Processort combos have gotten lately. To be safe, I’m going to be pricing out a new MB, chip and 1GB Ram today.

As well, any thoughts on getting the 3 devices on channel 10 freed up to differennt IRQs? I imagine the possibility of these coming into use simultaneously could be the root of most of my problems!

10 - Win9x-ME Promise Ultra100 TX2 IDE Controller (recently installed)
10 - Creative SB Live! Series
10 - Texas Instrumentss OHCI Compliant IEEE 1394 Host Controller

Oh and thanks a lot for your help, I appreciate it.

zen

certainly, yes, but it would help to know which brand the mobo is. (Re)Installing the right chipset (ide) driver might get your devices in (U)DMA mode again. Once u know which mobo brand you have u can download the appropriate ide driver from manufacturers website, install it and most likely your ide devices will be back in, at least, dma mode.

Yes, nobbad idea, but i would try the aforementioned first since it would be the easiest way.

FIFO mode means snail mode = PIO mode in terms of 98SE
As I said before, best thing open the case and see what mobo you have - should be printed somewhere on the mobo. Moving the CD drived to the promise card might do the trick - it’s worth a shot BUT installing the matching ide driver for your mobo will do the trick as well.

Definitely, your best idea since invention of sliced bread :slight_smile:
You seem to be same type than me - we stick too long to medieval technology.

Yes, I agree, to have an ide controller and soundcard share same irq is not a good idea. The firewire controller can be a problem as well depending on what device u have connected to it. 98SE has a special problem since day one, you can free up IRQs by going into your mobo’s bios and disable (for example) the two serial ports IF not in use - this will give u IRQ 3 and 4. You also can disable the LPT1 (printer port) if not in use - this would free up IRQ 5(7 if LPT2). However, 98SE is unable to rearrange the IRQs once it is installed, u would have to clean install SE to get it done - not a nice thought, eh? However, just try it - and see what SE is doing on your box…

Easiest way, and best bet would be installing the correct chipset ide driver for your mobo and leave everything as is - this will enable DMA on the mobo ports and problems might vanish as well. Your choice :bigsmile:

Steve

Thanks again. I’m going to rip the case open and see what MB this is, it’s a computer show special (no name brand gateway logo with award bios on it)…

I’m going to get out the bright light/magnifying glass to check it out.

I priced out an AMD 2800+ with a new MB for $140 bucks, 512Mb of PC2100 RAM for $60 and a whopper of a SATA Maxtor 200GB HD with 8MB cache for $160… ought to be all I need other than a new a case ($58) and a power supply or dongle adaptor to power the SATA drive. Ought to be stylin for $360.

I also priced out an ATI All in wonder pro 9600 (128MB - svideo/compsite jacks) for $135! cheap cheap cheap, and only marginally slower than the 9800 version.

A 2.2Ghz rig for under $450, now we’re talking…

Thanks, I’ll let you know how my old MB upgrades go before I build a new rig.

zen

Well I found out it’s a Gateway branded JABIL KADOKA E201074 (Gateway sku: 4000594) motherboard. I was able to upgrade the BIOS to the latest version which helped some - the weird part is I went to AMD’s website and downloaded their driver package to make the (dual fifo) settings into the UDMA 33/66 compatible ones this board is supposed to be capable of handling.

Well everything was going ok and the BIOS recognized the drives as S.M.A.R.T. UDMA 66 drives on bootup and then the machine loaded into windows and asked to restart for new settings to take effect. I rebooted and it did the same thing again (reboot for system settings to take effect), and it did it again, and again, and again.

I finally said “NO” when the prompt message came up after the 4th or 5th reboot, and I removed the IDE drivers in device settings and rebooted, and the machine hung on reload - but did say in the startup screen that both drives were S.M.A.R.T UDMA 66 drives, but disabled. Went into safe mode, and uninstalled the IDE drivers with the AMD software that I installed them with, rebooted, and dual fifo came back up as the default.

I’m going to try a few different configurations, and move the boot drive to IDE-1 and the CDROM to IDE-2, and move the two newer hard drives to IDE-3 as a master and slave, and the DVD-RW to IDE-4 and see if this helps.

I think the conflict might be the original 5.4GB Maxtor drive at 5400rpm is not DMA complient and causing the conflict.

It’s been a learning process to say the least.

More to come.
zen

Make very sure u get the right drivers for your type mobo!

How old is youe Win98 installation?
I believe the conflict is more between the promise controller and the newly installed mobo (ide) driver since they are installed “wrong way”, on top, you installed a new bios as well (Jesus!). The mobo drivers have to be the very first drivers installed - anything else (Promise) goes “on top”. You’re playing Russian roulette with two guns pointing at your head.
If your mobo is a (independent) dual channel mobo the slower Maxtor should not cause problems. If u are up to the task, I suggest to clean install 98SE, install mobo drivers, Promise, and other software – definitely a way out of the mess. The more u try different configurations the deeper u get into the 98SE “swamp”. 98SE is a fairly incomplete OS with many potholes - be careful, 98SE might stop booting! Get all your sensitive data backed up asap!

Steve

Way ahead of ya buddy, I have 20GB of backed up data at this point. There is nothing at this point on my HD that would be terribly missed if I had to do a clean install.

I also have a copy of XP that I’m debating a clean install on a freshly formatted HD and trying that over W98SE… Decisions decisions.

And yes, the system has grown extremeley unstable, I suspected a virus at one point as hackereliminator detected an DLLHOST.EXE file trying to be opened at one point last night, and I had to use defloc.exe to get the virus scan to work at bootup after these drivers were installed. The system is pretty wonky now, wonky but working. BUT, the computer is NOT happy.

I’ll keep ya updated. I’ve tried a few cable configurations, and I am not sure if they really helped or not. I’m running the 60GB HD and the DVD-RW on the promise card, and running my boot 5GB HD and 30GB slave on IDE-1 the CDROM on IDE-2 as a master. I might yank the promise card out, and retry the IDE channel AMD driver install.

The drive did not want to recognize blank CD Media, but it will burn DVDs. My free trial of Nero expired, so I tried to fire up Adapted EZCD creator, and it locks up the system when booted. I’m hoping Nero will have a new trial up today, as I only got 3 days of use from this one before it expired (july 31).

I guess its back up a few more gigs of data before getting ready for a clean install of either 98 or XP. I wonder how Xp will handle this old MB?

I’m not too worried about losing anything terribly important, as the most important thing on this computer is probably my “bookmarks” and some archived video files which are already off the main hard disk. Everything else can be reinstalled…(programs).

More to come. (yuck!)

zen

I hope all your backups are verified afterwards ? :rolleyes:

Since u basically have an ol’ Gateway system - it would be a trial and error task. Depending on your systems specs XP might be working a slower than 98SE. Probably better to stay with SE

Shit is boiling, eh? Ok, get it cleaned - remove all viruses and spyware …and scan your data backups as well or you might restore the viruses :cool:

Again make sure your backups are valid - verify data or you’re doomed to fail!

Backups are all verified.

I went through AMDs website and found the 1.43 IDE drivers for this motherboard, and the same issue came up - the system keeps asking to restart over and over for new settings to take effect, I finally hit NO and loaded into windows to look at the problem.

I think the Promise card’s drivers are preventing the MB’s IDE channels from accepting the new drivers. I’m going to remove the promise card, and reboot and see if the system will accept the new drivers. I’ve enclosed a screenshot to show what device manager is showing me.

I also ran FixIt Utilities 2000 and removed a bunch of garbage from the registry and cleaned a lot of TMP and BAK files out of the computer. Opted out of defragging for now, but will most likely run a defrag and optimization tonight (I dont use Windows defrag, dont worry).

Ran the XP system check, and decided it was more of a headache than it’s worth, about half my software and hardware is incompatible with XP - so it’s 98SE still for this old rig.

Tried to run a clean install of W98SE but it gave me some weird message saying I was “trying to install an older version of W98 over a newer one” which makes no sense, since I’m 99% sure this copy is SE (it’s an archived CD, the original was ruined from scratches). Anyone come across this before?

So many problems…

See screenshot, the computer is running, but the new IDE drivers wont initialize…The drives are useable even with the IDE channels having flags.

zen


Zen, a clean install means that you format(wipe) your HD (c:) first - what u tried was an install over with the original SE CD and these files, in fact, are older. The AMD busmaster driver seems incompatible (wrong one). I feel the situation ur in is a bit much for you to handle, isn’t it?! Is Gateway still on the market? - give them a ring and talk to their support guys to find out which are the correct drivers and bios for your mobo. Be careful what u do. U cant install from scratch until u know u have the correct drivers/bios for your mobo. If ur not used to clean installs better get some knowledgable local help to assist u - it’s notta task for a forum. Too much involved! You need quite some knowledge to get 98SE up and running again.

again, be careful!

Steve

This MB was a computer show special 4 years ago. Gateway has nothing to do with this, other than they manufactured the board, and it wound up on some no-name vendor’s table in march 2000. The updated BIOS came from the Gateway website, and it is the proper version. The drivers are from AMDs website, and are once again, the proper drivers according to AMD.

I only “got in over my head” when I added the new promise card and new Liteon DVD-RW - before a week ago this thing ran like a top. The drivers installed on the board prior to this were the windows default ones (AMD 756 PCI Bridge ((2/1999)).

All I want to do is have the IDE latest drivers (v1.43 (2/2002)) on the motherboard to determine if the DVD-RW is at fault (which it looks less likely that it is with each step), or if it’s a MB driver issue (which is looking more likely that it is).

The issue is why does W98SE hang on the restart, and I’m asking if someone can chime in and say “yeah it’s the promise card”, or “I dunno - good luck dood”.

Right now I’m like a mad scientist - I want to know why these problems exist. I think I’ll figure it all out before I’m done. I’ve fixed worse problems with crappier equipment.

Is the board old? Yes. If the processor old? Yes! Have I done clean installs on other machines? Yes. Have I built other machines? YES!

That being said, I’ll go back to my trial and error methods and hope I don’t destroy the machine in the process - and if I do, I’ll build another one. ;p

zen

Zen, I said already in an earlier posting 98SE does not really like fumbling in configurations and drivers once it has been installed freshly. This is due to the fact that SE is somewhat incomplete in handling the situation properly - something is mounting up in the OS “background” and will cause problems once the “barrel is full”.
Again, the only way out is wipe the hd (format) and clean install 98SE - install the proper latest drivers but the chipset drivers very first as soon as 98 is installed…the rest on top!
Then your box will be up and running again - trust me on that, I did it always once a year as long as I had 98SE since it came out. I agree with u that the burner is likely not the core problem u currently experience.

good luck and keep providing feedback… :bigsmile:

I just hate formatting the drive - always seems to be the “last way out” for me, and the “first choice” for tech support. LOL

Right now I uninstalled the 1.43 drivers, and its running ok. It cant find the original (dual fifo) drivers and is running in “unknown device” mode for now while I muse a few more things…

I have my choice of OS at this point, W98SE, W2000 professional, and XP Pro (corporate) to play with if I format the machine. I want to stick with 98SE (I have another box upstairs that my fiancee uses with W2000 and its ok I guess).

Been diggin’ out CD’s to make sure I have all my video editing software and other crap with the serial #‘s handy to get back on the machine when it’s formatted… I have 20gB backed up on DVD-R now, so It’s lookin’ good. Maybe another 4 or 5 DVD’s of backups and I’ll feel secure with a clean wipe. :slight_smile:

zen