Voices out of Sync

Help - I have 2 xVID avis when I burn them using Nero the voices are out of sync - this gets worse until the end of the movie it is as much as 5 secs out.

Can anyone give me any advice on this as it is driving me crazy :a

I have ran the file through virtual dub which states is has detected an improper VBR encoding and has told me to decompress the audiostream to an incompressed wav file and recompress with a constant bit rate encoder?

And this is exactly what you should do.

So open the file in virtualdub and go to Streams > Stream list. You will probably see one entry in the menu that appears. This entry represents the audio stream. Tell virtualdub to extract the stream, and you will probably get an mp3 file.

Then you have to decode this mp3 file to a .wav. Use any audio tool for this. Even WinAMP can decode an mp3 to a .wav using the Disk Writer plugin. At the end of doing this, you will have the original .mp3 file and a .wav file. You can discard the mp3 because you will not need it again.

Then use any mp3 encoder (I recommend LAME) to re-encode the .wav file. Make sure that you select CBR encoding. (If there isn’t an option, mostly likely CBR is the default mode.) At the end of this step, you will have the .wav and a new .mp3 file. You can delete the .wav because it is not needed anymore.

Then go back into the streams menu for in virtualdub. (Make sure you have that video open.) Delete the old stream and import the new mp3 file.

Then close this menu, and do File > Save As … and for “Video Mode” make sure you select “Direct Stream Copy” . Then you can save the .avi file under a new name and everything should be in sync.

Most of the time but not always the DMA or memory cause sync problems so get more ram and make sure DMA is set and not PIO