VISTA SHIELD on DVDFab Icon?

O.K. I had DVDFab for the 30 day trail and it worked just fine so I purchased it.

Now that I gave it my registration code, the DVDFab ICON has a VISTA Shield on it, and everytime I launch it VISTA ask if me If I should allow this program to continue? I am logged on as an administrator, and I am the only user on this laptop. My DVDFam HD Icon does not have this shield nor does it have vista asking for permission.

How do I fix this?
:sad:

This is normal if you don’t want the prompt message disable UAC.

Microsoft Corporation - Disable UAC

This is normal?

Why was it not doing this during the trail version?
Why are none of the other programs I have downloaded and install not doing this either? Disable UAC might resolve this issue, but UAC disable should not be the solution to the problem I would think.

Windows Vista Security Tweaks
Configure User Account Control (UAC)
UAC should never be turned off. Follow these suggestions for changing UAC settings.
But If you prefer to shut it off. Instructions are at bottom of page
The following procedures step you through the tasks of disabling Admin Approval Mode, disabling UAC from prompting for credentials to install applications, and changing the elevation prompt behavior.
Disable Admin Approval Mode
Use the following procedure to disable Admin Approval Mode.

To perform the following procedure, you must be logged into a client computer as a local administrator.

To disable Admin Approval Mode

  1. Click Start, click All Programs, click Accessories, click Run, type secpol.msc in the Open text box, and then click OK.
  2. If UAC is currently active, a User Account Control dialog box will appear. If so, verify that the details presented match the request you initiated, and click Continue.
  3. From the Local Security Settings console tree, click Local Policies, and then click Security Options.
  4. Scroll down and double-click User Account Control: Run all administrators in Admin Approval Mode.
  5. From the User Account Control: Run all administrators in Admin Approval Mode Properties dialog box, click Disabled, and then click OK.
  6. Close the Local Security Settings window.
    Disable User Account Control from prompting for credentials to install applications
    Use the following procedure to disable UAC from prompting for credentials to install applications.

To perform the following procedure, you must be logged into a client computer as a local administrator.

To disable UAC from prompting for credentials to install applications

  1. Click Start, click All Programs, click Accessories, click Run, type secpol.msc in the Open text box, and then click OK.
  2. From the Local Security Settings console tree, click Local Policies, and then Security Options.
  3. Scroll down and double-click User Account Control: Detect application installations and prompt for elevation.
  4. From the User Account Control: Detect application installations and prompt for elevation Properties dialog box, click Disabled, and then click OK.
  5. Close the Local Security Settings window.

You can also right click the Icon and select properties then click advance untick run as admin and do the same under compatibility and this too should work. I don’t really have that answer for you to be honest.

You can also right click the Icon and select properties then click advance untick run as admin and do the same under compatibility and this too should work.

Tried it and it made no difference. :sad:

StormJumper
I get “windows cannot find secpol.msc …”

This is the only program I have installed that gives this UAC warning and put a Vista Shield on the DVDFab descktop icon. The trail version did not do this :rolleyes:

Is it the way DVDFab is programed? All I want to do is get rid if the UAC warning everytime I launch this program, now is it easier fixed with a DVDFab program code correction, or can’t I just tell vista to allow this program to operate and stop asking me.

Instead of putting a shield on the DVDFab icon, they might as well put hand-cuffs!

Hi :slight_smile:
@
StormJumper, you just love the long way round, don’t you.
@
DREAMLINER, if you don’t want to disable UAC. Then just right click on the shortcut or the icon in the start menu, goto properties. Click security tab. Click on Advanced button & change the Permissions, to either just you or everyone. Click apply & close all windows.
N.B To take full control from system, you have to still be adminstrator too. Everyone dosen’t do this ‘full control’.

zebadee
Under “Permissions” All of them already say “FULL CONTROL”, I do not what it is you are saying to change their. I am in the permissions tab?

Hi :slight_smile:
In the Permissions area, after clicking the Advanced button. Only one is highlighted. i.e. System.
Highlight the one you want. Then click edit. You then have to repeat this. In the window you should now see. Check box Full control. Then click OK. Then Apply & OK in the next window. OK again until all windows are closed.
P.S. I was led to believe this wouldn’t work for Everyone (All Users). But it appears to do so.

N.B. In the ones where you already have 'Full control. note the check boxes are greyed out. Yet if you edit to give ‘Full control’. Even on return they remain as originally edited. (Not greyed out). Whether this greying out causes problems, I don’t know. As I have UAC disabled anyway.

zebadee
"Full Control" is already checked on all of them including System, and they are all greyed out. nothing for me to change here?

Hi :slight_smile:
Try editing one. Once this is done it appears that they are no longer greyed out.
As I have have UAC disabled (& currently doing something that requires this) I can’t tell if that will make any difference, other than cosmetic.

Edit to what is me question, if they all say “Full Control” already what am I changing it to?

Hi :slight_smile:
I realise your question.
My answer, is obviously not clear enough.
Remove all rights, close program.
Then open program & re-apply rights.
Do this for everyone. Not Admin.

Dear all,

New version of DVDFab will not ask administrator privilege at start up, it will only ask when needed.

Best Regards,
Fengtao

Dear fentago

I am using version 3.1.8.0 and am still having the same issue with VISTA.
:sad:
Thanks

zebadee
I Removed all rights to all except Admin
Close program
Then I open program & re-applied rights

Results:
No Change. I still have the VISTA SHEILD of the DVDFab icon on the desktop, and I still get the UAC warning questioning this program. I have no other programs installed that does this only DVDFab Platinum, my trail version did not do this and my DVDFab HD does not do this. It started after I purchased the program and entered the registration key. :confused:

I have also turned Off (UAC)
Rebooted
Applied reapplied Fab DVD key
Turned on (UAC)
Rebboted again

Results:
No Change

I have also turned off (UAC)
Uninstalled DVDFab with its own uninstaller
Rebooted
Downloaded new DVDFab file
Use the DVD fab registration key
Turned on (UAC)
Rebooted

Results:
No Change

I have also Restarted the computer in SAFE MODE
Re registered DVDFab Platinum
Then Rebooted back to normal mode

Results:
No Change

try this please I have had the same problem uninstall dvdfab first reboot and search for any reminants and delete now turn off UAC and reboot now reinstall dvdfab and the shield should be gone do this in the exact order as I posted.
good luck!! :slight_smile:

Dear all,

Please try DVDFab 3.1.9.5 Beta, you don’t need run as administrator every time now:

http://club.cdfreaks.com/showthread.php?t=228388

Best Regards,
Fengtao

Yep, confirm the problem is gone with the release of 3.2.0.0 :smiley:

Problem fixed with new DVDFab Version!!!
THNAKS :bow:

Could somebody explain the need or purpose of the new auto-play feature?

I realize that this has been fixed in the latest version. Thank you!

However, I figured that I would shed a little light on the subject, since I have contended with this issue on other occasions.

You could spend some time reading the MS help page on UAC:
http://technet2.microsoft.com/WindowsVista/en/library/0d75f774-8514-4c9e-ac08-4c21f5c6c2d91033.mspx?mfr=true]Microsoft UAC Step By Step Guide
However this one little item may change your mind:

Important:
Advanced configuration options for UAC are not available in Windows Vista Starter, Windows Vista Home Basic, or Windows Vista Home Premium.

And Again smack dab in the middle of another list of instructions on how to disable Admin Approval:

This procedure is not supported on Windows Vista Starter, Windows Vista Home Basic, or Windows Vista Home Premium.

So unless you have Ultimate it looks like you are SOL for any other UAC option other than Off, or On.

If anyone has a workaround that they have been using I would be interested in hearing about it.