Vista issue with NEC3500 and NEC3550 dvd burners

vbimport

#1

I have these 2 dvd burners and recently upgraded from XP to Vista. The Vista DVD installed fine and the 2 drives worked in Vista for a while. Now, however, the Device Manager shows them with a warning, indicating that Vista cannot initialize them. I’ve tried uninstalling them and letting Vista re-detect them, but I get the same warning. The “search online for a solution” didn’t find anything either. Am I “hosed” until Microsoft patches Vista for this, or does anyone have a suggestion?


#2

With the Plextor 716 drives, I know Plextor is releasing a firmware update so their DVD-RW will be compatible with Vista. There might be a similar method for the NEC drives. Maybe you should check NEC’s website for firmware updates. Otherwise your drive should typically work properly in Vista. All my drives work fine so far. Otherwise you might be hosed until MS releases a patch or update.


#3

Thanks for the reply. The NEC3500 was already at the highest firmware version. There is an updated firmware version for the NEC3550… I’ll need to move that drive to a different computer to upgrade it.


#4

You’re not the first having a problem with this drive in Vista: http://club.cdfreaks.com/showthread.php?t=207434


#5

Vista cannot initialize them.

Surprise surprise


#6

I resolved my issue last night! I swapped an NEC with a cd-burner and it too wasn’t initialized. This told me it had nothing to do with which optical drive(s) I had… glad I didn’t just order another drive. I then googled the exact error message from the Device Manager (Code 37) and found a registry edit to fix this. The edit was to remove the “UpperLimit” and “LowerLimit” for something (can’t remember now). Anyway, if anyone else has this problem, just go into the device manager, copy the exact error message and paste it into google. Then look for the website that has this listed as a “Question” with the “Answer” being a registry edit that asks you to (1) export your current registry, (2) clear those limit values and (3) reboot. Thanks to those who replied for your help! This was my first post on this site and I’ve had a nice experience. Maybe this thread will help someone else some day. PS – I also [I]suspect[/I] that restoring to a previous restore point would have resolved this issue. Since I’m new, I don’t know how to close this thread… I’ll see if I can find how, but if someone else can, that would be a good idea since this issue is now resolved.


#7

Thanks for the info [B]Driveshaft[/B] (very useful)
The thread is best left open as more people may post perhaps other methods of fixing this issue.


#8

Yeah, the XP registry fix works for Vista (32 bit in my case). It resolved the issue I was having with my OptiArc DVD drive (NEC drive?). This is on my Dell Inspiron e1705 Core 2 Duo. Strangely it only had an UpperLimit and no LowerLimit.

http://support.microsoft.com/?scid=kb%3Ben-us%3B314060&x=12&y=13

:bigsmile: