Vista has corrupted/crashed my system!

vbimport

#1

I have 8 hard drives on my 2 year old self built athlon system. Most of them have two partitions. One for active booting and playing with OS like windows and Linux–the other for data.

Yesterday, I could set which harddrive/OS to boot from by setting the order in my bios. Yesterday, I installed Vista Home Premium to a spare partition and it was up and running without any real issues to mention but right now I am not committed to it until I find software that drives all my requirements (like sound from Soundblaster) --so I disconnected the hard drive totally from my system and reinstalled a hard drive with XP on it that was working perfectly yesterday.

Today, none of the 8 hard drive boot partitions will work. System will post and show the hard drives but then freeze further on in the bootup at various stages. I then swapped the XP hard drive with the Vista hard drive that worked yesterday and YES, here I am with a working Vista boot partition trying to find out how to get back to what I had yesterday. While initial post shows my harddrives, not all of them are shown after Vista is running AND none of the non-Vista drives show any content–ie no folders or files are presented. The total size used and available are shown in total, but no individual files are accessable.

My only idea is that somehow the bios has been corrupted and needs to be reset:???–like take the battery out for 30 minutes??? I don’t think even reinstalling XP would work here but I might give that a try first as the “more ususal” thing to do?? I’ve read several articles on getting Vista and XP/Linux in a dual booting system and no one has mentioned my type of problem.

Any ideas on what has happened, how to fix it, how to avoid it in the future?
I could write my signature in CAPS now, but instead will continue researching. Any ideas/thoughts is appreciated. /// Bobbo.


#2

Vista installs its own bootloader…it does not rely on boot.ini. Since Vista won’t boot from boot.ini, the way legacy OS’s are handled is that you are presented with the Vista boot screen. If you select a legacy OS like XP, the Vista bootloader then passes the boot process to the “old-fashioned” boot loader.

I would put the Vista drive back in, and make sure you have the same setup that you had when you installed Vista. That should restore your configuration.

Also, download EasyBCD, which is a nice free editor for the Vista bootloader. It should help you restore your original boot configuration.


#3

Thanks HA–I think you are on to something - - but- - I removed all my hard drives and installed Vista on a single harddrive using the 0 Channel, Master Position. When I was thru experimenting, I swapped that Vista Hard drive with my old XP hard drive and reconnected about half of the other hard drives. I tried to isolate any corruption that might arise.

In the above sequence–it seems to me that the bios/cmos on the motherboard is the only “common” element?? ((or the controller for the ide channel??))

That said, I did return to the Vista only setup and it worked as it should. Then I attached 3 of the other hard drives–all seen during the post, only two seen after Vista is running and both of them reveal NO FILES available.

I think that covers your EXCELLENT idea and something else is amiss–maybe interacting with that Vista boot loader issue?? Looks like isolating the hard drive doesn’t guarantee no hassles–maybe I do need just a whole different computer to try this out??? Hope all 1.2 terrabytes of info is still there and ultimately I can access it?

Again, excellent and explain again if what I did missed your point. Other ideas? /// Bobbo. ((Yes, I will post on resolution of this–even if its to build another system with more RAM and a better video card!))


#4

I don’t know if this will help in your case, but many people use VistaBootPRO.


#5

Hmmm. So if I understand correctly, when you installed Vista, the only hard drive attached to the system was the one you installed Vista on? If so, that is a much stranger issue than the bootloader issue I speculated upon.

The only thing that makes sense is that the BIOS reset the hard drive boot priority when you removed the 8 drives in favor of just one. You may have to reset the boot priorities in the BIOS after re-attaching the rest of the drives.

Still, it doesn’t make sense that you can’t see the data. That should not be impacted.

Worst Case, you could install XP on a clean drive or partition while the other 8 (or as many of them as possible, at a time) are connected, and they should certainly be accessible at that point.


#6

Can you open your “Disk Management” in Vista…so we can see which partitions are logical, primary, etc…



#7

Hurricane–glad to see you see the problem same way I did. I tried to prevent all issues by loading Vista fresh onto a single drive and then removing that drive when finished. THATS what is so frustrating==and “something” has moved off the hard drive into the rest of the computer–bios or controller most logical.

Boot priorities have been checked and rechecked. Plus it shouldn’t be an issue to begin with as the active boot partition should have been and was (the best I can tell) the 0Channel Master Drive. When it didn’t work, I did reset the bios to boot from some of my other partitions, but they were unbootable as well–again, something that shouldn’t happen.


#8

Hyperspace–I don’t think a boot manager helps anything ((but if I miss your point, please direct me further)) as my system does boot from Vista and simply isn’t showing the data partitions in my other drives.

Yes, I did look at disk manager and as stated, only two of the three drives appears there. The two other drives are Fat 32 data drives without any OS on them BUT while showing they each have about 100 GB of data–when opened they report “There are no folders” and none of the recorded mpg files from my Liteon are visible or can be accessed.

When I take the Vista drive off my system, then none of the other OS’s will boot past the initial POST. I don’t think a boot loader would address that issue. Tell me if I am wrong. THanks. Any additional ideas/thoughts greatly appreciated. /// Bobbo.

PS–I’m trying to get a picture of disk manager like the one you posted and so far all I can find is the device manager. I’ll post when/if I find it. Easy in XP–I’m only 20 hours into Vista (smile!)==Found it. I can print screen it but can’t copy to this posting. It reports every partition as “healthy.”


#9

Right click Computer> Manage> Disk Management

Two quick ways…



#10

Well, I thought to run my system from my Knoppix 5.1.1 disk. It showed all the attached hard drives and their contents==while Vista would not, and while XP would not even boot.

I then took my Vista disk off-line again and reconnected my XP hard drive. No difference from what I reported above. Then I took one of the hard drives with XP and moved it around by itself on different cables. It is now working off of Channel 3 Master ((on my add-on 2 Channel IDE pci Controller Card.)) It won’t work if another hard drive is attached and it won’t work in Channel 0.

As always, too many variables and faulty observations to be definitive, but I think I have a continuing issue with “BAD CABLES.” I’m going to FRY’s and buy a bunch of brand new flat cables and replace them all and keep my fingers crossed. Will report back. ((and I still do think that boot.ini issue is still something that might have started all this–ignorance is like that!!)) I’ll report back in a few days after reinstalling/testing everything. If this hard drive weren’t working, my next move was going to be to go into recovery console and see if fixing the bootcfg or bootmbr files would fix things up. Don’t think thats it though.

Thanks for all the good thoughts, and keep em coming if you have more thoughts. How does one get jpg image into a post?? //// Bobbo.


#11

Think I’ve got the attach jpg command in the advanced section. I’ll use it in the future.///bobbo


#12

MY resolution–lots of time on google and with tech departments. While there are “always” too many variables to be sure, my conclusion is==

  1. Round cables more likely to corrupt data.
  2. Leaving hard drives connected to computer thru the data cable while removing the power cables is more likely to corrupt data.
  3. NTFS file system more likely to corrupt data when the same data is repetitively added and deleted in an “unbalanced” way. (Such key term not defined.)

When computer started up and found corrupted data, it went ahead and ran chkdsk to delete it.

Rebuild my system with flat cables and external usb boxes and keep my fingers crossed. Thanks for your all help. //// Bobbo.


#13

Are any of these drives SATA?

Did you have PATA controller emulation enabled for your SATA controllers previously, and when you reset your bios set it back to SATA native?

Did you change drivers for IDE controllers?

Although you say you’ve solved the problem … has it been solved, or has it just not turned up again ? :wink:


#14

Debro – sorry for late response–no email notice was given. To your post:

Are any of these drives SATA?//Two sata drives, one pata in a removable caddy, and two pata on motherboard ide controller have been corrupted. The external pata and sata usb connected hard drives have NOT been corrupted (yet) and neither has the boot drive which is a pata drive on an added ide controller card.

Did you have PATA controller emulation enabled for your SATA controllers previously, and when you reset your bios set it back to SATA native?///During the time at issue, I did not touch the sata or pata controllers. The Sata drives were set to non raid JOBD.

Did you change drivers for IDE controllers?///No. But I like your notion that this sounds like a controller issue–but as usual, I don’t know enough to say that with any authority.

Although you say you’ve solved the problem … has it been solved, or has it just not turned up again ?/// I didn’t say it was solved–only that I reached my private resolution and my fingers were crossed. Since then, Vista won’t boot so I removed the hard drive that contained Vista and am back to the hard drive partition that had XP Pro SP-2 that is only about 3 months from original installation. System does not crash now but on initial boot every 5-6th time, chkdsk runs and deletes anywhere from 1 to 30% of my files. Name of file remains, but it has zero bytes of data. File recovery programs can’t recover anything. One Sata Hard drive was left with 50% unallocated space. I reformatted this drive and recopied the data to it and after two days, the same thing happened all over again. As this is happening to 3 drives, I’m thinking its not a hard drive issue (Seagate and Windows tools report they are healthy). A bad controller for the Sata drives might be an issue as might some kind of interaction between the Sata Drives and my removable caddy drive–or the cables that connect them. I run AVG and have performed 2 web based virus searches with no joy. Just too many variables to know. Anything else come to mind??? /// Bobbo.


#15

Ok–I have just removed, cleaned, and reinstalled every peripheral in my computer except my cpu. I reinstalled each component one at a time and power cycled the machine. When I installed my dvd burner as slave to my hard drive caddy, the computer went black and rebooted. I tried different cables, caddies, and different caddy holders and confirmed jumper settings. The system reboot behavior remained--------so, I put the caddy as master alone on its own ide cable and the dvd burner as a slave on another channel. Everything worked. So–some kind of short or incompatibility has “evolved” in my system. It worked as it should for over a year before deciding to misbehave. A month ago I changed cables and ide channel positions thinking they had gone bad but that wasn’t it.

Now with a stable hard drive caddy, I HOPE all my other problems will go away (and why shouldn’t they???). Then all I’ll be left with is ignorance as to how such things happen and a very messy case with terrible air flow. If machine becomes stable and doesn’t lose anymore files, its a tradeoff all of us would make!

Sad that every added “thingy” (except my addon ide controller card - fingers crossed!) I’ve made to my computer has basically not worked and had to be worked around. Again–don’t know if this fixed it or it just hasn’t acted up again, but a major fubar was finally recognized and fixed. Wish me luck. //// Bobbo.


#16

Problem with VISTA

Win Vista is not run for smooth, if you don’t know how to install some softwares and Drives. First, you have to BOOT DVD from DVD rom restart computer ( remember choose First boot dish from DVD rom. after flowing instruction and partition hard drive ( uncheck mark automatic activation ).
Second time , after windows becoming for the first play, connect internet to download the Dive for SOUNDCARD from the instruction of windows …
Finally, checking everything working ok! inside system by right click from MY COMPUTER at properties and devide manager…
Importance, using Acronis to make IMAGE va save it in the second drive partition. Continuos to install every softwares…and checking windows again each times you’ve installed…Remember making IMAGE OKIE>
Good Luck


#17

Make sure the removable caddy is a Slave device (not master), and is NOT at the end of the cable.


#18

Hey Debro- - you are blowing me away with your expert opinion. Right now, the caddy is alone on its own channel as Master and everything is working so far after 3 reboots. Course, the Caddy sat as Master with a dvd drive as Slave for about one year and ran just fine until these problems started about 6 months ago.

I’ve googled and read various folks comment on how Win98 especially had problems with the position of cd players–but Win XP was not mentioned until your advice.

The caddy is so I can edit material recorded in my Liteon 5045 hard disk recorder on my computer. The caddy in the computer gets swapped with the caddy in the Liteon when the liteon is full. The hard drive “has to be” set as Master to operate in the Liteon and the purpose of the caddy is to avoid having to set jumpers and manually attache plugs and so forth—so I think it “has to be in the Master Position”–and it DID work for over a year.

Assuming you are right, in your experience, how does a conflict on Channel 1 cause drives on Channel 0,2, and 3 to become corrupted? I respect your time so don’t waste it if the variable factors exceed 10 to the 256th? —Note, if my current set up works, I won’t change it. If it fails, I will do as you suggest. Other forum told me that my experience was “impossible” with drive conflicts and it was a virus. My own lack of expertise, but general negativity, tells me it could still be “both?” thanks again!!! //// Bobbo. (((I am curious—why isn’t the caddy simply seen as a hard drive and act like it??? or does it and the position of the dvd burner is what actually controls??? --ie, most two channel set ups contain two hard drives–one of them being a Master???))


#19

An IDE chain requires a device at the end of the chain to maintain the required impedances (to minimise signal reflection). The caddy, I’m assuming, is just a dumb connection to the HDD, rather than intergrated electronics /etc.

In this case, if the HDD is not installed, the chain isn’t properly terminated and it may cause data/signalling errors for the slave DVD writer. On top of that, the Master is responsible for controlling the channel, and while often the slave will still work, many won’t - especially at higher speeds like UDMA33-66.
In either of these cases, god knows what information is being received by the controller. Technically the controller should be controlling where everything is going, when using DMA mode, so it shouldn’t cause issues wih other devices or conflicts in the RAM. But there may be bugs with drivers which have never come to light except when vista fires up, loads generic drivers & cops corrupted data/instructions from the optical drive.

As far as the Vista install goes, if the drives were disconnected when it was installed, vista cannot destroy the data on them (obviously).
The potential for corruption occurs at the following points though:
A) When you disconnected them, you have stored them next to a magnetic source which affected the drives (possible but unlikely) like your CRT monitor.
b) When you reconnected the two PATA drives to the motherboard, you have inadvertantly connected them to the wrong chains & have set the access methods & size manually, or the bios has either “AUTO” redetected them and has used a different method to access them (CHS / LBA / LARGE) ,and when read has corrupted the mbr/FAT in ram only … which makes it look like the drives are blank.

In any case, so long as you don’t perform any writing operations on the drives, the data should still be there, you just need to try the different access methods & ensure you have the correct sizes detected.

The last thing is possibly the IDE cables have been damaged when you’ve disconnected/reconnected them … replacement of them should fix the issue.

So summary … to try:

Caddy/HDD is to be master & is to be the only device on that IDE chain.

Replace the IDE Cables (no round cables).

Re-Detect the Drives in the BIOS (autodetect) for the size, then manually try LBA/LARGE/CHS … do NOT write to the HDD’s until you have verified the correct method … for a few days :wink:

Check if you can download updated Vista drivers for your IDE controller.

And worst case scenario … run a memory checking utility to thrash your RAM and check that it’s not the cause of the issues. It’s a common problem which goes unnoticed and you don’t realise it until you lose something.


#20

Thanks Debro–sure are alot of variables aren’t there??? Seems like the more I learn, the bigger/stranger my problems have become. ((Yours must be "enormous!))

While I’ve only had 3 reboots sofar, I am keeping a positive attitude that I had a caddy-gone-bad and the fix was putting it on its own cable. Got to catch up on routine use issues and then I will retry the Vista reboot, sticking with XP for now. I’ll post back if problem continues. Thanks for your detailed and informative response. All I really want to do is just “use” this machine, but it keeps fighting me. /// Bobbo.