Vista DMA issue

I have installed vista home premium 32 bit on my laptop. I recently installed a different DVD burner drive and for some reason it will not let me put it in DMA mode.

I click advanced settings under my ATA Channel 1 properties but the box that says “Enable DMA” is inactive. I can’t click it!

Any ideas?

Does it tell you what mode it’s running in at this moment in time? Perhaps it’s already running in UDMA mode, and you just can’t select it to downgrade it?

In device manager, delete the ata controller (not just the primary/secondary channel), and reboot the PC.

It’s also possible, you aren’t using the correct driver. Maybe try downloading the specific driver for the particular IDE controller chip you have?

I’ve tried the manufacturers driver and windows default drivers and it still won’t let me use DMA. The picture below is what I’m getting:

http://club.cdfreaks.com/attachment.php?attachmentid=185994&stc=1&d=1244167246

The drive works but it slows the computer wayyyyy down and takes forever to do anything.

my old drive worked fine but I gave it away b4 I got a chance to test this one :frowning: which is stuck in

PIO mode 0


[QUOTE=debro;2287137]In device manager, delete the ata controller (not just the primary/secondary channel), and reboot the PC.[/QUOTE]

Did you try this yet?
You need to uninstall/delete the Intel 82801GBM ide controller.

Are you using an 80wire cable, or are you using the older style 40wire IDE cable? This has been identified as a common problem.

Is the device a single device? If so, it should be set as master, and be connected to the last plug on the IDE cable.

Its on a laptop and uses the standard slim-drive connection. The drive itself has no option for master, slave or cable select.

Also I was warned not to delete the IDE controller as it can cause my computer not to reboot???

[QUOTE=cartpauj;2287728]Its on a laptop and uses the standard slim-drive connection. [B]The drive itself has no option for master, slave or cable select.[/B]

Also I was warned not to delete the IDE controller as it can cause my computer not to reboot???[/QUOTE]

They almost never have, its forced by the used firmware.

Thanks for the help so far guys!

Does anybody have any ideas for me? I really want to get DMA working on this drive so my computer isn’t so miserably slow whenever its in use.

I had the same problem a few yewars back and have always saved this sight. This will change your PIO to DMA.

http://winhlp.com/node/10

Good luck!

rene636,
thanks for the link. I tried but still no luck. I also tried the manual edit but there was no …checksum values in either of the 0001, 0002, etc. directories.

I think my laptop HDD and DVD are on SATA but I’m not sure if that could effect it at all???

cartpauj, You know, it took me a year or so (well, a bit longer) to figure the problem out that you are having. But I had XP then. The main reasons that this happens is when you have Nero installed and then uninstall it (that is a major cause) or it could have been a bad disc. But usually it is Nero that changes your DMA to PIO in your IDE. I will try to do a little more research for you.

Another thing you may try… Have you tried changing the new DVD burner to the master or is already it set as the master?

It’s worth a shot anyways, let me know if that works.

[QUOTE=rene636;2288148]I had the same problem a few yewars back and have always saved this sight. This will change your PIO to DMA.

http://winhlp.com/node/10

Good luck![/QUOTE]

This cannot work, I already told that this is dependent on the installed firmware and only the installed firmware.

So, the OP needs to find the appropriate firmware for this drive & this setup…

[QUOTE=cartpauj;2287728]Also I was warned not to delete the IDE controller as it can cause my computer not to reboot???[/QUOTE]

I’ve never had that issue with windows, neither XP, Vista nor 7b/7RC.

I guess I’m just gonna have to be stuck with this problem. I tried uninstalling IDE/ATA devices and letting windows reinstall them on reboot. Still nothing. I had an old laptop HDD laying in my drawer so I pulled out my current HDD, put in the old one and loaded XP onto it. Even on a fresh XP install the drive still loads in PIO mode and I can’t change it. I’m not sure what’s going on. Its a new DVD burner and I can’t imagine it won’t work in DMA mode but I guess not.

Check your Bios?

Either ESC or F2 is usual for getting into the bios on laptops.

The PIO mode may be set to 0 for an unknown reason … similarly, in the bios, DMA may be turned off?

checked my bios but its so basic! It bothers me how so many laptop bios’ try and decide everything for you instead of letting you decide how your computer runs.

Anyways no such setting even kind of exists in my bios. I have searched and searched on this problem but no one seems to have an answer.

Afer an exhaustive search of the internet, I have exactly the same issue when I replaced my failed TS series DVD burner with a DVR-K17LA burner in an Acer 9410Z laptop. There is nothing I can find anywhere after a very exhaustive search that will fix this problem. None of the suggestions, from deleting the IDE controllers so they reinstall to registry edits are the solution. There is no way to get at the BIOS settings that have to do with the DMA mode of the disk drives on this machine. There must be some factory special software needed to do this. The DVD simply will not let me set it to DMA mode. It stays in PIO mode. I cannot even play an audio CD without stuttering on playback. Very frustrating.