VirtualDubMod Error Code 2

I’m trying to merge 2 avi files and VirtualDubMod gives me the following error:

VideoSourceAvi error: The source image format is not acceptable. (error code-2)

Here are the specs for both files:

Also, when I add the first file, it tells me "“VirtualDub has detected an improper VBR audio encoding in the source AVI file and will rewrite the audio header with standard CBR values during processing for better compatibility. This may introduce up to 11008 ms of skew from the video stream. If this is unacceptable, decompress the entire audio stream to an uncompressed WAV file and recompress with a constant bitrate encoder. (bitrate: 155.5 + 14.0 kbps)” And it asks me if I want to rewrite the header and I say no.

Please bear with me, I don’t know a lot.

I’ve always had better luck merging files with vbr audio using nandub.
http://www.doom9.org/index.html?/software.htm
just search the page for nandub

http://ndub.sourceforge.net/

I used this and I got the exact same error message when I tried to merge them. It didn’t say anything about the audio though.

Looking at the FAQ at the Vdub support forums, there are three main causes for this. Look at this thread:
http://forums.virtualdub.org/index.php?act=ST&f=4&t=6608&

The source image format is not acceptable (error code -2)
There are three main causes for this to happen:

  1. You are trying to compress a video in a format that is not supported by the codec. This will usually mean that the frame height and width are incorrect or that the color depth is not valid. To see what restrictions there are for a codec go to video–>compression and select the codec. The codec restrictions will now appear in a box right of the middle in this window.

  2. It happens when trying to play the file in VirtualDub. This is the result of a codec that is trying to decompress a video stream, which it actually cannot handle. This shouldn’t be happening, but there are a few codecs (e.g. Panasonic DV) that will try to decompress anything they can get their hands on. Check the file info in VirtualDub and look up the codec used for decompression. Then uninstall/disable this codec and open the file again and see if it plays. It might be possible that with opening the file you will get another type of error message, which will be dealt with now.

  3. This error is also common with DivX and can have two main possible causes for it. First of all, it is recommended that in the advanced setting of the DivX config, you disable “Do not prompt with errors and warnings”. Why this setting is not disabled by default I don’t know, complain to DivX about it. If you now start your encode again an error message will appear. Usually there are problems with the logfile or the dimensions of your video are not correct. With DivX hardware profiles enabled, there are maximum resolutions you can encode with (e.g. 720x576 is the maximum res for the Home Theatre profile). It could also be that you have issues as described at number 1.

So is there anything I can do?

That is positively brilliant, thank you!

Reading is the suggestion #1!

you get this error because the audio is in vbr mode, load the avi into vdub & choose video direct stream and audio full processing, when you have audio full click on enable audio/video interleaving to turn the check mark off & clk ok. I usually then clk on compression and convert to pcm. This will give you an avi with cbr - constant bit audio, wave mode. The video and the audio will be in sync. You can then convert the pcm audio to whatever compression you want - ie mp3 - doug