Virtualdub & Virtualdubmod saving WAV probs

vbimport

#1

I’m having a problem using both of these softwares to convert the audio of a avi file to wav.

Both of the programs give a similar message saying:

Error initializing audio stream decompression.
Check to make sure you have the required codec.

Here’s the thing, I think I have the right codec, but I’m not sure, and I’ve used another program to save the wav, which worked fine, but it hasn’t done it well enough. So I want to fix this problem in Vdub or Vdubmod so I can see if saving the wav using either will work better for what I’m trying to do.

Does anyone know of the codec it speaks of?


#2

Welcome to the forum :slight_smile:

Try to use gspot to see what codec was used to encode that avi


#3

Thanks I’m already starting to like this place.

Video:
Xvid

Audio:
0x0055(MP3) ID’d as MPEG-1 Layer 3

is that what you meant?


#4

It seems a regular mp3 file, so it shouldn’t be a problem to extract wav.

What procedure did you use exactly in virtualdub?


#5

Well in virtualdub I first open the program. then “File” “Open video file…” “My AVI File.avi”. Then I’m promt with this message:

[!] AVI: Variable bitrate (VBR) audio detected. VBR audio in AVI is
non-standard and you may encounter sync errors up to 5952ms when
attempting to extract WAV files or processing the audio in Direct Stream
Copy mode. Full Processing mode is recommended to decompress or recompress
the audio. (bitrate: 121.8 ± 14.7 kbps)

Which is to be expected, I might add. Then I select “Video” “Direct Stream Copy” (not sure that it matters). Then “Audio” “Full Processing Mode”. Don’t usually need to worry about changing compression to “no compression PCM” as I think Vdub has it selected by default, but I check it anyways. Then I go to “File” “Save WAV…” type the desired filename then I get that message.

In Vdubmod, it’s practically the same except the interface is a little different but I end up with the same result.


#6

This is the same procedure I use to extract wav from an avi, I really can’t understand why you get that error :frowning:

Do you have latest version of virtualdub? Do you have mp3 codec installed in your computer?


#7

I think I have the latest version. VirtualDub 1.6.17 or VirtualDubMod 1.5.10.2 with bug fixes. As for the codecs, 4 different ones I think.


#8

Yes, virtualdub it’s latest version.

Try to install again the mp3 codec, maybe this solve.

You can find here LAME


#9

Might I be able to discuss my original problem which led me to this roadblock? Or should I submit a new post somewhere else?


#10

i’ve had the exact same issue and it’s usually do to 1 of 2 things…the audio is corrupted or sometimes…virtualDub won’t take vbr audio from an avi/mpeg etc…i don’t know why but these are usually the culprits

try another avi or mpeg and see…:slight_smile:


#11

That’s it exactly. I tried an avi file that I know doesn’t have a VBR and it didn’t give me the message. Weird, cuz I thought the solution to my sync problems was to extract the WAV from the crappy VBR avi file and re-insert it and save the new file. I guess I need to look for another solution to my sync problem. Thanks Nosmartz. You may of saved me hours of wasted time.


#12

yeah…i’ve done many vbr mpg/avi in VD…it’s always the same…error

ur welcome


#13

Where do you suggest I post my sync problem?


#14

You can still post here :slight_smile:


#15

you mean in this post or in this forum?


#16

try an app called avi preview 2.3…i used it to fix the audio and it went back through VD w/ no problems…:slight_smile:


#17

You can continue in this thread :slight_smile:


#18

Do you know where I can find this program? I tried google with no definate result. Thanks :slight_smile:


#19

i’ll send u a link


#20

Ok here goes geno888,

I have spent plenty of time scanning through presidencies looking for methods to avoid this, but frankly I’m sick of wasting DVDs in an effort to find out if the similar thread’s solutions will work in my case.

I am trying to burn some TV Rips to DVD. Here’s the problem: The burning process goes fine but when I play it in my dvd player, the audio starts out fine but gradually goes out of sync. DVD rips Burn fine, but I guess TV Rips do not.

From what I can gather from some of the presidencies and from the error in VirtualDub, which I’ve tried to use to fix this problem, is that it has to do with the mp3 compression of the audio being in VBR and not CBR. Does this familiar?

How can I fix this VBR problem?