VirtualBox and DVDFab

vbimport

#1

Okay, so I am migrating my laptop to a Linux Core but running VirtualBox (Sun) for those applications I must have on XP.

I tried to run a copy of DVDFab after mounting the physical DVD reader, and then inserted a DVD. DVDFab seems to ignore it completely.

This occurs regardless of the DVD inserted. I can play the DVD on Media Player Classic in the XP guest, but nothing from DVDFab. If there is a autorun.inf, it does run on the PC.

Has anyone gotten this to work?

Thanks.


#2

Before talking about running DVDFab in a virtual machine OS, perhaps it would be interesting for you to know that lots of folks have been running it using Wine.

There’s a nice tutorial on the debian forum:

http://forums.debian.net/viewtopic.php?f=16&t=32738&start=0

And there’s a Linux thread right on these forums:

I’ve never tried it in VirtualBox even though I run XP in it and 98SE in VMWare. But a problem might be because DVD playback and even CD playback aren’t supported in guests using either VirtualBox or VMWare.

Or it might be that your settings for the virtual guests don’t have the cdrom section configured to mount the specific cd writer drive and also have a check (in VirtualBox) to enable DVD passthrough. That option is supposed to enable cd/dvd burning throughput for the guest.

The files mfc42.dll and msvcp60.dll, as done using the guide I linked to, should be placed in ~./wine/drive_c/windows/system32, and the quartz.dll file in the pack the guide links to helps DVDShrink behave correctly as well. Just rename the one Wine puts in there and enable it in winecfg as that guide shows.

Generally if there’s a Linux application to handle something I use that, then Wine, and as a last resort, virtualization.

There’s a problem talked about on this forum’s thread I linked to and at the winehq.org ap database about DVDFab’s registration not being able to work. I just use the free part (DVDFabHDDecrypter) so haven’t encountered that, just ripping the whole DVD to a folder on my hard drive, using DVDShrink to shrink it (always choosing a full analysis) and then burning the VIDEO_TS folder in a DVD_VIDEO project in K3B, or if in Gnome having DVDShrink make an ISO instead and burning it with Brasero.

Another problem is DVDFab’s options screens. You’ve got to use the keyboard’s up and down arrows and the mouse to carefully navigate it as the mouse doesn’t work properly on the left pane.


#3

Yes, with Wine it’s much better. But did you mount it?