Video but no audio, and other problems

vbimport

#1

Hello all,
I have “downloaded” a few movies, that I honest to god actually own on dvd, but I downloaded them from the net in .avi 700 mb form.

While some of them work flawlessly, others don’t work at all or no audio or only audio.

Two files I have, which when I right click, advanced, properties, it says it’s encoded with XVID, which I have installed. Other xvid movies play fine, and I believe Installed the latest version of what I could find, non-beta.

This movie plays video, but the audio does NOT work period.

Another few movies, which I all seriously do own, will play for maybe a few seconds and then give me an error “One or more codecs could not be found” or something like that. I right click, properties, advanced on this one, and it says the file information is unavalible. I could just rip them from the dvd’s I have down stairs, but I prefer not to go through all that trouble, it takes my computer like 8 hours per movie to rip into divx.

NOTE: ALL of these files, play absolutely FLAWLESSLY on my xbox (modded) with Xbox Media Center/Player. Audio work, video works, no freezing or crashing, PERFECT. Why won’t they work on my computer?

I have divx 5.11 pro, xvid 1.04 (or something like that I think), nimo’s codec pack installed.

What should I do? Another few files will crash once they get too far into the movie, one of them specifically on the last 5 minutes, I run divx doctor or something, the repair thing for fixing bad divx movies, but once that runs, the movie is really messed up, it won’t even try to play in windows media player 10, it gives an error before ever starting the movie to play.

Thanks in advance!


#2

Open the avi in GSpot and tell us what the audio properties all are.
Odds are, you don’t have the audio codec for them.
This has nothing to do with Xvid, Divx, or Nimo’s crap.


#3

ok, opened in gspot 221

Video:
xvid
3 compatible codecs installed.

Audio:
ac3 (0x2000) Dolby Laboratories, Inc
Codec is Installed.

When I open the movie in windows media player 10, I see in the status bar it’s searching, loading, and then error downloading codec, then starts playing video, no audio.

How do I get this codec or make windows realize I have it?


#4

have you tried the ac3filter? Might help


#5

ok, thanks for all your guys help.

Ok, now I got the sound working perfectly, so the only problem is the few files that give a error when trying to play and does not play in windows xp on my destop but works totally fine in xbox media center.

Gspot stats:

Xvid
0x0055(MP3) ID’d as MPEG-1 Layer 3

both audio and video have two or three compatible codecs installed.

for “stat” one of them says file missmatch, and talks about how this file was either truncated or tried to be fixed with divfix and the frame is out of whack.

How can I fix this and make it so it does work? I think i’ve tried divx fix 1.08 or so, didn’t work but I’m willing to try anything.

NOTE: This file plays totally fine in xbox media center, just won’t work with windows media player 10, real player, or divx player.


#6

Hi,
i also have a problem with a divx. When i gspot it, it gives me that message. Any idea ?
thx in advance…

RD

DirectShow partially succeeded to play file. The actual text of the error or warning is:

0x00040242: VFW_S_PARTIAL_RENDER - Some of the streams in this movie are in an unsupported format.

The following combination of filters were used:

{D:\eMule\Incoming zi…-…STFr - By Marcus).avi} (Video Source)
{AVI Splitter} (Video Splitter)
{ffdshow MPEG-4 Video Decoder} (Video Decoder)
{Video Renderer} (Video Renderer)

Special Note: GSpot determined this audio should play, yet it didn’t, and the format code is 0x160 or 0x161. This combination of conditions is a likely indicator that the Microsoft WMA codec is attempting to play DivX 3 audio, or vice versa - an unfortunate result of original DivX designers’ neglect to use a distinct format code. The ability to play this audio may be dependent on the installation or uninstallation of at least the audio portion of the DivX 3.11 codec. This codec may also be referred to as “DivX audio version 4.0x”