VIA + XP = conflict?

Hi there,

i think I could do with some advice here. Just reinstalled winXP after rearranging cdrom and cdrw as follows:
primary master=hdd (IBM 75GXP 40GB)
slave=cd-rom LG 8322B

secondary master=cd-rw (HP 16r)
slave=hdd (Quantum 3 GB)

The burner was according to XP in PIO position. I read in this forum that that should preferrably be DMA, and that in order to achieve that I could download the VIA miniport. Done that and indeed it is now dma mode 2.

HOWEVER: XP now recognizes both hdd’s as scsi devices and has a hard time finding the drivers (yellow excklamation marks).

DMA positions of the devices is now as follows:
primary master (IBM hdd) = utra dma mode 5 (ata 100)
slave (cd-rom) = multi word dma mode 2

secondary master (cd-rw) = multiword dma mode 2
slave (hdd Quantum) = utra dma mode 2 (ata 33)

Questions: Is there anything I can do about this? Should I? Would it be better to go back to the old situation?

Your tips/advice/thoughts are greatly appreciated. Thanx in advance.

I have WinXP Home and VIA KT266A and I get no problems at all with the newest VIA 4-in-1 drivers. Here’s something I post to almost everyone, I’m sorta lazy. You can skip steps 1 & 2.

Ok, here’s a few things to try, for WinXP. Well it works the same for Win2K, and the other OS can’t be too different.

  1. Update Nero to the newest version, 5.5.9.0 (Last Official Release), 5.5.9.6 (Leaked), or 5.5.9.9 (New Official Release, NOT Leaked Beta).

Get 5.5.9.0 Here | Mirror | Mirror | Mirror | Mirror | Mirror

Get 5.5.9.6 Here | Mirror | Mirror | Mirror

Get 5.5.9.9 Here | Mirror | Mirror | Mirror | Mirror | Mirror

  1. Update your CD-RW’s firmware to the newest release.

  2. Go to the Control Panel, under Administrative Tools, select Services, find “IMAPI CD-Burning COM Service,” then switch it to disabled from manual/automatic.

  3. Go to the Control Panel, go to System. Select the Hardware tab, then go to Device Manager, then expand “IDE ATA/ATAPI Controllers,” go to “Secondary IDE Channel,” and make sure DMA is enabled, if it is already, but it says its in PIO mode then go immediately to step 5.

5 Follow step 4 to the “IDE ATA/ATAPI Controllers” part and delete/uninstall the “VIA Busmaster IDE Controller” (or whatever your motherboard chipset’s busmaster controller is), now reboot the pc and follow step 4.

  1. Your ASPI drivers may be bad, so try to use ForceASPI 1.7, and change it to 4.60, don’t worry, this program has the best ASPI drivers for WinXP and makes an auto backup of your ASPI drivers so you can do a rollback.

Download it here | Find mirrors here | Get more info here

7.You might have a VIA chipset, www.viaarena.com, so if you haven’t already, consider upgrading to the newest v4.42 (P2). If you have some other chipset, like Intel, please go to www.intel.com, and find the newest INF drivers release and also the Intel Application Accelerator (IAA), now v2.2.2.2150.

Download the latest VIA 4-in-1 drivers here

Download the latest Intel Application Accelerator drivers here

  1. Consider upgrading your BIOS

That’s all I can think of for now, please test one at a time (cept 4 and 5 tho), in whatever order you want.

Oh n please post your results,
DFourthHorseman

dfourthhorseman: thx for replying. I did try your solution before going this road, but it didn’t have the desired effect: the secondary master (burner) remained in PIO. I therefore thought that installing the via mini portdriver would have the desired effect, which of course it had. Unfortunately it came with a couple of undesired side-effects, although I don’t really know which impplications it has (if any). (Didn’t try to burn anything yet).

When making use of a KT266a chipset, installing the Via 4-in-1 drivers should be enough to make your system work just fine.

Since the miniport drivers are clearly corrupting some IDE settings, it it possible that the multiword dma mode from the HP writer is “made up” as well? There are many IDE writers (especially olders models) that do not support any form of DMA, only PIO…

Thx Dee-ehn. 4in1 drivers are up-to-date. I just changed the setting for the burner from multi-word dma 2 to ultra dma 2 and although the setting after rebooting remained on multi-word dma 2, the problem at least for that channel was solved! Hdd appeared as normal Quantum drive (not scsi). Primary channel however still looks a bit of a mess.

Well i have to agree with Dee-ehn, but i would say just delete the dodgy entries out of device manager, install latest via 4in1’s and reboot - should sort it out.

Thx nb-. Tried that but no, xp reinstalls the exact same stuff.

LennartII
Have you tried putting the HD’s on primary and CD’s on secondary?

rdgrimes. Thanx for helping out. Havent tried that yet. Read something about old hdd slowing down new hdd if on same cable, but that has been contradicted quite vigorously on this forum so will give it a try tonite.

Rdgrimes. Opened computer but found out in a hurry that in order to do what you suggested I would have to buy another fast flatcable to connect both harddrives. So, I just fiddled around ewith the flatcables a bit and when I rebooted lo and behold, all devices were in dma mode. Both cd-rom and cd-writer in multiword dma 2. Hope that’ll work!

I got a Verbatim and was having problems flashing it to a LiteOn 48125W. Mtkflash worked but Infotool did not show Mt Rainier as supported. LiteON’s windows flasher took forever and then said dram to bin compare failed. When installing the latest VIA 4in1 drviers it said I had to first uninstall VIA IDE miniport. After installing the 4in1’s and without doing anything else, InfoTool showed Mt Rainier supported. I then installed miniport (for my Maxtor ATA133 and Win XP Pro) and Infotool did not have the tick for Mt. Ranier. I uninstalled miniport and the tick re-appeared.

TambourineMan: Thanx for your input. So, what’s your conclusion am I right in reading between the lines that the Via miniport driver sucks, or is it something else?

the latest via drivers work great for me on XP
the version before that ruined my xp install

works great now

Well if you guys didn’t know I’ll tell you now, the newest right now is 4.43 as of a couple weeks ago.

Download the latest VIA 4-in-1 v4.43 drivers here

Try it if 4.42 doesnt work for you.

My problem is not from the 4in1 drivers, but rather from the VIA ISE miniport driver

when you install the via 4 in 1, de-select the ide drivers

Originally posted by damiandimitri
when you install the via 4 in 1, de-select the ide drivers
why

Yea, the miniport driver is independent of the 4-in-1 pack. The pack has a ide filter I think, not the miniport. And I believe the miniport should only be used under WinNT or something.

I could have some of the facts messed up, check with www.viaarena.com

isn’t it in de via 4-1 drivers?? i have to look that up. I thought i saw it in there.

The miniport driver is NOT compatible with XP, or XP-Pro. If you have the latest 4-in-1 drivers, it will allow you your choices in the device manager. You also have to make sure that it is enabled in the BIOS, or all is for naught! BTW If you made a restore point before installation of the miniport drivers, you can return to a point before they corrupted your files.

OS: XP Corp, NTFS
Abit KR7A-133(133) Via KT 266a
2 Maxtor 60 GB 7200 RPM ATA 133
Liteon 40125s
Samsung 32-12-40

Both of my CD-R/W are using DMA 2 / Multi Word DMA, with only 4-in-1 Drivers installed.