VIA Chipset IDE/Atapi controller? (3540a)

vbimport

#1

I’ve been looking for this for a while but cant seem to find it. I found some beta ones but they made my computer much much slower.

I need them because all of my hard drives and optical drives are in lower Ultra DMA modes than they should be. The ones that come with windows came out in 2001 and put my DVD burner at Ultra DMA mode 1.

The beta controller said it got them to where they’re supposed to be, but it took an hour to do something that used to take 6 mins afterwards.

If you can help, it would be appreciated.

thanks

mother board is PC Chips K7 KT266a/8235 if that helps


#2

aren`t the via ide driver included in the via 4in1 drivers?


#3

i thought so but i’ve downloaded a few different versions and none have changed them. What changed them for me was the “VIA IDE Accelerator Driver” but it also didn’t work well.


#4

you have an older via chipset and should NOT use the via ide accelerator driver. You have to revert back to the ms driver. I have the pt880 chipset and have had zero problems with ide accelerator driver. You can go to the forum at viaarena.com to learn more.

You can also try uninstalling the secondary ide controller in the device manager, but you may have to restart more then once. With the ms driver I’ve only had to restart it once, but with the new ide driver from via it took two or three (can’t recall).


#5

The MS driver never gave me full speeds. That’s why I got the accelerated drivers. Is there a later MS driver for this?


#6

nope.

so you have some other problem (obviously :slight_smile: )

did you try uninstalling the secondary ide controller? + rebooting.


#7

yeah, i tried that. didn’t help. i still get UDMA mode 1 for my DVD burner and 4 for my hard drives


#8

Have u checked your bios settings cos if your drive is not being recognised properly or u have a old bios it may not support higher udma speeds.


#9

where would i look in my bios?


#10

In the main menu where all ur drives are listed,go to the drive hit enter,it should show u the PIO or DMA mode and if its enabled or not,also check motherboard maker for possibly newer bios version.
ps dont forget to save ur bios settings if u needed to change them,save is in exit menu


#11

All DMA modes are enabled. There is a newer bios, but it doesn’t mention any fixes for this. Still worth checking out?


#12

“K7 KT266a”

You should have no problem whatsoever with Microsoft basic IDE drivers with the KT266A chipset.

I own a KT266 boards myself (MSI KT266Pro), with a Pioneer 109 drive on it and everything is fine with the MS drivers, UDMA mode 4.

Maybe you already installed, once, a VIA 4in1 package and this could be the reason why you have this problem, this is a well-known issue on these forums that the Via IDE drivers don’t do a proper job for DVD burners.

Anyway you’ll have to uninstall these “Accelerated drivers” that are not supported by your mobo.

How are all your IDE drives connected? i.e.:
Primary master=?
Primary slave=?
Secondary master=?
Secondary slave=?


#13

Primary channel is hooked up with a 80 pin IDE cable.
master: hard drive (udma mode 4 instead of 5)
slave : hard drive (udma mode 4 instead of 5)

secondary channel is hookedu p with a 80 pin cable.
master: dvd drive (udma mode 1 instead of 2)
slave : hard drive (udma mode 2 instead of 6 - but that’s understandable cause it’s on the same line as the dvd drive.)

I’m going to fix the problem of the hard drive that should be udma 6 by buying a PCI IDE controller card. Could this help with the other problems too?


#14

“I’m going to fix the problem of the hard drive that should be udma 6 by buying a PCI IDE controller card. Could this help with the other problems too?”

Probably, if you plug the NEC on this card too.

But you could try, first, to update your BIOS: http://www.pcchipsusa.com/download-mainframe.asp.

Your model seems to be m811luv31

When you’ve done that, uninstall all VIA drivers, delete both IDE channels in the device manager, reboot, and see what happens… if it doesn’t help, go for the IDE card. :iagree:

Good luck :slight_smile: