Very WEIRD problem with BTC DVD-R 1108 (...help!)

Hello Sirs!

Maybe someone of you, tech Wizards, can help me, thank you in advance !:

  1. The DVD was working fine, until today I tried to open the “drawer” (to get the DVD disk out of the drive)

  2. the drawer opened/ejected the disk only in 1/2 (even though the disk was not blocking it / misaligned etc.)

  3. I manually pushed the drawer back in, then tried to open it. Still opening only to 1/2

  4. To make the story short… I manually opened the drawer it to remove the disk, inserted another one, it closes only to open again in 1/2, doesn’t read the new disk. Tried a few times, no luck. Restarted the system (after closing it cold). No luck. (two times). On closing it keeps opening the drawer to 1/2. The same when reading a new disk: it closes fine, then tries to read it, then opens to 1/2 and stops like that.

  5. It seems that the drive maybe thinks the secured closed position is in 1/2, that’s why it keeps ejecting the drawer.

Is this a hardware or (low level ?) software problem ? Is there any way to cure this nice DVD drive ?

I really need your help, please !!!


Btw. Here’s a tip for everyone who’s got problems with multisession DVD-Rs in Nero (the new session unreadable, even though Nero says it completed the recording without problems). I found out, that adding new sessions at lower speeds cures the problem). Maybe it’s the disks, maybe it’s Nero. But this fixes the problem 100%.