Very slow reads (Samsung SH-S203N / TS-H653N)

vbimport

#1

[qanda]This thread is about the Samsung SH-S203N / TS-H653N. Click here to see full specs[/qanda]I have been using my SH-S203N for about six months now, and have burned probably 40+ DVDS. Some of these are AVCHD disks, which I use to archive HD video from my Sony AVCHD camcorder.

Last night I went to play one of these AVCHD disks and it was very stuttery, and the playback froze a number of times. Thinking that it was my video driver I updated the Nvidia driver to the latest for my 7600GT card. It helped a little but the playback was still really bad. Note, I can play the AVCHD clips from my hard drive without any issues.

Next I began to suspect the disk itself, which would be a real concern as these are Verbatim Gold Archive DVD-R which is now my only record of this video footage.

I used drivespeed from Nero8 (drivespeed4) and it measured transfer times of less than 2x ! ( I am assuming that ‘transfer speed’ equates to the read speed of my burner)

Next I tried a Panasonic DVD+R which my father had burned on his Panasonic VCR in the UK, it also reported <2x transfer speed.

I have read of one user who experienced similar problems with his Samsung burner but the fix in his case was to update the BIOS on his motherboard. I am a little hesitant to do this so wanted to ask this forum if there was anything else I should check first?

These disks used to play ok on this machine, I don’t know what has changed.

My system comprises: Core2Duo E6300, 3Gb RAM, Gigabyte 965P-DS3 Rev 2.0 motherboard, Asus 7600GT 265M graphics card, XP Pro SP2 + latest patches

thanks in advance for your help.


#2

Hi,

please check if DMA is enabled (provided your Sata controller is in IDE compatible mode): http://club.cdfreaks.com/f61/troubleshooting-enabling-checking-dma-windows-vista-xp-2000-me-9x-101616/

Michael


#3

Hi Michael,
Thanks to the pointer to the article about enabling DMA, naively I though this was just an old IDE thing, I had not realized that my SATA drives, being set up in ‘IDE Compatibility’ mode in the BIOS it also applied. I am however unclear as to how my two SATA hard drives and SH-S203N tie up with what I see in the device manager:

Currently in device manager I see:

IDE ATA/ATAPI controllers
Intel® ICH8 2 port Serial ATA Storage Controller – 2825
Intel® ICH8 4 port Serial ATA Storage Controller – 2820
Primary IDE Channel
Primary IDE Channel
Secondary IDE Channel
Secondary IDE Channel

For the upper Primary IDE Channel in the list above, the properties are as follows:
Device 0
Device Type: Auto Detection –> Grayed out
Transfer Mode: PIO
Current Transfer Mode: PIO Mode
Device 1
Device Type: Auto Detection
Transfer Mode: DMA if available
Current Transfer Mode: Not Applicable
For the lower Primary IDE Channel in the list above, the properties are as follows:
Device 0
Device Type: Auto Detection –> Grayed out
Transfer Mode: DMA if available
Current Transfer Mode: Ultra DMA Mode 5

Device 1
Device Type: Auto Detection
Transfer Mode: DMA if available
Current Transfer Mode: Not Applicable
For the upper Secondary IDE Channel in the list above, the properties are as follows:
Device 0
Device Type: Auto Detection
Transfer Mode: DMA if available
Current Transfer Mode: Not Applicable

Device 1
Device Type: Auto Detection
Transfer Mode: DMA if available
Current Transfer Mode: Not Applicable
For the lower Secondary IDE Channel in the list above, the properties are as follows:
Device 0
Device Type: Auto Detection -> Grayed out
Transfer Mode: DMA if available
Current Transfer Mode: Ultra DMA Mode 5

Device 1
Device Type: Auto Detection
Transfer Mode: DMA if available
Current Transfer Mode: Not Applicable
I am not sure how the two SATA hard drives and SH-S203N DVD Burner relate to the above. I have two SATA controllers on my motherboard, one is an Intel ICH8 which has four connectors/ports, also there is a Gigabyte SATA controller which has two connectors/ports. My hard drives and SH-S203N are plugged into three of the four ICH8 connectors. (The Gigabyte SATA controller is used for RAID, which I don’t currently have set up).

One thing I read in that thread you pointed me to go me thinking …
A few months ago I was battling with problems with bad burns from my SH-S203N when using Verbatim DVD+RW. I had terrible trouble getting reliable burns and in some cases I couldn’t even erase successfully. In the end I had to admit defeat and the only satisfaction I got was to take each of the Verbatim disks and bend in half and throw in the garbage. Since then I have been using Sony DVD+RW and have not seen the problem since. I am wondering if the problems erasing and reading the Verbatim disks could have resulted in XP detecting too many CRC errors and forcing the transfer mode to PIO?

BTW, for the upper Primary IDE Channel shown above, I change the mode to ‘DMA if available’ and rebooted my system but it still shows ‘Current transfer mode: PIO’


#4

Hi Michael,

I changed the setting the BIOS, from ‘IDE’ to ‘Native’ but it didn’t help.

Also, I discovered that the Gigabyte SATA controller was enabled in the BIOS, so I disabled that. Unfortuantely that also made no difference.

At the suggestion of that thread you pointed me to, I checked in the event viewer, and on Nov 15th there were a lot of errors for the DVD Burner, some were timeout errors. I am wondering now if Windows has fixed the mode to PIO because of having too many errors.

Problem is that I don’t seem to be able to change it back to DMA mode.


#5

Hi,[quote=bbear;2165124]
For the upper Primary IDE Channel in the list above, the properties are as follows:Device 0
Device Type: Auto Detection –> Grayed out
Transfer Mode: PIO
Current Transfer Mode: PIO Mode
[/quote]This is your drive. Running in PIO.
The other drives shown as Ultra DMA 5 are your HDDs

I am wondering if the problems erasing and reading the Verbatim disks could have resulted in XP detecting too many CRC errors and forcing the transfer mode to PIO?
Possibly.

BTW, for the upper Primary IDE Channel shown above, I change the mode to ‘DMA if available’ and rebooted my system but it still shows 'Current transfer mode: PIO’
Check http://winhlp.com/node/10 please. They also have a resetdma tool there.

[quote=bbear;2165185]I changed the setting the BIOS, from ‘IDE’ to ‘Native’ but it didn’t help.[/quote]IDE should be the correct setting.

At the suggestion of that thread you pointed me to, I checked in the event viewer, and on Nov 15th there were a lot of errors for the DVD Burner, some were timeout errors. I am wondering now if Windows has fixed the mode to PIO because of having too many errors.

Problem is that I don’t seem to be able to change it back to DMA mode.
You might also try a new Sata cable. I had similar issues with a HDD on my brother’s computer. A new Sata cable was the solution there.

Michael


#6

[quote=mciahel;2165234]
Check http://winhlp.com/node/10 please. They also have a resetdma tool there.
Michael[/quote]

Hi Michael,
I read up on the manual method described on the winhlp site but decided to take the easy way out and ran the vbs script. It reset my drives sucessfully and the two hard drives and the SH-S203N all show that they are set to UltraDME Mode5 !!

Nero disc speed 4 shows that reads are not back to what I would expect.

Nero Showtime is playing my AVCHD disks super smooth again :slight_smile:

About the bios setting - it is still set to ‘native’ but you indicated that I should set it to ‘IDE’. It seems to be working ok in ‘native’ and the reason I set it this way is because my two hard drives support NCQ. Is it important for my burner that I set it back to ‘IDE’?

thanks so much for your help!


#7

Hi,

IDE is the most compatible setting for optical drives. If another setting works for you, then there is no reason to change. Make sure you have the latest chipset and Sata drivers installed then.

Michael


#8

IDE or native makes normally no difference.