Verbatim dvd+r dl 8x wont read on my PC.. Only 2x does?

vbimport

#1

Why isit when i insert a verbatim 8.5gb dvd+r dl 2x disc it reads on my pc . But when i insert a Verbatim 8.5gb dvd+r dl 8x, my pc just freezes and never reads it.
Whats the problem??
By the way i have a LITE-ON LH-20A1H Drive I just upgraded the firmware for it. However i am still getting this problem. My drive cannot read or recognize 8x dvd+r dl discs, it doesnt come up on ‘my computer’, it doesnt come up on ‘dvdinfo pro’ or ‘imgburn’, my drive also begins to make odd noises for a few seconds then stops. Isit a Hardware or Software issue? i can however read and write perfectly with 2.4x dvd+r dl discs.
Help would be appreciated

thanks

alex


#2

What is the MID?


#3

Sorry what do you mean by the MID?, sorry im new here.


#4

ImgBurn will give you a lot of info.



#5

I start up IMGBURN, but there is no details of the disc??, the disc is already in the drive but as i said before it doesnt even read it at all?, no program or even ‘my computer’ realises that there is a disc in the drive, so its not possible for me to give you a MID :frowning:

Please help

(I printed some images for you, the Verbatim DVD+R DL 8X disc is IN MY DRIVE at the time i started IMGBURN)

It doesnt even know its there? :frowning:


#6

Your burner is not properly working, maybe wrongly set up?
Check the devicemanager first.


#7

[QUOTE=chef;2042106]Your burner is not properly working, maybe wrongly set up?
Check the devicemanager first.[/QUOTE]

Yeah i checked device manager. My dvd drive is under ‘DVD/CD ROM Drives’. Its all there, and the firmware is updated. But what do you mean wrongly set up?.

Im completly baffled as to why one of the best burners on the market is giving me this stupid problem. It wont read 8x dvd+r dl. Do you think its a region lock issue? software? hardware? please help

thanks


#8

[QUOTE=pfloyd1;2041390]What is the MID?[/QUOTE]

I managed to put the dvd in my other pc’s drive. and it read it? i went on to IMGBURN and i got the MID for you, its - Disc ID: MKM-003-00

Why doesnt the dvd read on my other drive???!?.

Please help thanks


#9

I think you meant “it wont recognize the 8x DL” then?!
It does only happen with this media?

Have you tried finding an firmware update for your burner? Is incd/alcohol/damontools installed?


#10

Same type of problem as us

http://club.cdfreaks.com/f44/lite-lh-20a1h-wont-read-blank-dvd-r-dl-keep-making-some-weird-sound-though-266206/

IS there really no one out there who knows whats wrong? Its not our burner because everything else works fine. I tried other discs (old/new/other types of blanks) and they all work. its just something with this lite on drive and stupid verbatim dual layers.