VeloSSD2012: many many Bugs

hi

I have buy VeloSSD 2012 Professional Edition.
i have some Problems with the Software.

The Trail Doesn’t work! In the first Installation a Doubleclick on the VeloSSD Icon show the UAC promt but nothing other. No Key Enter Dialog, nothing. After uninstall und reinstall (with reboot) the VeloSSD Windows are show. But i Can’t create a Volume only the Key Enter Dialog was show. After Rebooting I only see the Key Enter dialog.
Option ok or cancel or close (X). But nothing work. The configruation window doesn’t show. So i Buy VeloSSD Pro Version.

but:

  1. After creating a VeloSSD Volume the Windows 7 Sytem-reserved Volume (100MB) and the 16Gbyte CacheSSD become a drive Letter why?
    I Don’t want to see the two drives. But if I delete the drive letter from the full cache drive VeloSSD not work. Windows 7 show all the Time “drive G: ist full”.

  2. Why i can only Cache one partition? One Disk is ok but only one partion…

  3. I activate VeloSSD online. But after a reboot the Software say “not activated”. I receiver the Error: already activated.-5. The problem is: the e-mail contact link in the info tab doesn’t work -> perfect!
    No online Activation Mangement nothing? What i need to do to activate again?

After all this problem i think you should go back to beta testing and Bufixing. After this Update your Website and write a Manuell/documentation.

my system:
Windows 7 SP1 64Bit
Lenovo Thinkpad Edge 530 nzqc2ge

AIDA64 log of the system: ftp://nfxmc.no-ip.org/Report.htm

Hi,
thank you for your posting. Gratulations you are a Laptop user with HDD & SSD !

After reviewing your post and our software several times, we could reproduce some
of the behaviour you describe.

>>The Trail Doesn’t work! In the first Installation a Doubleclick on the VeloSSD
>>Icon show the UAC promt but nothing other. No Key Enter Dialog, nothing.
>>After uninstall und reinstall (with reboot) the VeloSSD Windows are show. But i
>>Can’t create a Volume only the Key Enter Dialog was show. After Rebooting I
>>only see the Key Enter dialog.
>>Option ok or cancel or close (X). But nothing work. The configruation window
>>doesn’t show. So i Buy VeloSSD Pro Version.

If you deny UAC prompt App will end. Thats normal.
You need to enter your Installation Key before you can create a cache.
Afterwards you have full access to the application.

>>1. After creating a VeloSSD Volume the Windows 7 Sytem-reserved Volume (100
>>MB) and the 16Gbyte CacheSSD become a drive Letter why?
>>I Don’t want to see the two drives. But if I delete the drive letter from the full
>>cache drive VeloSSD not work. Windows 7 show all the Time “drive G: ist full”.

Only the System reserved Volume gets a letter, we will remove this.
The “drive G: ist full” message sucks but is not a bug.
You have assigned all space on that volume as cache.
Maybe there is a way windows can be tweaked to stop showing anoying warnings ?

>2. Why i can only Cache one partition? One Disk is ok but only one partion…
You can cache 4 volumes with the professional edition and 8 with the enterprise.
By design VeloSSD 2012 works with volumes, so it is compatible to all kinds of windows volumes.

>>3. I activate VeloSSD online. But after a reboot the Software say “not
>>activated”. I receiver the Error: already activated.-5. The problem is: the e-mail
>>contact link in the info tab doesn’t work -> perfect!
>>No online Activation Mangement nothing? What i need to do to activate again?

The activation works one time, you wrote you deinstalled the software.
Oh, that deletes the key and on a new install activation will be denied.
In near future there will be an automatic mechanism that allows new activation in such a case.

>>After all this problem i think you should go back to beta testing and Bufixing.
>>After this Update your Website and write a Manuell/documentation.
Update 2.0.0.8 release will come out early this week, including a website update.

thanks for you fast and detailed answer.

But:
If you deny UAC prompt App will end. Thats normal.
You need to enter your Installation Key before you can create a cache.
Afterwards you have full access to the application.

I always say “Fortsetzen” (in German). I never cancel the UAC Message.
Why I can download a Trail Version if I can’t create a Volume to test the Software?

To use the trial you just need to register Email and password.
It is a straightforward thing.
The website will email you an Installation Key,
which is necessary to create a trial cache volume.
We do not allow complete anonymously access
because we must keep track of our user base.

i have create an account on your website but that I need a Trail key…I never read this befor.

hi again.
VeloSSD2012 V 2.0.08 is release but:

  1. After creating a VeloSSD Volume the Windows 7 Sytem-reserved Volume (100MB) become a drive Letter why?

-> the problem always exist! / is not fixed!

The problem is: the e-mail contact link in the info tab doesn’t work -> perfect!
-> the problem always exist! / is not fixed!

@Update 2.0.0.8 release will come out early this week, including a website update

-> I can’t see a Website Update. The german Language Version is poor…
My english is poor yes, i know^^ but your official website german an Webdesign is poorer. I think the german translation is not so critical but a modern, lightwight and clear english website is very important for your business.

at first again a feature request:

is it possible to add a option to change the Cache size without delete and re-create the Cache volume again?

second point some more bugs:

if i change the language (in this cas german to english united states) and not restart VeloSSD the program crash if i open the info tab

the bigger bug is:

if i create a volume, set the cache to 90% of the volume (13,xxGB) and go in to the last dialog of the assistent i can change the cache size again (button “Erweitert”)VeloSDD recommend 9,88Gbyte. if i cancel this dialog the result of the assistent dialog not change but the cache volume has only 9,88Gbyte after the reboot.


Hi,
thanks for your posts.
we have analysed and fixed issues. Below is a detailed list.
There is also an updated download available.

Email contact link:
Windows 7 comes without eMail Client, XP for instance had that integrated.
So it fails to open an Email Application, when the user hasn´t installed one.
Nowadays most people use webmail.
As reaction the VeloSSD shows a Message Box, explaining that situation.
Image:

Changing the language exits the Application
After changing the language, the App must be restarted.
It displays a message and shuts down.
Image:

Hidden Volume letter:
This one was confirmed and is still in work.

wrong cache size when exiting Dialog via Cancel:
We reproduced and removed that.

The feature request you made:
Changing the cache size while running.
It makes some sense, we will respond to that.



@EliteBytes

thanks for your qiuck answer again.

To the eMail Contact problem:
Show the eMail Adress in a dialog and if a Mail client is avaiable open the Mail program. I think this is the best way.

language problem:
I read the message :wink: but if a restart is needed the program should make it, not the costumer. I understand the message that a restart is only to change the language, if not the language is not changed yet (but after the next start of the programm).

Another Bug:

After removing a Volume ( synchronize was successfull) and reboot Windows say that the Volume C: (the cached partition) need to be checked. chkdsk find and repair many many failure on the drive. This is the second time I have this problem. The first time (after deinstallation of VeloSSD) the system not boot (BlueScreen). After a repair the windows system was damaged (no Sound, no network). I have not see a connection but now I think VeloSSD damage the FileSystem on some circumstance if the Cached Volume is removed. Please check this.

I reinstall Sie Windows system after the first time but Driver an other are the same, so you can use the AIDA64 log from the first post.

A part of the problem can be my SSD. The SanDisk U100 drive is extremly slow!


Some Feature Request Again:

  1. Please make an option to create a systemrestore-point befor a cache volume are created.
  2. Please make an option for a SafeMode. In the SafeMode only read caching is enabled. no caching of write action or other.
    A write operation write direct to the HDD without using the SSD. It is slow but safe :wink:
  3. Please give an Option to enter the percent and Size (MB/GB) manually of the cache. A slider is nice to have but i want to enter the Size direct.

Thanks for your posting:

We have been trying to reproduce what you wrote.
Although well tested we checked again and again.
Version 2.0.0.8 does not damage the filesystem
when the cache is removed.

You can use following commands from administrator command line:

fast test:
chkdsk
-This checks only the filesystem

slower test:
sfc /VERIFYONLY
-this check integrity of windows files.

We have been testing on 3 machines all over the day.
Finding no damage in more then a dozen test runs each
with different loads.

Since your posts are informative and up to now were mainly correct.
We figured out the damage on your system was very likely been done
by an older version. Very probably 2.0.0.7, it had such an issue. it was removed with 2.0.0.8.

However we take your feature requests to note with gratitude.

[QUOTE=EliteBytes;2648239]Thanks for your posting:

We have been trying to reproduce what you wrote.
Although well tested we checked again and again.
Version 2.0.0.8 does not damage the filesystem
when the cache is removed.
[/quote]

I can only say after removing the cache the File system and windows audio system is damaged. the first time it was Version 2.0.0.7 but the second time with same issue was Version 2.0.0.8. I have remove and recreate the cachevolume many times without any problem between the 2 Issues. but the 2 Volumes they are used for 2+ days have the problem. I will look at this problem in the next days/weeks and report again.

the damaged File System Bug again:

in the last 2 Days after the recovery i hve not use VeloSSD. Yesterday I have recreate a CacheVolume -> the File System was damage today. Only 2 Files. I think it is a special problem with my system. So please make a Safe mode only for read cache for testing.

2 outher Bugs:

the actually Cache ist 3days old.
on the last boot the Cache not working. Windows boot from the HDD (slow boot). After a Reboot -> cache is activ again (fast boot). in the VeloSSD Control menu
show no Problems.

After 2 Days with the Cache, I become the the boot option “Starthilfe (epfohlen)” [Selected] and “Windows normal starten” on every boot in the last 2 days. The reason is that windows could not be start correctly (Windows konnte nicht werden). Windows shutdown correctly in the Session(s) befor. If I use “Windows normal starten” ist works without Problems. no defect in the filesystem. If I remove the Cache the boot option are not show.

[QUOTE=Nero FX;2649332]
After 2 Days with the Cache, I become the the boot option “Starthilfe (epfohlen)” [Selected] and “Windows normal starten” on every boot in the last 2 days. The reason is that windows could not be start correctly (Windows konnte nicht werden). Windows shutdown correctly in the Session(s) befor. If I use “Windows normal starten” ist works without Problems. no defect in the filesystem. If I remove the Cache the boot option are not show.[/QUOTE]

Same problem here, only that the problem started on the same day the trial version was installed (yesterday). Windows displays a page with the title “Windows Fehlerbehebung” and says that it could not be started and the reason could be a recent change in hard- or software. It gives the option to go to the recovery menu or to start normally.
If I choose normal start everything works nicely, but I don’t want to have this screen on every start.
If I choose the recovery option and tell windows recovery to correct problems that keep it from starting it tells me that it did not find any problems and windows should be able to boot.
Apparently that is true as it works if I choose to boot normally, but somehow/somewhere a flag is set that configuration has changed.
The problem only occurs when I do a “cold start” after the PC has been turned off, not when I do a restart in the windows start menu without turning the PC off.
There are no problems if I disable caching in VELOSSD.

Stefan

Hello,
the Windows Startmenu showing up with no real reason:
we are investigating this and will post information / fix it.

hi again.
I have the defect filesystem bug again!
This Time Some mkv Files, Downloaded yesterday (I use the file! no Problem with the files befor) and many other smal files deleted by chkdsk. Chkdsk say: “verwaiste Einträge” and delete it from the Index. The files are deleted. Chkdsk has correct the MFT.

I think that die Big, one time used, mkv files are not cached by VeloSSD with only 14Gbyte Cache.

Hello Nero FX,
we have found the reason.
And will release an update that fixes this.
It is also responsible for reduced
cache boot performance.
It may be responsible for the
windows boot menu showing up.
The update will come when testing is satisfactory.
It will be version 2.0.0.9.

Of course we are testing similar scenarios,
right now, making sure all is correct.

Until then you should try letting your computer sleep
instead of powering off.

Kind regards,
Support

and will upload a software

Hi back again with new and known bugs.

  1. Velo SSD say after a normal boot: Please enter a Key-> the 2nd time this bug. first time with Version 2.0.0.8.
  2. After cancel -> VeloSSD say boot failure cache are not used and VeloSSD remove the Cache Volume and closed (not GUI / Dialog) this is not reality! The cache was used (the system boot to fast for HDD only use!)
  3. After this Message I want to start VeloSSD again, after UAC Dialog -> the following dialog popup:

“VeloSSD 2012 läuft bereits auf diesem Rechner im Kontext eines anderen Benutzers…”

this is not the fact! the used Account/User is the only user on this machine!

After a Reboot (HDD only) VeloSSD ask for a Key Again.
-> OK without Key the Message popUp:

EBcreateFileErr:2Das System kann die angegebene Datei nicht finden.
-> OK
next dialog box:

Fehler bei der Verbindungsherstellung zum Gerät! Das Gerät konnte nicht in Betrieb genommen werden.
->OK
next Dialog:
Bei dem versuch das virtuelle Laufwerk zu erzeugen, kam es zu einem Fehler.
–> The GUI popup in the background
next Dialog:
EBcreateFileErr:2Das System kann die angegebene Datei nicht finden.
-> OK
next dialog box:

Fehler bei der Verbindungsherstellung zum gerät! Das Gerät konnte nicht in Betrieb genommen werden.
->OK
next Dialog:
Bei dem versuch das virtuelle Laufwerk zu erzeugen, kam es zu einem Fehler.

Now i see the Gui with the deletet / not working Volume

some stat Pictures after all this:


hi,
quick i´d say you should stop and update to 2.0.0.9.
We need to long time test it before public release.
But it is ready, i can up it and would
you like to try ?