V7.5.9.0: UDF invalid Parameter

Hi,

today I did update to 7.5.9.0
Now I get after “Phase: Create directories” something like
UDF invalid parameter. - I want normal ISO-CD, not UDF.

Width Nero 5.5/6.0/6.6/7.0 it worked fine.
What has changed?

NERO_WRITE_CD writeCD;

writeCD.nwcdIsoTrack = NeroCreateIsoTrackEx(
pIsoItem->subDirFirstItem,
m_Titel, NCITEF_CREATE_ISO_FS|NCITEF_USE_JOLIET);
testUDF1=writeCD.nwcdIsoTrack->BurnUDF(); // returns FALSE

NeroBurn(ndhDeviceHandle,
NERO_ISO_AUDIO_MEDIA,
&writeCD, NBF_WRITE, m_Speed, npProgress);

What is wrong?

Bye, Holger.

After looking in NeroHistory.log some more Information:

The UDF parameters contain illegal values.
(Medium in drive: CD-R. Medium required by compilation: CD-R/RW; DVD R/RW; DVD-RAM.)

bye, Holger.

I’ve found the bug:

It is not a good Idea to use
NERO_MEDIA_TYPE Media=(NERO_MEDIA_TYPE )(MEDIA_CD | MEDIA_DVD_ANY);
in NERO_CD_INFO and NeroGetAvailableDrivesEx.

Bye, Holger.

I have a similar problem.

I get “waiting for a particular media type: unknown” “The UDF parameters contain illegal values” after trying to burn using code that worked fine with Nero 6.

I have just updated to nero 7.9.6 and now get these errors when trying to burn

Code is attached - how can I make this work again?

Mike

nero_code.zip (78 KB)

Its seems the Nero Fiddles example with SDK 1.0.8 also has this problem!!!

This also happens if I choose the image recorder - so it doesn’t seem like a drive / media problem

It seems you cannot mix CD and DVD media types anymore when using Drive.BurnIsoAudioCD function. This must be some bug introduced with newer versions of Nero 7.

More information - mixing of types - e.g. NERO_MEDIA_CDR + NERO_MEDIA_CDRW results in a (different) error after burn is started.

It is now necessary to use NERO_MEDIA_CD and NERO_MEDIA_DVD_ANY (on separate lines (I used option button to select CD or DVD) rather than specify the types manually.

IMO this is a bug - it certainly is a reduction in functionality! And must be fixed!