Using Regedit To Reset Dma

vbimport

#1

“BACKUP YOUR SYSTEM FIRST BEFORE USING REGEDIT”

Please Note using the regedit incorrectly can cause damage and you will have to re-format your system. use at your own risk

If you do not feel comfortable using the Registry Editor you can try Step 1 which has been known to work, if you are comfortable with regedit go to Step 2

STEP 1.)
Set the device that stays stuck in PIO mode to “PIO mode only”. Reboot.
Then reset the device again to Use UDMA if available. Reboot… Wowlah! The hard drive is now in UDMA mode!

STEP 2.)
If deleting the IDE channel and your burner from Device Manager doesn’t help, open the Registry (Start -> Run -> Regedit) and open the following key:

HKEY_LOCAL_MACHINE \ SYSTEM \ CurrentControlSet \ Control \ Class \ {4D36E96A-E325-11CE-BFC1-08002BE10318}

Within this key you will find several subkeys. Most likely you will see the following:

0000 (for the IDE controller)
0001 (for the Primary IDE channel)
0002 (for the Secondary IDE channel)

Each of these subkeys has a named value called “DriverDesc” that will make it clear to you to which component they correspond too.

Open the subkey corresponding to the channel on which your troublesome drive is located.
Then, if the troublesome drive is the master, delete the “MasterIdDataChecksum” named value.

Or, if the troublesome drive is the slave, delete the “SlaveIdDataChecksum” named value.

Reboot. The OS will redetect the device DMA capabilities after reboot.

Note that for many older CD-ROM drives DMA can not be enabled in Windows 2000/XP, so be sure to check the capabilities of your particular drive if you continue to have problems.


#2

StormJumper, this is great information and thanks for pulling this all together.:clap: Good job! I think you left out the warning about how even opening regedit can cause abnormal heart rhythm and excessive armpit sweat (at least for me):bigsmile: .


#3

FUNNY [B]VERY[/B] FUNNY