Using nero 6 and I got a message saying mpeg 4 expired

Hi all I have been using nero 6 and I got a message saying mpeg 4 expired so I downloaded a demo of nero 7 and I still cannot burn some movies to dvd. I have posted the log reports for details. Thank you

I have just looked at g spot and it says
DSH YV12 Nero Digital AVC Video Enc {426F6A6F-FEF8-4A5B-8DDC-099E7499EF50} 0x00200000 ** File Missing:

Can someone enlighten me please and let me know if this is the issue and how I can rectify it. Thank you

Some OEM and demo versions of Nero don’t come with mpeg 4 plugins. Mpeg 4 is Nero Digital format not DVD which is mpeg 2. Try changing the format in Nero Vision to DVD instead of Nero Digital for your output files or just use Nero Express to burn DVDs.

I think they included mpeg4 capabilities on a long term trial (6 months or something like that) with some versions. I’m guessing it was to help push the use of their nero digital format, and that may be why it worked in the past and now you get an expired message. It could be the trial is shorter now or all of them expired on a certain date or something?

Thank you very much for the advice. I have just purchased and installed Nero 7 Ultra Edition and the aforementioned problems seem to be solved.