Using an IDE to USB adapter with Plextor drives

vbimport

#1

I spent some time yesterday hooking up various Plextor IDE drives via an external IDE to USB plug adapter (the type without casing).

I was amazed that plextools would notice and access the drives including all the goodie-features. I then tried the 712A in operation, and here the trouble started!

Here is what I tried to do using Nero(6.6.1.4): I tried to write at 12x, but the burn failed 6% into the track. I tried again (this time at the rear usb2), and it failed again at about 8%. Both times the drive light went green and nero’s progress indication simply halted, time kept counting, no error message occured till my patience run out. One burn failed at 6%, one at 13%. I then did successfully write a DVD+RW @ 4x. I then hooked up the 755 for a dvd+rw at 8x, which burned ok too. Then I created my third coaster by trying an MCC004 at 12x on the 755. That was the price for knowing that it wasn’t a particular problem of the 712.

Then I decided that I had enough coasters on my hand and figured, that I should move my coaster production machinery away from the big PC to my notebook, where it shall be used anyway. From backups, I also know that the USB adapter works faster with the Intel chipset in my notebook than with the Via chipset in the desktop. At first, I checked the write transmission speed using Plextools and the 712A via usb2. Should have done that earlier, cause it reaches only 10.5x. Also, there is a downward spike once 8x is surpassed. These spikes seem to occur every time, once an even write speed is surpassed (8, 10, 12, 14 on the 755), probably PR kicking in.

Then I tried writing an MCC004 @ 6x using the 712A via USB, using Nero. It worked. Then I tried the same setting for 8x. Strangely, the drive wrote only at 6x CLV, whereas even the log stated that 8x is selected. I had PR on, and I have not yet tried it off.

So, aside from passing this information on, I have some unsolved riddles here.
What causes the burn to die above a certain speed? (i.e. AS, BP, PR) And why can’t I burn at 8x, even though I seleced it? Wild guess: only Intel USB tells transmission rate to nero, and nero puts a halt to the kamikazi burn speed? (I am somewhat tempted to select 12x and see, if that only gets done at 6x as well)

Any informed oppinions on what I am doing or should be doing? I just ordered 100 more mcc004, cause I am about to run out of “soon to be coasters”.

Greetings,
ux-3


#2

IDE to USB/1934 bridges and ODDs can be tricky to get to work. My first question would be what make is the bridge chip?

I think older Oxford chips would not allow for faster than 8x because of limited throughput. I’ve got an external exclosure here with Prolifics 3507 chip. Haven’t tried Firewire much but a 712 seems to work solid on USB, same goes for a Premium with the exeption that DAE seems to be limited to 42x (not really an issue for me since i usally encode as i rip). Others have reported the 716 works fine with it.


#3

how are you powering these internal IDE drives when they’re hooked up externally? from what you’ve written it seems you’re not using an external casing, just the IDE>USB adapter.


#4

Bridge chip? I took a look into windows XP but didn’t find it. On the CD, there are drivers for CS881x and GL811, thats all. Is there a simple way to find out?

As far as drives are concerned, I have tried the 24/40/10, the Premium, the 712A, the 716A and the 755A. I get the impression that they all sort of work, but fail above a certain speed or perhaps due to a certain operation caused by BP, PR or AS. It would take a lot of coasters to find out exactly, so I hoped I could gather some information here.

Power: No, I am not frying my notebook :disagree: The adapter came with an external power supply that plugs right into the 4 pin power plug of the drive. And yes, it is rated for 2A on both 5V and 12V.


#5

what specific IDE>USB adapter+power supply are you using? quality brand or generic? even though the external PS is rated for 2A on both rails, some of the issues you’ve describe sound like the drives are underpowered for higher speed burning.


#6

The hardware part that translates USB to IDE (and back). Look here for some nice pictures: http://www.reviews.ru/clause/article.asp?id=930 In this case the USB bridge is an “ALI” chip as seen here: http://www.reviews.ru/clause/hdd/box3/IMG_3284.jpg , there is a dual bridge solution (ALI/Oxford 911) for USB and 1934 (if i interpret this correctly, i don’t speak the langauge) http://www.reviews.ru/clause/hdd/box3/IMG_3287.jpg and a single chip solution (Prolific) for both USB/1934 http://www.reviews.ru/clause/hdd/box3/IMG_3289.jpg and single chip solution by Oxford (922) http://www.reviews.ru/clause/hdd/box3/IMG_3297.jpg

If it doesn’t show in the hardware manager you’ll have to open up whatever it has been built in and look at it.


#7

I am using a noname product. I just completed an 8x burn on the 712A using plextools and deactivated powerrec. By required time and final speed in plextools, it was an 8x burn. I am pretty sure that I can’t write much faster to HDD either, when using this adapter. So perhaps I can get it to burn 8x using Nero if I disable powerec. That would be quite satisfactory to me, since my internal burner is atrocious at 6x and slow as well.

The transfer rate test cuts very abruptly and then levels at about 9x. The read test does the same. If power were the issue, the rate should increase since angular velocity stays constant.


#8

Add on: I just took the 712a back and forth between the desktop and the notebook. I was surprised to see that the read transfer test would go all the way to 12x speed on the desktop, but only to 10x on the notebook, when set to max CPU speed, (9x if set to only high cpu speed) So much for that notion of intel surpassing Via. It seems even more mysterious to me now. The 12x burn on the desktop failed repeatedly very early, long before the drive would reach 8x I guess. I have not yet tried to burn 12x without powerec. When the need for yet another coaster arises, I will try it…


#9

Update:

  1. I solved the usb transfer rate problem on the notebook. The 712A now draws a write speed curve all the way up to 12x. The reason for the previously lower transfer rate must have been bandwith allocation to a usb docking adapter. After unplugging that, the transfer speed does not clip at 10x any more. Further tests with the 755A now show a cliping at 15x write speed.

  2. As a check, I then tested the write speed with the 755A USB’ed to my desktop, where transmission not only clipped but deteriorated. So I took a look on the 755A’s label, and it asks for 2.4 A, which my external power supply can not supply. So I hooked it up to the internal power supply, but the same thing happened. Apparently, the VIA chipset USB quits at 12x.

  3. I do have two other PCI-USB2 cards, based on NEc and ALI, which I could try. Wonder if I should?

greetings
ux-3


#10

SFJI, but the topic is very interesting. I’m waiting for a usb connector for hard discs (including power supply). I don’t want to have to build old hard discs into my pc just to clean them before I give them away. That’s why I ordered one. I don’t know anything about the chip etc. because the connector hasn’t arrived yet. But does it mean that basically I can try it with my Premium, which is hanging around the shelves at the moment?


#11

Yes.


#12

Good news. Thank you.


#13

Update: I successfully burned a 12x using 712A with USB on the notebook. I kept PR off and used the plextools to keep the situation neat. So the problem may be PR, the Via USB chipset or the other USB peripherals on the desktop.


#14

Another step taken: I just successfully burned a 12x DVD+R on the USB-hooked 712A on the formerly troublesome desktop, using Nero 6. As far as I can see, there are only two reasons why it did work now. I had disabled PR and I had disconnected my USB card reader. It will likely cost me a coaster to find out which of these causes the trouble.

happy greetings
ux-3


#15

This older story of the op just happened to me!

I burned an MCC004 at 12x (AS: Off, PowerRec: On, Booktype: +R > -ROM) in order to improve my normally near perfect burns at 16x. As for the first few hundred MBs the disc is burned ok but then suddenly PIEs rise higher and higher and then the disc is unreadable for many hundreds of MBs.

It’s a relief to some degree to read about this situation here, but I’m stilll paniced, since I need to buy new discs tomorrow and can’t burn at the moment to see whether my burner is well :(. Should everything be ok, I still have to hope there was no laser-life wasted during this catastrophy :sad:. I’m overreacting a little because I don’t like the way how much stronger than usual and how a little different than usual the disc smelled after that failed burn.


#16

For anyone interested in using a Plextor DVD recorder in external enclosure I can give the following infos:

After tedious testing with various different external enclosures with different chipsets (Chipsets: Prolific PL-3507, Cypress CY7C68300C, Oxford 911, GL811E-04 - for PATA to USB and/or PATA to FW), my conclusion:

The PX-716 (FW 1.10) will work well in most enclosures (at least with current chipsets). Of course, the better the chipset, the higher the maximum possible write speed. I have been able to get 12x with good results with every chipset I have tried. I never use 16x or 18x (internal or external), only 8x or 12x, for the sake of extra quality reserves.

The PX-760 (FW 1.05), however, appears to be a very different animal. I have not been able to get satisfying burn speeds in any external enclosure (did not try 4x or less, which would be kind of rediculous with a PX-760). Inside my PCs the 760 works extremely well, but not externally. Interestingly, here the chipset used did make a difference in the Write Transfer tests (in some cases it dropped down to 3x for extended periods of time), but it never yielded acceptable results. This could be due to the reduced internal buffer of 2MB or perhaps some limitation put in on purpose by Plexor. Otherwise, I can see no reason why a 760 would not work properly where a 716 does.


#17

Bumping this thread with my own results.

I put my 760A into my 716UF’s case and tried some high speed burns with Nero CD-DVD Speed. I found that the drive will reach about 15x max and then the buffer will bottom out, using either the USB2.0 or the IEEE 1394 interface. It seems to be an inherent problem with the current Plextor drives as YSS had the same issue connecting his 755A externally via a Firewire case.


#18

Some FYI:
712A in an external case with Oxford 911+ on Firewire and Cypress AT2+ for USB 2.0: both interfaces work like a charm.
760A in the same case as above: drive freaks out on Firewire and works great on USB.

I have a Neo case from Dealsonic coming in sometime this week. It has the NEC USB chipset. It’ll be interesting to see how the 760 works in there.


#19

Well, the 716UF case uses an NEC chipset for USB and Epson for Firewire. It’s either a firmware issue or a power issue as the 755A and 760A require 2.4A on DC12V, although the 716UF case’s power supply outputs 3A—I don’t know what the deal is.