Used the Firmware Version 1.UG and same rip speed

I just bought the NEC ND 3520A drive, tested a moive rip using DVD Decrypter, using the stock fimware of 1.04. It took 35 minutes, with a transfer rate of around 2x to 3.7x being the highest.

I flashed the drive using the new modified firmware 1.UG, and rebooted. I tried the same movie again, and it went at the same speed, nothing had changed.

Also I thought the drive was suppose to be loud during the ripping process. I know I chose the NON quiet firmware flash. There were two options:

  1. LD3520 1.UF Quiet Firmware Package
  2. LD3520 1.UF Firmware Package

I chose option 2, no question about it.

What am I doing wrong or is it me?

Thanks
Mike

are your source and destination drives on seperate ide channels?

is dma enabled?

the quiet verson of F/w is if you want to whatch movies, but i agree my 3500 is no were near as noisey as my 1673s even with the fast F/W.

unfornatuley yes, there on the same channel. My secondary IDE port has gone bad or something. It doesn’t recongize anything connected to it anymore.

I guess I need to try it in another computer using the secondary channel set as master.

Thanks
Mike

could just be a dead ide lead, have you tried swaping the ide leads over?

Whats a IDE lead? I’ve tried other cables, no dice.

Anyways, I tried the drive in another computer and setup it up on secondary channel as master, and still the same thing. The highest the transfer rate got using DVD Decrypter was 4.3x then it started going back down, and level out at 3.7x. Took a total of 29 minutes. Just like the others, they all started around 36 minutes and the total time after complete rip was around 29 - 30 minutes. I checked and I’m using Ultra DMA 2 for the Secondary channel, and Ultra DMA 4 for the Primary channel. Are DVD/CD drives limited to only Ultra 2, or can they run at Ultra 4, and if so, how do I change it?

I’m not sure what speeds I should be expecting, but I thought using the modified firmware would make the rip faster then the stock firmware since it turn off riplock, and I’m sorry, I havn’t noticed a difference. If thats fast, well then I should have kept the stock firmware, becasue it was the same speed.

What is a good rip speed when ripping a standard full dvd movie single layer?

What else can I try, I want to get the most out this? I’m glad I tested this before I updated, or I would’ve just assume it was faster.

Mike