USB Problems

vbimport

#1

I have been working on my USB stick today, took it out in correct sequence, however when I came to put it into another computer it says Please insert disk into drive F: the disk is in there, when I click on safely remove hardward it allows me to to this, I have all my data on it, I have a backup but not for the most recent data. Please help I am using Windows XP


#2

Don’t freak out since you know it’s probably not the flash drive but the other PC since it worked on the original PC. You can test it by trying the drive on yet another PC to make sure the drive works.

I have a feeling that the other PC turned off the ‘Plug and Play’ service in Windows. You can reboot the other PC first and try again. If it still doesn’t work, click on Start, Run… Type “services.msc” into the dialog box and look for 'Plug and Play". Double-click on it and make sure it is set to ‘Automatic’. I had ths problem once but it was because one of my USB ports didn’t work. Try a different USB port too.


#3

I am having the same problem… But after rebooting my computer and then trying it in several other computers, I have come to realize the problem is with my flash drive. Does anyone know if there is any way to recover a flash? Everytime I try to open it, it just continually asks if I want to format it first.