USB port dead

Haven’t been here for a while but I have run into a problem that has me at a total loss. I am working on an Acer Aspire x1300 desktop. On the bottom front there are five usb ports. Two on the bottom left, two on the bottom right and one on the top center.

The two on the bottom right work fine as does the one on the top center. The two ports on the bottom left don’t work. When I plug a usb device into one of the ports I get a message that the device is recognized and Device Manager opens showing an unknown device under Universal Serial Bus Controllers. When I click on the unknown device under Device Status there is this message: "Windows has stopped this device because it has reported problems. (Code 43)’. Nothing I try has corrected this problem

If I look under the driver tab in Unknown Device properties and click on Driver Details I get the message "No driver files are required or have been loaded for this device’. . If I click on Update Driver I get the message: “Windows has determined that your driver is up to date”.

I plugged a USB port I have for testing onto the motherboard header and it worked. So what could be the problem.

I would list what I have done to fix the problem but I have tried everything I can find on the internet and couldn’t even begin to remember them all. Thanks.

Forgot to mention that there are four USB ports on the back of the computer and one of them is dead also. And, when a USB device in plugged into this port nothing happens. Not even a message that the USB device is not recognized.

Never mind.

You might try going into the device manager and deleting all of the USB controllers and then rebooting the computer. The machine will rebuild all of the controllers when it re-boots. Now if you have a USB keyboard or mouse they will most like stop working when you delete their controller so you may have to simply power down the machine with the power button to restart it.

Try with a Linux Live CD

Instead of shutting down with the physical power button, one could open the command prompt, and type shutdown /r /t 120. This will cause the computer to shutdown after 120 seconds (two minutes), unless the user subsequently aborts with shutdown /a.


@kemperhils: Also, trying with a GNU/Linux boot disc might also be worth a try (as @zurst aready pointed out). There are plenty on the internet, but I recommend Xubuntu. Open a command terminal in Xubuntu, and type lsusb, and post the results here. That might give you (or us) a clue as to what the problem is.

Pro tip: if you type lsusb > ~/Desktop/lsusb.txt, you’ll get a file on your desktop called lsusb.txt. This is useful for if there are so many USB devices detected that they don’t quite fit on the terminal screen. This file will probably be wiped when you reboot your computer, but you can always log in from Xubuntu and copy/paste the contents of the file before you reboot.