USB Flash drives - problems and possible solutions

Currently I’m having big troubles recovering a Traxdata EZ Drive 2.0 pro 1 GB under Windows XP Pro SP2 and I was searching all around the web for a possible solution. The good thing is that I found many possible ways to bring the drive back to live, the bad is that nothing worked for my drive.

However, I’m for sure not the only one who have problems with such devices and so I thought it’s probably a good idea to create a thread where everyone who has/had problems with such devices can post what he/she has tried.

Don’t care if it has worked or not because that it doesn’t have worked for you doesn’t mean that it doesn’t help others.

In my special case the drive refuses to do anything, it wont let format via Windows XP or the Traxdata format tool. The error message I get is: The device is write protected.

Here what I’ve tried:

1.) Checked the write protection switch of the stick
R.) Write protection is disabled

2.) Tried to format the stick in a different computer
R.) Didn’t work

3.) Tried to format the stick using Windows CMD (start–> run–> cmd)
R.) Didn’t work

4.) Tried to disable the write protection in the registry
How to (found over at techspot)

[quote=“fatbird_from_TechSpot”]

[ul][li]Start > Run > type ‘regedit’ (without the speachmarks) > Enter
[/li][li]Single-click on ‘My Computer’ > File > Export > save it to the Desktop (Always best to have a backup!!)
[/li][li]Go to the following: My Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\StorageDevicePolicies
[/li][li]Double click on the string ‘WriteProtect’ and change the ‘Value Data’ box to ‘0’
[/li][li]Then: File > Export > save somewhere useful as something like ‘StorageDevicePolicies001.reg’
[/li][li]You also need to do this for the strings in any folders called ‘ControlSet**’ ( = any Digit, i.e. 001, 002) – for example: Everything is the same, just change ‘CurrentControlSet’ to ‘ControlSet**’
[/li]My Computer\HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\StorageDevice Policies
[li]Save these to the same place as before as ‘StorageDevicePolicies00
’
[/li][li]The saves are in case it reverts at a later date, just double click (saying ‘yes’ to importing these to the registry) on all of the files and it will all work again![/ul] [/li][/quote]

R.) wasn’t able to find StorageDevicePolicies in the registry

5.) Tried to run chkdsk via Windows CMD
R.) unable to run chkdsk, because file system on the device is RAW

Today, I’ll play around with the Disk Management Tool.

Any other posts and suggestions are highly appreciated.

If StorageDevicePolicies cannot be found, it must be created if you want to try those nice registry hacks :slight_smile:

Thanks, I planned something like this :wink: today

hello, h3rb3i in reguard to yur flash usb stick issue, i dunno if you care about the data on the memory or not but there is a program called media wiper that will wipe the flash media clean of all data and format it automaticaly after that. then all you have to do is put the driver/format file back on there that came with the stick. you can get the program at whitecanyon dot com

hopes this help let me know!
also i think that they do provide a demo for you try it out for free!

Hi bobby2400 and welcome to the forums,

thanks for your suggestion, but I was already able to solve my problem by the use of the following tool: http://www.transcendusa.com/Support/DLCenter/Software/recovery_1002.exe it did it’s job very well.

Anyway, your suggestion is probably the right solution for others with the same problem. :wink:

Hello H3rB3i:
I download Recovery1002 but it can not find the device while my USB Flash is shown on my computer. Can you give a suggestion. Media wiper software costs more than my USB Flash, it does not worth it.
Thanks in advance

I am having a problem with some flashdrives that I recently purchased. I am a part-time karate instructor and over the years I have collected an abundance of instructional videos from various public domain areas on the internet. My plan was to copy these videos onto flash drives and give them to some of my better students. All told I have about 21GB worth of files (about 260 of them).

I bought 30 No-Name 32GB Flash Drives from a vendor in China which was probably a mistake. I have noticed that when I attempt to copy the files from my harddrive to the flashdrive (a process that can take several hours) into 3 primary directories on the flash drive, I notice that the first directory (folder) copies fine, but the 2nd and 3rd directories (folders) when I click on them to open them up to verify the transfer of the data, that almost invariably i get a message that the folder is empty, but when I go back and do a right-click and “properties” on the root directory all 21GB appear to be there, but the subfolder names aren’t listed nor are the filenames there.

Was wondering if anyone else has experienced this type of problem…perhaps I’m not formatting the flash-drive properly, I just don’t know. When I try to execute the same file transfer onto a 32GB HP flashdrive that I’ve owned for years the file transfer goes on without a hitch. Any suggestions? Please PM me or email me at @

Hi and Welcome!

You want to test your new USB sticks with h2testw. Don’t be afraid of the german website (it’s the original source), the user interface of the software can be switched to english.
Depending on the speed of your USB drive, the test will take some time. But there is no way around that.

Michael

Michael,
How do I convert to English? I had 2 years of German in highschool, but that was 44 years ago.

Russ

Sounds like you bought some fake drives: http://reviews.ebay.com/BEWARE-of-FAKE-128GB-256GB-USB-Flash-Drives-on-eBayeBay?ugid=10000000001236200

Tick the “English” option:

To me it sounds like a fake flash drive. :doh: This where a 4GB or smaller USB drive is modified to look like a much larger drive. Any files stored beyond the real capacity will disappear or overwrite existing data.


RMPrepUSb has a Quick Size Test button. It destroys all data on the USB device but tests it much quicker than H2TESTW (though not as thoroughly). It was specifically designed to test for ‘false capacity’ fake USB Flash drives.
Tutorial #53 on the www.rmprepusb.com site explains how to fix write-protected drives and Tutorials 7, 39 and 23 may also be of interest.

Last week, a penpal wrote to complain that a newly purchased PNY-64 stick was really slow.

Gee. So is mine. Then, I read thru the above notes and the commentaries on the websites…

“Fake sticks will usually not have any embossed printing on the metal USB connector…”

Wow. I just noticed. Mine doesn’t. Neither does my friend’s. Hmmm…

I ran the RMPrepUSB “QuickTest” (which offered 2 hours! - that’s quick?!!) but my unit gave “slow write errors after 30 minutes - 25% done” and eventually I cancelled. RMPrep’s prognosis: “7Mb is available for writing.”

64Gb. 7Mb good. Hmmm…

This is getting interesting.

[QUOTE=ChristineBCW;2652923]64Gb. 7Mb good. Hmmm…[/QUOTE] That’s [I]only[/I] 99.99% of the capacity missing, so what are you complaining about?! :stuck_out_tongue:

Truly! [I]Look on the bright side of life…[/I]

The exchange was completed and it has all the same (lack of) markings as before, but I’m copying 4 DVDs worth of VOBs to it now… #3 has completely. If those can be copied back (and play!), then I’ll load in 7 or 8 more and see what happens.

Next step - “does it last overnight?”

Yeah yeah - why press my luck, eh?

I had a dead USB drive - my solution was to plug it into a powered hub with a special AC adapter - and set the power VERY LOW. Transfer took a few hours, but it was worth it!

Hope that helps all.